summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:55:53 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:55:53 +0000
commit4d965fd24fe8b9a3f21ca7edd609fc6bcddec9f4 (patch)
tree710628750dccf441fab73d3dfbcf1046be1cf8d3 /dev-dotnet/pe-format
parentAdding USE=selinux dependency towards selinux-makewhatis$ (diff)
downloadgentoo-2-4d965fd24fe8b9a3f21ca7edd609fc6bcddec9f4.tar.gz
gentoo-2-4d965fd24fe8b9a3f21ca7edd609fc6bcddec9f4.tar.bz2
gentoo-2-4d965fd24fe8b9a3f21ca7edd609fc6bcddec9f4.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-dotnet/pe-format')
-rw-r--r--dev-dotnet/pe-format/ChangeLog7
-rw-r--r--dev-dotnet/pe-format/pe-format-2.9999.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index 24cb436afe83..c000e6680afe 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-dotnet/pe-format
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.40 2012/08/31 09:02:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.41 2012/12/15 12:55:53 mgorny Exp $
+
+*pe-format-2.9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +pe-format-2.9999.ebuild:
+ Import the live ebuild.
31 Aug 2012; Michał Górny <mgorny@gentoo.org> metadata.xml,
pe-format-2.1.1.ebuild:
diff --git a/dev-dotnet/pe-format/pe-format-2.9999.ebuild b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
new file mode 100644
index 000000000000..cd273a2770eb
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.9999.ebuild,v 1.1 2012/12/15 12:55:53 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}2.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils fdo-mime systemd
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://bitbucket.org/mgorny/pe-format2/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}2/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+
+DEPEND="sys-devel/systemd-sdk"
+#endif
+
+src_configure() {
+ systemd_to_myeconfargs
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+
+ fdo-mime_desktop_database_update
+}