summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-07-24 19:59:05 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-07-24 19:59:05 +0000
commit5c66abd0b19d6a9be384a4298c1d2c3c66e6b3ae (patch)
treee513b9e2961de053949b800ead4c91ce87e25c51 /dev-embedded/gpsim
parentKeyword amd64-linux, x86-linux (diff)
downloadgentoo-2-5c66abd0b19d6a9be384a4298c1d2c3c66e6b3ae.tar.gz
gentoo-2-5c66abd0b19d6a9be384a4298c1d2c3c66e6b3ae.tar.bz2
gentoo-2-5c66abd0b19d6a9be384a4298c1d2c3c66e6b3ae.zip
Use prune_libtool_files from eutils.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/gpsim')
-rw-r--r--dev-embedded/gpsim/ChangeLog5
-rw-r--r--dev-embedded/gpsim/gpsim-0.26.1.ebuild15
2 files changed, 12 insertions, 8 deletions
diff --git a/dev-embedded/gpsim/ChangeLog b/dev-embedded/gpsim/ChangeLog
index aabcb73aeeda..7a04e473dc0c 100644
--- a/dev-embedded/gpsim/ChangeLog
+++ b/dev-embedded/gpsim/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-embedded/gpsim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.56 2012/07/21 16:37:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/ChangeLog,v 1.57 2012/07/24 19:59:05 ssuominen Exp $
+
+ 24 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> gpsim-0.26.1.ebuild:
+ Use prune_libtool_files from eutils.
21 Jul 2012; Pacho Ramos <pacho@gentoo.org>
+files/gpsim-0.26.1-glib-single-include.patch,
diff --git a/dev-embedded/gpsim/gpsim-0.26.1.ebuild b/dev-embedded/gpsim/gpsim-0.26.1.ebuild
index 9e98a87ec55c..9ee7bcbfd785 100644
--- a/dev-embedded/gpsim/gpsim-0.26.1.ebuild
+++ b/dev-embedded/gpsim/gpsim-0.26.1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.26.1.ebuild,v 1.3 2012/07/21 16:37:50 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gpsim/gpsim-0.26.1.ebuild,v 1.4 2012/07/24 19:59:05 ssuominen Exp $
EAPI=4
+inherit autotools eutils
-inherit eutils autotools
DESCRIPTION="A simulator for the Microchip PIC microcontrollers"
HOMEPAGE="http://gpsim.sourceforge.net"
SRC_URI="mirror://sourceforge/gpsim/${P}.tar.gz"
@@ -27,9 +27,11 @@ DEPEND="${RDEPEND}
DOCS=(ANNOUNCE AUTHORS ChangeLog HISTORY PROCESSORS README README.MODULES TODO)
src_prepare() {
- epatch "${FILESDIR}/gpsim-0.26.1-glib-single-include.patch"
- epatch "${FILESDIR}/gpsim-0.26.1-gtkextra.patch"
- eautoreconf
+ epatch \
+ "${FILESDIR}"/${P}-glib-single-include.patch \
+ "${FILESDIR}"/${P}-gtkextra.patch
+
+ eautoreconf
}
src_configure() {
@@ -42,6 +44,5 @@ src_install() {
default
use doc && dodoc doc/gpsim.pdf
- # remove useless .la files
- use static-libs || find "${D}" -name '*.la' -exec rm -f '{}' +
+ prune_libtool_files
}