summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2010-09-19 10:16:33 +0000
committerDominik Kapusta <ayoy@gentoo.org>2010-09-19 10:16:33 +0000
commit11c391267c7b650df5d8f3debc0087f023e02541 (patch)
tree5a09445ca61c3ee1beeac20d2ebdd5e8bf76093a /dev-embedded/scratchbox
parentVersion bump. Remove old ebuilds (diff)
downloadgentoo-2-11c391267c7b650df5d8f3debc0087f023e02541.tar.gz
gentoo-2-11c391267c7b650df5d8f3debc0087f023e02541.tar.bz2
gentoo-2-11c391267c7b650df5d8f3debc0087f023e02541.zip
Version bump, remove old versions. Thanks to David King <amigadave@amigadave.com> for reporting (bug #338019).
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/scratchbox')
-rw-r--r--dev-embedded/scratchbox/ChangeLog10
-rw-r--r--dev-embedded/scratchbox/scratchbox-1.0.11.ebuild113
-rw-r--r--dev-embedded/scratchbox/scratchbox-1.0.17.ebuild103
-rw-r--r--dev-embedded/scratchbox/scratchbox-1.0.20.ebuild (renamed from dev-embedded/scratchbox/scratchbox-1.0.16.ebuild)6
4 files changed, 12 insertions, 220 deletions
diff --git a/dev-embedded/scratchbox/ChangeLog b/dev-embedded/scratchbox/ChangeLog
index 6a5f52e69b3a..e575606ed402 100644
--- a/dev-embedded/scratchbox/ChangeLog
+++ b/dev-embedded/scratchbox/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-embedded/scratchbox
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.16 2010/06/29 17:35:55 ayoy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.17 2010/09/19 10:16:33 ayoy Exp $
+
+*scratchbox-1.0.20 (19 Sep 2010)
+
+ 19 Sep 2010; Dominik Kapusta <ayoy@gentoo.org> -scratchbox-1.0.11.ebuild,
+ -scratchbox-1.0.16.ebuild, -scratchbox-1.0.17.ebuild,
+ +scratchbox-1.0.20.ebuild:
+ Version bump, remove old versions. Thanks to David King
+ <amigadave@amigadave.com> for reporting (bug #338019).
*scratchbox-1.0.19 (29 Jun 2010)
diff --git a/dev-embedded/scratchbox/scratchbox-1.0.11.ebuild b/dev-embedded/scratchbox/scratchbox-1.0.11.ebuild
deleted file mode 100644
index 528039fccfd0..000000000000
--- a/dev-embedded/scratchbox/scratchbox-1.0.11.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.11.ebuild,v 1.4 2010/01/18 08:56:50 flameeyes Exp $
-
-inherit eutils
-
-SBOX_GROUP="sbox"
-
-DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
-HOMEPAGE="http://www.scratchbox.org/"
-SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-core-${PV}-i386.tar.gz
- http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-libs-${PV}-i386.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE=""
-
-# Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-TARGET_DIR="/opt/scratchbox"
-
-S=${WORKDIR}/${PN}
-
-src_install() {
- dodir ${TARGET_DIR}
- # doins doesn't work with symlinks, getting "file not found" with doins
- cp -pRP ./* "${D}/${TARGET_DIR}"
- ln -s opt/scratchbox "${D}/scratchbox"
-
- # scratchbox service loader
- newinitd "${FILESDIR}/scratchbox.rc" scratchbox || die "newinitd failed"
-
- # group already created
- echo ${SBOX_GROUP} > "${D}/${TARGET_DIR}/.run_me_first_done"
-}
-
-pkg_preinst() {
- einfo "Creating group sbox"
- enewgroup "${SBOX_GROUP}"
-}
-
-pkg_postinst() {
- elog
- elog "You need to run:"
- elog "\"emerge --config =${CATEGORY}/${PF}\""
- elog "to set permissions right and setup scratchbox and users"
- elog
- elog "For further documentation about how to setup"
- elog "scratchbox for your development needs have a look at"
- elog "http://scratchbox.org/documentation/user/scratchbox-1.0/"
- elog
- elog "Also note that when you reboot you should run:"
- elog "/etc/init.d/scratchbox start"
- elog "before trying to run scratchbox."
- elog "You can also add it to the default runlevel:"
- elog "rc-update add scratchbox default"
- elog
- elog "Type /opt/scratchbox/login to start scratchbox."
- elog
-}
-
-pkg_postrm() {
- elog
- elog "To remove all traces of scratchbox you will need to remove the file"
- elog "/etc/init.d/scratchbox. Don't forget to delete the sbox group."
- elog
-}
-
-pkg_config() {
- if [ `id -u` != "0" ]; then
- ewarn "Must be root to run this"
- die "not root"
- fi
-
- einfo "Do you want to configure scratchbox? [Yes/No]"
- einfo "Note: This will set permissions and copy files from the system into the scratchbox"
- read choice
- echo
- case "$choice" in
- y*|Y*|"")
- "${TARGET_DIR}/sbin/sbox_configure" "no" ${SBOX_GROUP} || die "sbox_configure failed"
- ;;
- *)
- ;;
- esac
-
- mkdir -p "${TARGET_DIR}/scratchbox/users"
-
- while true; do
- einfo "Existing users:"
- einfo $(ls "${TARGET_DIR}/users")
- echo
-
- einfo "Create new user (leaf empty to skip): "
- read newuser
- case "$newuser" in
- "")
- break;
- ;;
- *)
- einfo "Note: users have to be in the '${SBOX_GROUP}' to be able to login into the scratchbox"
- "${TARGET_DIR}/sbin/sbox_adduser" ${newuser} || die "sbox_adduser failed"
- ;;
- esac
- done
-
- einfo "Configuration finished. Make sure you run '/etc/init.d/scratchbox start' before logging in."
-}
diff --git a/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild b/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild
deleted file mode 100644
index 89739e6dca04..000000000000
--- a/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.17.ebuild,v 1.3 2010/01/18 08:56:50 flameeyes Exp $
-
-inherit eutils
-
-SBOX_GROUP="sbox"
-
-DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
-HOMEPAGE="http://www.scratchbox.org/"
-SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-core-${PV}-i386.tar.gz
- http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-libs-${PV}-i386.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-# Stripping BREAKS scratchbox, it runs in a chroot and is pre-stripped when needed (bug #296294)
-RESTRICT="strip"
-
-DEPEND=""
-RDEPEND=""
-
-TARGET_DIR="/opt/scratchbox"
-
-S=${WORKDIR}/${PN}
-
-src_install() {
- dodir ${TARGET_DIR}
- # doins doesn't work with symlinks, getting "file not found" with doins
- cp -pRP ./* "${D}/${TARGET_DIR}"
- ln -s opt/scratchbox "${D}/scratchbox"
-
- # scratchbox service loader
- newinitd "${FILESDIR}/scratchbox.rc" scratchbox || die "newinitd failed"
-
- # group already created
- echo ${SBOX_GROUP} > "${D}/${TARGET_DIR}/.run_me_first_done"
-}
-
-pkg_preinst() {
- einfo "Creating group sbox"
- enewgroup "${SBOX_GROUP}"
-}
-
-pkg_postinst() {
- "${TARGET_DIR}/sbin/sbox_configure" "no" ${SBOX_GROUP}
-
- elog
- elog "You can run:"
- elog "\"emerge --config =${CATEGORY}/${PF}\""
- elog "to setup scratchbox users"
- elog
- elog "For further documentation about how to setup"
- elog "scratchbox for your development needs have a look at"
- elog "http://scratchbox.org/documentation/user/scratchbox-1.0/"
- elog
- elog "Also note that when you reboot you should run:"
- elog "/etc/init.d/scratchbox start"
- elog "before trying to run scratchbox."
- elog "You can also add it to the default runlevel:"
- elog "rc-update add scratchbox default"
- elog
- elog "Type /opt/scratchbox/login to start scratchbox."
- elog
-}
-
-pkg_postrm() {
- elog
- elog "To remove all traces of scratchbox you will need to remove the file"
- elog "/etc/init.d/scratchbox. Don't forget to delete the sbox group."
- elog
-}
-
-pkg_config() {
- if [ `id -u` != "0" ]; then
- ewarn "Must be root to run this"
- die "not root"
- fi
-
- mkdir -p "${TARGET_DIR}/users"
-
- while true; do
- einfo "Existing users:"
- einfo $(ls "${TARGET_DIR}/users")
- echo
-
- einfo "Create new user (leaf empty to skip): "
- read newuser
- case "$newuser" in
- "")
- break;
- ;;
- *)
- einfo "Note: users have to be in the '${SBOX_GROUP}' to be able to login into the scratchbox"
- "${TARGET_DIR}/sbin/sbox_adduser" ${newuser} || die "sbox_adduser failed"
- ;;
- esac
- done
-
- einfo "Configuration finished. Make sure you run '/etc/init.d/scratchbox start' before logging in."
-}
diff --git a/dev-embedded/scratchbox/scratchbox-1.0.16.ebuild b/dev-embedded/scratchbox/scratchbox-1.0.20.ebuild
index 5be85a12cfc1..9f2d1b28ac9c 100644
--- a/dev-embedded/scratchbox/scratchbox-1.0.16.ebuild
+++ b/dev-embedded/scratchbox/scratchbox-1.0.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.16.ebuild,v 1.5 2010/01/18 08:56:50 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.20.ebuild,v 1.1 2010/09/19 10:16:33 ayoy Exp $
inherit eutils
@@ -8,8 +8,8 @@ SBOX_GROUP="sbox"
DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
HOMEPAGE="http://www.scratchbox.org/"
-SRC_URI="http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-core-${PV}-i386.tar.gz
- http://scratchbox.org/download/files/sbox-releases/stable/tarball/scratchbox-libs-${PV}-i386.tar.gz"
+SRC_URI="http://scratchbox.org/download/files/sbox-releases/hathor/tarball/scratchbox-core-${PV}-i386.tar.gz
+ http://scratchbox.org/download/files/sbox-releases/hathor/tarball/scratchbox-libs-${PV}-i386.tar.gz"
LICENSE="GPL-2"
SLOT="0"