summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2009-05-06 20:31:39 +0000
committerOlivier Crête <tester@gentoo.org>2009-05-06 20:31:39 +0000
commitdef8f84476f6fcd20b9b84017cd1170b3ca7c4a8 (patch)
treee67a3d270a8f3fe3f492bbe34289e38a93a2a42d /dev-embedded/scratchbox
parentVersion bump (diff)
downloadgentoo-2-def8f84476f6fcd20b9b84017cd1170b3ca7c4a8.tar.gz
gentoo-2-def8f84476f6fcd20b9b84017cd1170b3ca7c4a8.tar.bz2
gentoo-2-def8f84476f6fcd20b9b84017cd1170b3ca7c4a8.zip
Fix permissions in postinst
(Portage version: 2.1.6.11/cvs/Linux i686)
Diffstat (limited to 'dev-embedded/scratchbox')
-rw-r--r--dev-embedded/scratchbox/ChangeLog8
-rw-r--r--dev-embedded/scratchbox/scratchbox-1.0.14.ebuild20
2 files changed, 12 insertions, 16 deletions
diff --git a/dev-embedded/scratchbox/ChangeLog b/dev-embedded/scratchbox/ChangeLog
index e7c025006688..f6cee771423d 100644
--- a/dev-embedded/scratchbox/ChangeLog
+++ b/dev-embedded/scratchbox/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-embedded/scratchbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.2 2009/05/06 20:23:32 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.3 2009/05/06 20:31:39 tester Exp $
+
+ 06 May 2009; Olivier Crête <tester@gentoo.org> scratchbox-1.0.14.ebuild:
+ Fix permissions in postinst
+
+ 06 May 2009; Olivier Crête <tester@gentoo.org> scratchbox-1.0.14.ebuild:
+ Set the permissions in postinst
*scratchbox-1.0.14 (06 May 2009)
diff --git a/dev-embedded/scratchbox/scratchbox-1.0.14.ebuild b/dev-embedded/scratchbox/scratchbox-1.0.14.ebuild
index 958451f806c1..5b4603f118f2 100644
--- a/dev-embedded/scratchbox/scratchbox-1.0.14.ebuild
+++ b/dev-embedded/scratchbox/scratchbox-1.0.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.14.ebuild,v 1.1 2009/05/06 20:23:32 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-1.0.14.ebuild,v 1.2 2009/05/06 20:31:39 tester Exp $
inherit eutils
@@ -43,10 +43,12 @@ pkg_preinst() {
}
pkg_postinst() {
+ "${TARGET_DIR}/sbin/sbox_configure" "no" ${SBOX_GROUP}
+
elog
- elog "You need to run:"
+ elog "You can run:"
elog "\"emerge --config =${CATEGORY}/${PF}\""
- elog "to set permissions right and setup scratchbox and users"
+ elog "to setup scratchbox users"
elog
elog "For further documentation about how to setup"
elog "scratchbox for your development needs have a look at"
@@ -75,18 +77,6 @@ pkg_config() {
die "not root"
fi
- einfo "Do you want to configure scratchbox? [Yes/No]"
- einfo "Note: This will set permissions and copy files from the system into the scratchbox"
- read choice
- echo
- case "$choice" in
- y*|Y*|"")
- "${TARGET_DIR}/sbin/sbox_configure" "no" ${SBOX_GROUP} || die "sbox_configure failed"
- ;;
- *)
- ;;
- esac
-
mkdir -p "${TARGET_DIR}/scratchbox/users"
while true; do