summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2014-05-09 20:46:43 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2014-05-09 20:46:43 +0000
commit04b3fac466530590507d5edf53449821866339ba (patch)
tree2b4335d216a36dabf76bb26cdf2700c9402c8ce3 /dev-embedded
parentAdd ruby21 target. (diff)
downloadgentoo-2-04b3fac466530590507d5edf53449821866339ba.tar.gz
gentoo-2-04b3fac466530590507d5edf53449821866339ba.tar.bz2
gentoo-2-04b3fac466530590507d5edf53449821866339ba.zip
Version bump. Bump jimtcl dependency to 0.75
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 09BF4F54C2BA7F3C!)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/openocd/ChangeLog9
-rw-r--r--dev-embedded/openocd/files/openocd-0.8.0-jimtcl-0.75.patch66
-rw-r--r--dev-embedded/openocd/openocd-0.8.0.ebuild (renamed from dev-embedded/openocd/openocd-0.8.0_rc2.ebuild)8
-rw-r--r--dev-embedded/openocd/openocd-9999.ebuild4
4 files changed, 82 insertions, 5 deletions
diff --git a/dev-embedded/openocd/ChangeLog b/dev-embedded/openocd/ChangeLog
index 6e20434f512e..98cd88995dd0 100644
--- a/dev-embedded/openocd/ChangeLog
+++ b/dev-embedded/openocd/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-embedded/openocd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/openocd/ChangeLog,v 1.49 2014/05/04 10:42:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/openocd/ChangeLog,v 1.50 2014/05/09 20:46:43 hwoarang Exp $
+
+*openocd-0.8.0 (09 May 2014)
+
+ 09 May 2014; Markos Chandras <hwoarang@gentoo.org>
+ +files/openocd-0.8.0-jimtcl-0.75.patch, +openocd-0.8.0.ebuild,
+ -openocd-0.8.0_rc2.ebuild, openocd-9999.ebuild:
+ Version bump. Bump jimtcl dependency to 0.75
04 May 2014; Markos Chandras <hwoarang@gentoo.org> metadata.xml,
openocd-0.8.0_rc2.ebuild, openocd-9999.ebuild:
diff --git a/dev-embedded/openocd/files/openocd-0.8.0-jimtcl-0.75.patch b/dev-embedded/openocd/files/openocd-0.8.0-jimtcl-0.75.patch
new file mode 100644
index 000000000000..1791cabc66fb
--- /dev/null
+++ b/dev-embedded/openocd/files/openocd-0.8.0-jimtcl-0.75.patch
@@ -0,0 +1,66 @@
+Apply upstream patch for jimtcl-0.75 compatibility
+
+X-Gentoo-Bug: 509902
+X-Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=509902
+Link: http://repo.or.cz/w/openocd.git/commitdiff/92ea548aafee840e1507306a3ffb38625f427ec5
+
+Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
+
+From 92ea548aafee840e1507306a3ffb38625f427ec5 Mon Sep 17 00:00:00 2001
+From: Paul Fertser <fercerpav@gmail.com>
+Date: Mon, 28 Apr 2014 14:34:47 +0400
+Subject: [PATCH] Update to the current Jim Tcl
+
+This is a post-release version but hopefully some fixes that went in
+are worth it; also the changes here make OpenOCD compatible with stock
+0.75 version if a distro maintainer decides to use it.
+
+Change-Id: I7ad1814c7c4868198475cdca4750c3d0ee4f5f8b
+Signed-off-by: Paul Fertser <fercerpav@gmail.com>
+Reviewed-on: http://openocd.zylin.com/2121
+Tested-by: jenkins
+Reviewed-by: Freddie Chopin <freddie.chopin@gmail.com>
+---
+ jimtcl | 2 +-
+ src/helper/command.c | 2 +-
+ src/helper/command.h | 4 ++--
+ 3 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/src/helper/command.c b/src/helper/command.c
+index 21362a6..137ac7e 100644
+--- a/src/helper/command.c
++++ b/src/helper/command.c
+@@ -365,7 +365,7 @@ static int register_command_handler(struct command_context *cmd_ctx,
+
+ LOG_DEBUG("registering '%s'...", ocd_name);
+
+- Jim_CmdProc func = c->handler ? &script_command : &command_unknown;
++ Jim_CmdProc *func = c->handler ? &script_command : &command_unknown;
+ int retval = Jim_CreateCommand(interp, ocd_name, func, c, NULL);
+ free(ocd_name);
+ if (JIM_OK != retval)
+diff --git a/src/helper/command.h b/src/helper/command.h
+index 0f0edbb..0eda5b5 100644
+--- a/src/helper/command.h
++++ b/src/helper/command.h
+@@ -168,7 +168,7 @@ struct command {
+ struct command *parent;
+ struct command *children;
+ command_handler_t handler;
+- Jim_CmdProc jim_handler;
++ Jim_CmdProc *jim_handler;
+ void *jim_handler_data;
+ enum command_mode mode;
+ struct command *next;
+@@ -204,7 +204,7 @@ char *command_name(struct command *c, char delim);
+ struct command_registration {
+ const char *name;
+ command_handler_t handler;
+- Jim_CmdProc jim_handler;
++ Jim_CmdProc *jim_handler;
+ void *jim_handler_data;
+ enum command_mode mode;
+ const char *help;
+--
+1.7.6.6.GIT
+
diff --git a/dev-embedded/openocd/openocd-0.8.0_rc2.ebuild b/dev-embedded/openocd/openocd-0.8.0.ebuild
index fb6b42f8e77e..3b3eb2727e89 100644
--- a/dev-embedded/openocd/openocd-0.8.0_rc2.ebuild
+++ b/dev-embedded/openocd/openocd-0.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/openocd/openocd-0.8.0_rc2.ebuild,v 1.3 2014/05/04 10:42:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/openocd/openocd-0.8.0.ebuild,v 1.1 2014/05/09 20:46:43 hwoarang Exp $
EAPI="5"
@@ -27,7 +27,7 @@ SLOT="0"
IUSE="cmsis-dap dummy ftdi parport +usb verbose-io"
RESTRICT="strip" # includes non-native binaries
-RDEPEND=">=dev-lang/jimtcl-0.73
+RDEPEND=">=dev-lang/jimtcl-0.75
cmsis-dap? ( dev-libs/hidapi )
usb? (
virtual/libusb:0
@@ -41,6 +41,10 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch_user
+ # jimtcl-0.75 compatibility. Remove it on the
+ # next version bump
+ epatch "${FILESDIR}"/${P}-jimtcl-0.75.patch
+
if [[ ${PV} == "9999" ]] ; then
AT_NO_RECURSIVE=yes eautoreconf
fi
diff --git a/dev-embedded/openocd/openocd-9999.ebuild b/dev-embedded/openocd/openocd-9999.ebuild
index 2887231ebb1f..754066cefccd 100644
--- a/dev-embedded/openocd/openocd-9999.ebuild
+++ b/dev-embedded/openocd/openocd-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/openocd/openocd-9999.ebuild,v 1.35 2014/05/04 10:42:51 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/openocd/openocd-9999.ebuild,v 1.36 2014/05/09 20:46:43 hwoarang Exp $
EAPI="5"
@@ -27,7 +27,7 @@ SLOT="0"
IUSE="cmsis-dap dummy ftdi parport +usb verbose-io"
RESTRICT="strip" # includes non-native binaries
-RDEPEND=">=dev-lang/jimtcl-0.73
+RDEPEND=">=dev-lang/jimtcl-0.75
cmsis-dap? ( dev-libs/hidapi )
usb? (
virtual/libusb:0