summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-02-01 06:23:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-02-01 06:23:08 +0000
commit0061f69895e553cef4b76b0d546d5e43efa50e12 (patch)
tree0a39ea0269c6214231342ef636246e2ff374fe1a /dev-games/ggz-client-libs
parentRestored ~ppc and ~ppc64 keywords to KDE-4.2.0 (diff)
downloadgentoo-2-0061f69895e553cef4b76b0d546d5e43efa50e12.tar.gz
gentoo-2-0061f69895e553cef4b76b0d546d5e43efa50e12.tar.bz2
gentoo-2-0061f69895e553cef4b76b0d546d5e43efa50e12.zip
add patch from Michael Edenfield to apply the DESTDIR string correctly (bug #237607)
(Portage version: 2.1.6.4/cvs/Linux 2.6.28.1 i686)
Diffstat (limited to 'dev-games/ggz-client-libs')
-rw-r--r--dev-games/ggz-client-libs/ChangeLog10
-rw-r--r--dev-games/ggz-client-libs/files/ggz-client-libs-0.0.14.1-destdir.patch34
-rw-r--r--dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild5
3 files changed, 45 insertions, 4 deletions
diff --git a/dev-games/ggz-client-libs/ChangeLog b/dev-games/ggz-client-libs/ChangeLog
index 44491ca77b34..d5460aedaa05 100644
--- a/dev-games/ggz-client-libs/ChangeLog
+++ b/dev-games/ggz-client-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/ggz-client-libs
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ggz-client-libs/ChangeLog,v 1.28 2008/11/13 19:46:25 ranger Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ggz-client-libs/ChangeLog,v 1.29 2009/02/01 06:23:08 mr_bones_ Exp $
+
+ 01 Feb 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ggz-client-libs-0.0.14.1-destdir.patch,
+ ggz-client-libs-0.0.14.1.ebuild:
+ add patch from Michael Edenfield to apply the DESTDIR string correctly (bug
+ #237607)
13 Nov 2008; Brent Baude <ranger@gentoo.org>
ggz-client-libs-0.0.14.1.ebuild:
diff --git a/dev-games/ggz-client-libs/files/ggz-client-libs-0.0.14.1-destdir.patch b/dev-games/ggz-client-libs/files/ggz-client-libs-0.0.14.1-destdir.patch
new file mode 100644
index 000000000000..1592e19b0927
--- /dev/null
+++ b/dev-games/ggz-client-libs/files/ggz-client-libs-0.0.14.1-destdir.patch
@@ -0,0 +1,34 @@
+--- ggz-client-libs-0.0.14.1/ggz-config/ggz-config.c.orig 2008-01-05 14:02:46.000000000 -0500
++++ ggz-client-libs-0.0.14.1/ggz-config/ggz-config.c 2008-11-11 15:48:51.000000000 -0500
+@@ -452,12 +452,14 @@
+ {
+ char *suffix = ".module.dsc";
+ char global_pathname[(moddest ? strlen(destdir) : 0)
+- + strlen(copydir)
++ + strlen(copydir) + 2];
++ char full_pathname[strlen(global_pathname)
+ + strlen(modname)
+- + strlen(suffix) + 3];
++ + strlen(suffix) + 2];
+ char fixedmodname[strlen(modname) + 1];
+ unsigned int i;
+
++
+ if(moddest)
+ sprintf(global_pathname, "%s/%s", destdir, copydir);
+ else
+@@ -473,10 +475,11 @@
+ for(i = 0; i < strlen(fixedmodname); i++) {
+ if(fixedmodname[i] == '/') fixedmodname[i] = '_';
+ }
+- sprintf(global_pathname, "%s/%s%s", global_pathname, fixedmodname, suffix);
+
+- printf(_("Preserving %s as %s...\n"), modfile, global_pathname);
+- return filecopy(modfile, global_pathname);
++ sprintf(full_pathname, "%s/%s%s", global_pathname, fixedmodname, suffix);
++
++ printf(_("Preserving %s as %s...\n"), modfile, full_pathname);
++ return filecopy(modfile, full_pathname);
+ }
+
+
diff --git a/dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild b/dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild
index ef24ae7f1e7e..669eb7b46587 100644
--- a/dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild
+++ b/dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild,v 1.9 2008/11/13 19:46:25 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ggz-client-libs/ggz-client-libs-0.0.14.1.ebuild,v 1.10 2009/02/01 06:23:08 mr_bones_ Exp $
inherit games-ggz
@@ -16,3 +16,4 @@ RDEPEND="~dev-games/libggz-${PV}
virtual/libintl"
DEPEND="${RDEPEND}
sys-devel/gettext"
+PATCHES=( "${FILESDIR}"/${P}-destdir.patch )