summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-10-14 11:29:13 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-10-14 11:29:13 +0000
commitac65cdea428ea3e5181f69826b034966a0f251cc (patch)
tree14447aa1252f10f977926738daa30bd0a17ee733 /dev-games/irrlicht
parentRemove swtaylor from metadata.xml due to retiring. (diff)
downloadgentoo-2-ac65cdea428ea3e5181f69826b034966a0f251cc.tar.gz
gentoo-2-ac65cdea428ea3e5181f69826b034966a0f251cc.tar.bz2
gentoo-2-ac65cdea428ea3e5181f69826b034966a0f251cc.zip
Fix jpeg library mismatch and demo Makefile. Bug #148593
(Portage version: 2.1.1)
Diffstat (limited to 'dev-games/irrlicht')
-rw-r--r--dev-games/irrlicht/ChangeLog8
-rw-r--r--dev-games/irrlicht/files/digest-irrlicht-1.1-r13
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch14
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch21
-rw-r--r--dev-games/irrlicht/irrlicht-1.1-r1.ebuild72
5 files changed, 117 insertions, 1 deletions
diff --git a/dev-games/irrlicht/ChangeLog b/dev-games/irrlicht/ChangeLog
index 1d83c41ace06..d7a8515d37b4 100644
--- a/dev-games/irrlicht/ChangeLog
+++ b/dev-games/irrlicht/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/irrlicht
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.18 2006/09/16 11:29:59 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.19 2006/10/14 11:29:13 tupone Exp $
+
+*irrlicht-1.1-r1 (14 Oct 2006)
+
+ 14 Oct 2006; <tupone@gentoo.org> +files/irrlicht-1.1-demoMake.patch,
+ +files/irrlicht-1.1-jpeg.patch, +irrlicht-1.1-r1.ebuild:
+ Fix jpeg library mismatch and demo Makefile. Bug #148593 by Jesper Saxtorph
*irrlicht-1.1 (16 Sep 2006)
diff --git a/dev-games/irrlicht/files/digest-irrlicht-1.1-r1 b/dev-games/irrlicht/files/digest-irrlicht-1.1-r1
new file mode 100644
index 000000000000..905f5ed5b361
--- /dev/null
+++ b/dev-games/irrlicht/files/digest-irrlicht-1.1-r1
@@ -0,0 +1,3 @@
+MD5 c2a3606e037213555e7891f0433fa98a irrlicht-1.1.zip 15647723
+RMD160 1469ade750699b12244e0f38ea07e6a4314e696c irrlicht-1.1.zip 15647723
+SHA256 6ef74629d33b4f2cb2faa91d81cbd0f591ebce620ebfae8e4fd3fb71f1137f19 irrlicht-1.1.zip 15647723
diff --git a/dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch b/dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch
new file mode 100644
index 000000000000..56de8ca5c8e8
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.1-demoMake.patch
@@ -0,0 +1,14 @@
+--- ../../examples/Demo/Makefile.old 2006-10-14 13:06:42.000000000 +0200
++++ ../../examples/Demo/Makefile 2006-10-14 13:08:32.000000000 +0200
+@@ -2,9 +2,9 @@
+ # Handwritten by me, made with Kate. So it is far from being perfect. :)
+
+ CXX = g++
+-CPPFLAGS = -I"../../include" -I"/usr/X11R6/include"
++CPPFLAGS = -I/usr/include/irrlicht
+ CXXFLAGS = -O3 -ffast-math
+-LDFLAGS = -L"/usr/X11R6/lib" -L"../../lib/Linux" -lIrrlicht -lGL -lGLU -lXxf86vm -lXext -lX11
++LDFLAGS = -lIrrlicht -lGL -lGLU -lXxf86vm -lXext -lX11 -lpng -ljpeg
+ # if you enable sound add the proper library for linking
+ # -laudiere
+ # -lSDL_mixer -lSDL
diff --git a/dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch b/dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch
new file mode 100644
index 000000000000..0097aa28839c
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.1-jpeg.patch
@@ -0,0 +1,21 @@
+--- CImageLoaderJPG.h.old 2006-10-14 12:18:56.000000000 +0200
++++ CImageLoaderJPG.h 2006-10-14 12:19:55.000000000 +0200
+@@ -12,8 +12,6 @@
+ #include "IrrCompileConfig.h"
+ #ifdef _IRR_COMPILE_WITH_LIBJPEG_
+ extern "C" {
+- #include "jpeglib/jconfig.h"
+- #define JCONFIG_INCLUDED
+ #ifndef _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #include <jpeglib.h> // use system lib
+ #else // _IRR_USE_NON_SYSTEM_JPEG_LIB_
+--- CImageWriterJPG.cpp.old 2006-10-14 12:20:14.000000000 +0200
++++ CImageWriterJPG.cpp 2006-10-14 12:20:35.000000000 +0200
+@@ -10,7 +10,6 @@
+ #ifdef _IRR_COMPILE_WITH_LIBJPEG_
+ extern "C"
+ {
+- #include "jpeglib/jconfig.h"
+ #ifndef _IRR_USE_NON_SYSTEM_JPEG_LIB_
+ #include <jpeglib.h>
+ #include <jerror.h>
diff --git a/dev-games/irrlicht/irrlicht-1.1-r1.ebuild b/dev-games/irrlicht/irrlicht-1.1-r1.ebuild
new file mode 100644
index 000000000000..bdb7ad2b5134
--- /dev/null
+++ b/dev-games/irrlicht/irrlicht-1.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.1-r1.ebuild,v 1.1 2006/10/14 11:29:13 tupone Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="open source high performance realtime 3D engine written in C++"
+HOMEPAGE="http://irrlicht.sourceforge.net/"
+SRC_URI="mirror://sourceforge/irrlicht/${P}.zip"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND="media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ virtual/opengl
+ virtual/glu
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ x11-proto/xproto
+ x11-proto/xf86vidmodeproto"
+
+S=${WORKDIR}/${P}/source/Irrlicht
+
+src_unpack() {
+ unpack ${A}
+ cd "${WORKDIR}"/${P}
+ edos2unix source/Irrlicht/CSceneManager.h \
+ include/IrrCompileConfig.h
+ epatch "${FILESDIR}"/${P}-gcc41.patch \
+ "${FILESDIR}/"${P}-config.patch
+ cd "${S}"
+
+ edos2unix CImageLoaderJPG.h \
+ CImageWriterJPG.cpp \
+ ../../examples/Demo/Makefile
+ epatch "${FILESDIR}/"${P}-jpeg.patch \
+ "${FILESDIR}/"${P}-demoMake.patch
+
+ # stupid nvidia / xorg GL differences
+ # still needed - bug #114335
+ if echo -e '#include <GL/glx.h>\nglXGetProcAddress blah;' | \
+ $(tc-getCC) -E - | \
+ grep -q glXGetProcAddressARB
+ then
+ epatch "${FILESDIR}"/${PN}-0.12.0-opengl.patch
+ fi
+
+ # use the system zlib/jpeg/png
+ sed -i -r \
+ -e '/^CXXFLAGS/s:=:+=:' \
+ -e '/^CXXINCS/s:-Izlib -Ijpeglib -Ilibpng::' \
+ -e '/^ZLIBOBJ/d' \
+ -e '/^JPEGLIBOBJ/d' \
+ -e '/^LIBPNGOBJ/d' \
+ Makefile || die "sed objs"
+}
+
+src_install() {
+ cd ../..
+ dolib.a lib/Linux/libIrrlicht.a || die "dolib.a failed"
+ insinto /usr/include/${PN}
+ doins include/* || die "doins failed"
+ dodoc changes.txt readme.txt
+ if use doc ; then
+ cp -r examples media "${D}"/usr/share/doc/${PF}/ || die "cp failed"
+ fi
+}