summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2007-07-19 18:25:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2007-07-19 18:25:43 +0000
commitd84e579db87505601554de36037c971dc6c5bd76 (patch)
tree21c6395bd702f54158359a016fac0653f18b0308 /dev-games/ogre
parentalpha/ia64/x86 stable wrt security #184934 (diff)
downloadgentoo-2-d84e579db87505601554de36037c971dc6c5bd76.tar.gz
gentoo-2-d84e579db87505601554de36037c971dc6c5bd76.tar.bz2
gentoo-2-d84e579db87505601554de36037c971dc6c5bd76.zip
version bump
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-games/ogre')
-rw-r--r--dev-games/ogre/ChangeLog8
-rw-r--r--dev-games/ogre/files/digest-ogre-1.4.33
-rw-r--r--dev-games/ogre/files/ogre-1.4.3-cegui.patch19
-rw-r--r--dev-games/ogre/ogre-1.4.3.ebuild94
4 files changed, 123 insertions, 1 deletions
diff --git a/dev-games/ogre/ChangeLog b/dev-games/ogre/ChangeLog
index fe4ec176f789..98d1011125fb 100644
--- a/dev-games/ogre/ChangeLog
+++ b/dev-games/ogre/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/ogre
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.39 2007/06/13 11:55:15 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ChangeLog,v 1.40 2007/07/19 18:25:43 mr_bones_ Exp $
+
+*ogre-1.4.3 (19 Jul 2007)
+
+ 19 Jul 2007; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/ogre-1.4.3-cegui.patch, +ogre-1.4.3.ebuild:
+ version bump
*ogre-1.4.2 (13 Jun 2007)
diff --git a/dev-games/ogre/files/digest-ogre-1.4.3 b/dev-games/ogre/files/digest-ogre-1.4.3
new file mode 100644
index 000000000000..ec3bf0da2427
--- /dev/null
+++ b/dev-games/ogre/files/digest-ogre-1.4.3
@@ -0,0 +1,3 @@
+MD5 d184bfbc1dd7cbc56aef419171699da6 ogre-linux_osx-v1-4-3.tar.bz2 28642728
+RMD160 ad279ef2e4b4f6f4ef7f139fe6b9a0e65f9a568a ogre-linux_osx-v1-4-3.tar.bz2 28642728
+SHA256 a609f4da17b38578e0b45f95d390782195b287d141db5ee599f683e2c0349138 ogre-linux_osx-v1-4-3.tar.bz2 28642728
diff --git a/dev-games/ogre/files/ogre-1.4.3-cegui.patch b/dev-games/ogre/files/ogre-1.4.3-cegui.patch
new file mode 100644
index 000000000000..c089164af219
--- /dev/null
+++ b/dev-games/ogre/files/ogre-1.4.3-cegui.patch
@@ -0,0 +1,19 @@
+--- acinclude.m4
++++ acinclude.m4
+@@ -411,6 +411,8 @@
+ ])
+
+ AC_DEFUN([OGRE_CHECK_CEGUI], [
++ AC_ARG_ENABLE(cegui)
++ if test x$enable_cegui != xno; then
+ PKG_CHECK_MODULES(CEGUI, CEGUI >= 0.5.0,
+ [build_cegui_sample=true], [build_cegui_sample=false])
+ if test x$build_cegui_sample = xtrue; then
+@@ -426,6 +428,7 @@
+ else
+ AC_MSG_RESULT([CEGUI not available, Gui and FacialAnimation samples will not be built])
+ fi
++ fi
+ AM_CONDITIONAL([HAVE_CEGUI], [test x$build_cegui_sample = xtrue])
+ ])
+
diff --git a/dev-games/ogre/ogre-1.4.3.ebuild b/dev-games/ogre/ogre-1.4.3.ebuild
new file mode 100644
index 000000000000..d8e045d4cf20
--- /dev/null
+++ b/dev-games/ogre/ogre-1.4.3.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-1.4.3.ebuild,v 1.1 2007/07/19 18:25:43 mr_bones_ Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="Object-oriented Graphics Rendering Engine"
+HOMEPAGE="http://www.ogre3d.org/"
+SRC_URI="mirror://sourceforge/ogre/ogre-linux_osx-v${PV//./-}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc cegui cg devil double-precision examples freeimage gtk openexr threads"
+RESTRICT="test" #139905
+
+RDEPEND="dev-libs/zziplib
+ >=media-libs/freetype-2.1.10
+ virtual/opengl
+ virtual/glu
+ x11-libs/libXt
+ x11-libs/libXaw
+ x11-libs/libXrandr
+ x11-libs/libX11
+ cegui? ( >=dev-games/cegui-0.5 )
+ cg? ( media-gfx/nvidia-cg-toolkit )
+ devil? ( media-libs/devil )
+ freeimage? ( media-libs/freeimage )
+ gtk? (
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libglademm-2.4
+ )
+ openexr? ( >=media-libs/openexr-1.2 )
+ threads? ( dev-libs/boost )"
+DEPEND="${RDEPEND}
+ x11-proto/xf86vidmodeproto
+ dev-util/pkgconfig"
+
+S=${WORKDIR}/ogrenew
+
+pkg_setup() {
+ if use threads && has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use dev-libs/boost threads
+ then
+ die "Please emerge dev-libs/boost with USE=threads"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find -name CVS -print0 | xargs -0 rm -rf
+ if use examples ; then
+ cp -r Samples install-examples || die
+ find install-examples \
+ '(' -name 'Makefile*' -o -name obj -o \
+ -name bin -o -name '*.cbp' -o -name '*.vcproj*' ')' \
+ -print0 | xargs -0 rm -rf
+ fi
+ sed -i '/CPPUNIT/d' configure.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-cegui.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --disable-dependency-tracking \
+ --disable-ogre-demos \
+ --enable-static \
+ --with-platform=GLX \
+ --with-gui=$(usev gtk || echo Xt) \
+ $(use_enable cegui) \
+ $(use_enable cg) \
+ $(use_enable devil) \
+ $(use_enable double-precision double) \
+ $(use_enable freeimage) \
+ $(use_enable openexr) \
+ $(use_enable threads threading) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html
+ doins -r Docs/* || die "doins Docs failed"
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/Samples
+ doins -r install-examples/* || die "doins Samples failed"
+ fi
+ dodoc AUTHORS BUGS LINUX.DEV README
+}