summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2014-11-14 16:45:28 +0000
committerJulian Ospald <hasufell@gentoo.org>2014-11-14 16:45:28 +0000
commit1caada69b370f5c5fc78b448f9cd48f5afacffcd (patch)
tree97c27cd22aaca2ead1d9226dc4c088e60ed8b12a /dev-games
parentversion bump (diff)
downloadgentoo-2-1caada69b370f5c5fc78b448f9cd48f5afacffcd.tar.gz
gentoo-2-1caada69b370f5c5fc78b448f9cd48f5afacffcd.tar.bz2
gentoo-2-1caada69b370f5c5fc78b448f9cd48f5afacffcd.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key BDEED020)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/aseprite/ChangeLog8
-rw-r--r--dev-games/aseprite/aseprite-1.0.6.ebuild76
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-obinary.patch27
-rw-r--r--dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch11
4 files changed, 121 insertions, 1 deletions
diff --git a/dev-games/aseprite/ChangeLog b/dev-games/aseprite/ChangeLog
index 1df8cae9be02..8c89e2a6d122 100644
--- a/dev-games/aseprite/ChangeLog
+++ b/dev-games/aseprite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/aseprite
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/aseprite/ChangeLog,v 1.7 2014/11/14 00:45:23 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/aseprite/ChangeLog,v 1.8 2014/11/14 16:45:28 hasufell Exp $
+
+*aseprite-1.0.6 (14 Nov 2014)
+
+ 14 Nov 2014; Julian Ospald <hasufell@gentoo.org> +aseprite-1.0.6.ebuild,
+ +files/aseprite-1.0.6-obinary.patch, +files/aseprite-1.0.6-png_sizeof.patch:
+ version bump
14 Nov 2014; Tom Wijsman <TomWij@gentoo.org> metadata.xml:
Maintainer needed.
diff --git a/dev-games/aseprite/aseprite-1.0.6.ebuild b/dev-games/aseprite/aseprite-1.0.6.ebuild
new file mode 100644
index 000000000000..641066fd5437
--- /dev/null
+++ b/dev-games/aseprite/aseprite-1.0.6.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/aseprite/aseprite-1.0.6.ebuild,v 1.1 2014/11/14 16:45:28 hasufell Exp $
+
+EAPI="5"
+
+inherit cmake-utils multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="Animated sprite editor & pixel art tool"
+HOMEPAGE="http://www.aseprite.org"
+SRC_URI="https://github.com/aseprite/aseprite/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2 FTL"
+SLOT="0"
+# giflib still unkeyworded
+KEYWORDS=""
+
+IUSE="debug memleak"
+
+RDEPEND="dev-libs/tinyxml
+ media-libs/allegro:0[X,png]
+ >=media-libs/giflib-5.0
+ media-libs/libpng:0
+ sys-libs/zlib
+ virtual/jpeg
+ x11-libs/libX11
+ x11-libs/pixman"
+DEPEND="${RDEPEND}
+ dev-cpp/gtest"
+
+PATCHES=( "${FILESDIR}"/aseprite-0.9.5-underlinking.patch
+ "${FILESDIR}"/${P}-obinary.patch
+ "${FILESDIR}"/${P}-png_sizeof.patch )
+
+DOCS=( docs/files/ase.txt
+ docs/files/fli.txt
+ docs/files/msk.txt
+ docs/files/pic.txt
+ docs/files/picpro.txt
+ README.md )
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Fix to make flag-o-matic work.
+ if use debug ; then
+ sed -i '/-DNDEBUG/d' CMakeLists.txt || die
+ fi
+
+ rm -r third_party/* || die
+}
+
+src_configure() {
+ use debug && append-cppflags -DDEBUGMODE -D_DEBUG
+
+ local mycmakeargs=(
+ -DCURL_STATICLIB=OFF
+ -DENABLE_UPDATER=OFF
+ -DFULLSCREEN_PLATFORM=ON
+ -DLIBPIXMAN_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --variable=includedir pixman-1)/pixman-1"
+ -DLIBPIXMAN_LIBRARY="$($(tc-getPKG_CONFIG) --variable=libdir pixman-1)/libpixman-1.so"
+ -DUSE_SHARED_ALLEGRO4=ON
+ -DUSE_SHARED_CURL=ON
+ -DUSE_SHARED_GIFLIB=ON
+ -DUSE_SHARED_GTEST=ON
+ -DUSE_SHARED_JPEGLIB=ON
+ -DUSE_SHARED_LIBLOADPNG=ON
+ -DUSE_SHARED_LIBPNG=ON
+ -DUSE_SHARED_PIXMAN=ON
+ -DUSE_SHARED_TINYXML=ON
+ -DUSE_SHARED_ZLIB=ON
+ $(cmake-utils_use_enable memleak)
+ )
+
+ cmake-utils_src_configure
+}
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
new file mode 100644
index 000000000000..4536fc53a217
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.0.6-obinary.patch
@@ -0,0 +1,27 @@
+From 9997ad9fcbb0dcef16e4e8224e4238ecdfe56b66 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Matthias=20Mail=C3=A4nder?=
+ <Mailaender@users.noreply.github.com>
+Date: Sun, 28 Sep 2014 06:38:18 +0200
+Subject: [PATCH] always declare O_BINARY
+
+closes #461
+---
+ src/base/file_handle.cpp | 5 +++++
+ 1 file changed, 5 insertions(+)
+
+diff --git a/src/base/file_handle.cpp b/src/base/file_handle.cpp
+index 0ba214e..f336513 100644
+--- a/src/base/file_handle.cpp
++++ b/src/base/file_handle.cpp
+@@ -21,6 +21,11 @@
+ #include <fcntl.h>
+ #endif
+
++#ifndef O_BINARY
++#define O_BINARY 0
++#define O_TEXT 0
++#endif
++
+ using namespace std;
+
+ namespace base {
diff --git a/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
new file mode 100644
index 000000000000..02fa48006646
--- /dev/null
+++ b/dev-games/aseprite/files/aseprite-1.0.6-png_sizeof.patch
@@ -0,0 +1,11 @@
+--- src/app/file/png_format.cpp
++++ src/app/file/png_format.cpp
+@@ -413,7 +413,7 @@
+ #endif
+
+ // Save the color palette.
+- palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * png_sizeof(png_color));
++ palette = (png_colorp)png_malloc(png_ptr, PNG_MAX_PALETTE_LENGTH * sizeof(png_color));
+ for (c = 0; c < PNG_MAX_PALETTE_LENGTH; c++) {
+ fop_sequence_get_color(fop, c, &r, &g, &b);
+ palette[c].red = r;