summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-01-16 04:06:56 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-01-16 04:06:56 +0000
commit9238334580e35ed7bcd19667f0079c3d2fbb1d74 (patch)
treec6006ebf01947f5f4393e733d7c32b891cde6637 /dev-games
parentadd static-libs support (diff)
downloadgentoo-2-9238334580e35ed7bcd19667f0079c3d2fbb1d74.tar.gz
gentoo-2-9238334580e35ed7bcd19667f0079c3d2fbb1d74.tar.bz2
gentoo-2-9238334580e35ed7bcd19667f0079c3d2fbb1d74.zip
add static-libs support
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/guichan/ChangeLog7
-rw-r--r--dev-games/guichan/guichan-0.8.2.ebuild13
2 files changed, 14 insertions, 6 deletions
diff --git a/dev-games/guichan/ChangeLog b/dev-games/guichan/ChangeLog
index b9e6395d5d79..cf6cfc640d52 100644
--- a/dev-games/guichan/ChangeLog
+++ b/dev-games/guichan/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/guichan
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.23 2010/10/15 12:48:31 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/ChangeLog,v 1.24 2011/01/16 04:06:56 mr_bones_ Exp $
+
+ 16 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> guichan-0.8.2.ebuild:
+ add static-libs support
15 Oct 2010; Brent Baude <ranger@gentoo.org> guichan-0.8.2.ebuild:
stable ppc, bug 318909
diff --git a/dev-games/guichan/guichan-0.8.2.ebuild b/dev-games/guichan/guichan-0.8.2.ebuild
index 5f66b71cf4eb..29a3b5ef0ee2 100644
--- a/dev-games/guichan/guichan-0.8.2.ebuild
+++ b/dev-games/guichan/guichan-0.8.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.2.ebuild,v 1.4 2010/10/15 12:48:31 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/guichan/guichan-0.8.2.ebuild,v 1.5 2011/01/16 04:06:56 mr_bones_ Exp $
EAPI=2
inherit eutils autotools
@@ -12,7 +12,7 @@ SRC_URI="http://guichan.googlecode.com/files/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="allegro opengl sdl"
+IUSE="allegro opengl sdl static-libs"
DEPEND="allegro? ( media-libs/allegro )
opengl? ( virtual/opengl )
@@ -32,10 +32,15 @@ src_configure() {
$(use_enable allegro) \
$(use_enable opengl) \
$(use_enable sdl) \
- $(use_enable sdl sdlimage)
+ $(use_enable sdl sdlimage) \
+ $(use_enable static-libs static)
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog NEWS README TODO
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -exec rm {} + \
+ || die "la removal failed"
+ fi
}