summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-07-09 15:08:17 +0000
committerMichael Weber <xmw@gentoo.org>2012-07-09 15:08:17 +0000
commit9739a848e1283556c6a992c963da793c540c7e7e (patch)
treed0f82cc72a086a347ed423d8f4d9bec0274c3fab /dev-games
parentMarking cheese-3.2.2 ~ppc for bug 379649 (diff)
downloadgentoo-2-9739a848e1283556c6a992c963da793c540c7e7e.tar.gz
gentoo-2-9739a848e1283556c6a992c963da793c540c7e7e.tar.bz2
gentoo-2-9739a848e1283556c6a992c963da793c540c7e7e.zip
Fix boost-1.48 compilation issue (bug 407433, c bou)
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/simgear/ChangeLog6
-rw-r--r--dev-games/simgear/files/simgear-2.4.0-boost148.patch29
-rw-r--r--dev-games/simgear/simgear-2.4.0.ebuild14
3 files changed, 42 insertions, 7 deletions
diff --git a/dev-games/simgear/ChangeLog b/dev-games/simgear/ChangeLog
index b7c823c7db66..5fe5a29199b9 100644
--- a/dev-games/simgear/ChangeLog
+++ b/dev-games/simgear/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/simgear
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/ChangeLog,v 1.49 2012/04/06 10:48:32 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/ChangeLog,v 1.50 2012/07/09 15:08:17 xmw Exp $
+
+ 09 Jul 2012; Michael Weber <xmw@gentoo.org>
+ +files/simgear-2.4.0-boost148.patch, simgear-2.4.0.ebuild:
+ Fix boost-1.48 compilation issue (bug 407433, c bou)
06 Apr 2012; Andreas Schuerch <nativemad@gentoo.org> simgear-2.4.0.ebuild:
x86 stable, see bug 405665
diff --git a/dev-games/simgear/files/simgear-2.4.0-boost148.patch b/dev-games/simgear/files/simgear-2.4.0-boost148.patch
new file mode 100644
index 000000000000..a8b1aacc9cc3
--- /dev/null
+++ b/dev-games/simgear/files/simgear-2.4.0-boost148.patch
@@ -0,0 +1,29 @@
+--- simgear-2.4.0/simgear/structure/Singleton.hxx
++++ simgear-2.4.0/simgear/structure/Singleton.hxx
+@@ -1,7 +1,7 @@
+ #ifndef SIMGEAR_SINGLETON_HXX
+ #define SIMGEAR_SINGLETON_HXX 1
+
+-#include <boost/pool/detail/singleton.hpp>
++#include "boost/thread/detail/singleton.hpp"
+
+ #include <osg/Referenced>
+ #include <osg/ref_ptr>
+@@ -22,7 +22,7 @@
+ static Class* instance()
+ {
+ Class& singleton
+- = boost::details::pool::singleton_default<Class>::instance();
++ = boost::detail::thread::singleton<Class>::instance();
+ return &singleton;
+ }
+ };
+@@ -38,7 +38,7 @@
+ static RefClass* instance()
+ {
+ SingletonRefPtr& singleton
+- = boost::details::pool::singleton_default<SingletonRefPtr>::instance();
++ = boost::detail::thread::singleton<SingletonRefPtr>::instance();
+ return singleton.ptr.get();
+ }
+ private:
diff --git a/dev-games/simgear/simgear-2.4.0.ebuild b/dev-games/simgear/simgear-2.4.0.ebuild
index 486d01c63f8f..c109d9afeed0 100644
--- a/dev-games/simgear/simgear-2.4.0.ebuild
+++ b/dev-games/simgear/simgear-2.4.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-2.4.0.ebuild,v 1.3 2012/04/06 10:48:32 nativemad Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/simgear/simgear-2.4.0.ebuild,v 1.4 2012/07/09 15:08:17 xmw Exp $
EAPI=4
-inherit autotools-utils
+inherit autotools-utils eutils
DESCRIPTION="Development library for simulation games"
HOMEPAGE="http://www.simgear.org/"
@@ -17,18 +17,20 @@ IUSE="debug"
RESTRICT="test"
-RDEPEND="
- >=dev-games/openscenegraph-3.0.1
+RDEPEND=">=dev-games/openscenegraph-3.0.1
>=dev-libs/boost-1.37
dev-vcs/subversion
media-libs/freealut
media-libs/openal
- >=media-libs/plib-1.8.5
-"
+ >=media-libs/plib-1.8.5"
DEPEND="${RDEPEND}"
DOCS=(AUTHORS NEWS TODO)
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-boost148.patch
+}
+
src_configure() {
myeconfargs=(
--with-jpeg-factory