summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2014-09-12 19:12:38 +0000
committerAlfredo Tupone <tupone@gentoo.org>2014-09-12 19:12:38 +0000
commitc989833add7b92625924aaaf3b4f9d558a581e5b (patch)
tree9d98f0cca1a9662876da4c849f057d67cf8b04fc /dev-games
parentRemove ~mips keyword for net-libs/webkit-gtk:3 because it fails to compile on... (diff)
downloadgentoo-2-c989833add7b92625924aaaf3b4f9d558a581e5b.tar.gz
gentoo-2-c989833add7b92625924aaaf3b4f9d558a581e5b.tar.bz2
gentoo-2-c989833add7b92625924aaaf3b4f9d558a581e5b.zip
Fix build with USE=doc. Bug #521340
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0145142D)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/clanlib/ChangeLog8
-rw-r--r--dev-games/clanlib/clanlib-2.3.7.ebuild14
-rw-r--r--dev-games/clanlib/files/clanlib-2.3.7-doc.patch14
3 files changed, 31 insertions, 5 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 71ed4a36efa6..69dd72a3001c 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/clanlib
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.64 2013/10/28 23:31:47 mr_bones_ Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.65 2014/09/12 19:12:38 tupone Exp $
+
+ 12 Sep 2014; Tupone Alfredo <tupone@gentoo.org> clanlib-2.3.7.ebuild,
+ +files/clanlib-2.3.7-doc.patch:
+ Fix build with USE=doc. Bug #521340 by flameeyes
*clanlib-2.3.7 (28 Oct 2013)
diff --git a/dev-games/clanlib/clanlib-2.3.7.ebuild b/dev-games/clanlib/clanlib-2.3.7.ebuild
index 95713d2b00d4..9d7c5ad5f18f 100644
--- a/dev-games/clanlib/clanlib-2.3.7.ebuild
+++ b/dev-games/clanlib/clanlib-2.3.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.7.ebuild,v 1.1 2013/10/28 23:31:47 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-2.3.7.ebuild,v 1.2 2014/09/12 19:12:38 tupone Exp $
EAPI=4
inherit flag-o-matic eutils autotools-utils
@@ -44,7 +44,10 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
-PATCHES=( "${FILESDIR}"/${P}-autotools.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-autotools.patch
+ "${FILESDIR}"/${P}-doc.patch
+)
AUTOTOOLS_AUTORECONF=1
AUTOTOOLS_IN_SOURCE_BUILD=1
DOCS=(
@@ -54,6 +57,11 @@ DOCS=(
README
)
+src_prepare() {
+ autotools-utils_src_prepare
+ ln -sf ../../../Sources/API Documentation/Utilities/ReferenceDocs/ClanLib
+}
+
src_configure() {
myeconfargs=(
$(use_enable doc docs)
diff --git a/dev-games/clanlib/files/clanlib-2.3.7-doc.patch b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
new file mode 100644
index 000000000000..627df26785b4
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-2.3.7-doc.patch
@@ -0,0 +1,14 @@
+--- Documentation/Utilities/ReferenceDocs/Makefile.old 2014-09-12 20:06:52.970459560 +0200
++++ Documentation/Utilities/ReferenceDocs/Makefile 2014-09-12 20:08:17.387048685 +0200
+@@ -3,7 +3,10 @@
+ LIBS=clanCore
+ EXTRA_LIBS=-lpthread
+
+-include ../../../Examples/Makefile.conf
++CXXFLAGS += -pthread -std=c++0x -I.
++all: $(EXAMPLE_BIN)
++$(EXAMPLE_BIN): $(OBJF)
++ $(CXX) $(CXXFLAGS) $(OBJF) -o $(EXAMPLE_BIN) -Wl,-R../../Sources/Core/.libs -L../../../Sources/Core/.libs -lclan23Core $(EXTRA_LIBS)
+
+ # EOF #
+