summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2015-06-09 03:07:26 +0000
committerZac Medico <zmedico@gentoo.org>2015-06-09 03:07:26 +0000
commit4fb9116db7dfd1f28a149ee3b04d50e0c3a85c79 (patch)
tree28f523ed62bd9031e243d0070b9373418e919ccc /dev-go
parentFix gnome-3.16 overmasking, thanks to floppym for noticing (diff)
downloadgentoo-2-4fb9116db7dfd1f28a149ee3b04d50e0c3a85c79.tar.gz
gentoo-2-4fb9116db7dfd1f28a149ee3b04d50e0c3a85c79.tar.bz2
gentoo-2-4fb9116db7dfd1f28a149ee3b04d50e0c3a85c79.zip
Add 1.4.2_p20150604 snapshot with timestamp preservation for bug 551486.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key FDE8EF85AE5719A3)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-text/ChangeLog8
-rw-r--r--dev-go/go-text/go-text-1.4.2_p20150604.ebuild54
-rw-r--r--dev-go/go-text/go-text-9999.ebuild3
3 files changed, 63 insertions, 2 deletions
diff --git a/dev-go/go-text/ChangeLog b/dev-go/go-text/ChangeLog
index 8dc60fcbab38..177ddcebd64b 100644
--- a/dev-go/go-text/ChangeLog
+++ b/dev-go/go-text/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-go/go-text
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-text/ChangeLog,v 1.6 2015/05/24 08:19:30 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-text/ChangeLog,v 1.7 2015/06/09 03:07:26 zmedico Exp $
+
+*go-text-1.4.2_p20150604 (09 Jun 2015)
+
+ 09 Jun 2015; Zac Medico <zmedico@gentoo.org> +go-text-1.4.2_p20150604.ebuild,
+ go-text-9999.ebuild:
+ Add 1.4.2_p20150604 snapshot with timestamp preservation for bug 551486.
24 May 2015; Zac Medico <zmedico@gentoo.org> go-text-1.4.2_p20150506.ebuild,
go-text-9999.ebuild:
diff --git a/dev-go/go-text/go-text-1.4.2_p20150604.ebuild b/dev-go/go-text/go-text-1.4.2_p20150604.ebuild
new file mode 100644
index 000000000000..84ac76d1cb57
--- /dev/null
+++ b/dev-go/go-text/go-text-1.4.2_p20150604.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-text/go-text-1.4.2_p20150604.ebuild,v 1.1 2015/06/09 03:07:26 zmedico Exp $
+
+EAPI=5
+
+KEYWORDS="~amd64"
+DESCRIPTION="Go text processing support"
+MY_PN=${PN##*-}
+GO_PN=golang.org/x/${MY_PN}
+HOMEPAGE="https://godoc.org/${GO_PN}"
+EGIT_COMMIT="df923bbb63f8ea3a26bb743e2a497abd0ab585f7"
+SRC_URI="https://github.com/golang/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+DEPEND=">=dev-lang/go-1.4"
+RDEPEND=""
+S="${WORKDIR}/src/${GO_PN}"
+EGIT_CHECKOUT_DIR="${S}"
+STRIP_MASK="*.a"
+
+src_unpack() {
+ default
+ mkdir -p src/${GO_PN%/*} || die
+ mv ${MY_PN}-${EGIT_COMMIT} src/${GO_PN} || die
+}
+
+src_compile() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ GOROOT="${WORKDIR}/goroot"
+ cp -sR "${EPREFIX}"/usr/lib/go "${GOROOT}" || die
+ rm -rf "${GOROOT}/src/${GO_PN}" \
+ "${GOROOT}/pkg/linux_${ARCH}/${GO_PN}" || die
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} go install -v -x -work ${GO_PN}/... || die
+}
+
+src_test() {
+ # Create go symlink for TestLinking in display/dict_test.go
+ mkdir -p "${GOROOT}/bin"
+ ln -s /usr/bin/go "${GOROOT}/bin/go" || die
+
+ GOROOT="${GOROOT}" GOPATH=${WORKDIR} \
+ go test -x -v ${GO_PN}/... || die $?
+}
+
+src_install() {
+ exeinto /usr/lib/go/bin
+ doexe "${WORKDIR}"/bin/*
+ insinto /usr/lib/go
+ find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ insopts -m0644 -p # preserve timestamps for bug 551486
+ doins -r "${WORKDIR}"/{pkg,src}
+}
diff --git a/dev-go/go-text/go-text-9999.ebuild b/dev-go/go-text/go-text-9999.ebuild
index 312b2ab1b981..37b218ff7c47 100644
--- a/dev-go/go-text/go-text-9999.ebuild
+++ b/dev-go/go-text/go-text-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-text/go-text-9999.ebuild,v 1.4 2015/05/24 08:19:30 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-text/go-text-9999.ebuild,v 1.5 2015/06/09 03:07:26 zmedico Exp $
EAPI=5
inherit git-r3
@@ -42,5 +42,6 @@ src_install() {
doexe "${WORKDIR}"/bin/*
insinto /usr/lib/go
find "${WORKDIR}"/{pkg,src} -name '.git*' -exec rm -rf {} \; 2>/dev/null
+ insopts -m0644 -p # preserve timestamps for bug 551486
doins -r "${WORKDIR}"/{pkg,src}
}