summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-13 13:25:02 +0000
committerMark Wright <gienah@gentoo.org>2014-12-13 13:25:02 +0000
commit967684e9f86cb445d338cb523ea62124bd253177 (patch)
tree8363351e6e2e1d9b08892c6583db9f7aec13cef6 /dev-haskell/authenticate/authenticate-1.3.2.10.ebuild
parentBump asn1-types to 0.3.0 (diff)
downloadgentoo-2-967684e9f86cb445d338cb523ea62124bd253177.tar.gz
gentoo-2-967684e9f86cb445d338cb523ea62124bd253177.tar.bz2
gentoo-2-967684e9f86cb445d338cb523ea62124bd253177.zip
Bump authenticate to 1.3.2.10
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/authenticate/authenticate-1.3.2.10.ebuild')
-rw-r--r--dev-haskell/authenticate/authenticate-1.3.2.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-haskell/authenticate/authenticate-1.3.2.10.ebuild b/dev-haskell/authenticate/authenticate-1.3.2.10.ebuild
new file mode 100644
index 000000000000..e4437b89e9ca
--- /dev/null
+++ b/dev-haskell/authenticate/authenticate-1.3.2.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/authenticate/authenticate-1.3.2.10.ebuild,v 1.1 2014/12/13 13:25:02 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Authentication methods for Haskell web applications"
+HOMEPAGE="http://github.com/yesodweb/authenticate"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+network-uri"
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ >=dev-haskell/http-conduit-1.5:=[profile?]
+ >=dev-haskell/http-types-0.6:=[profile?]
+ dev-haskell/monad-control:=[profile?]
+ dev-haskell/resourcet:=[profile?]
+ >=dev-haskell/tagstream-conduit-0.5.5:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.1:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ network-uri? ( >=dev-haskell/network-uri-2.6:=[profile?] )
+ !network-uri? ( <dev-haskell/network-2.6:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag network-uri network-uri)
+}