summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-03-08 19:31:30 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-03-08 19:31:30 +0000
commit8bd33722b2bf9927931744fdb0e09f2e0930895f (patch)
tree408c31b9501ad0ad6320284ef060c762533e6ad6 /dev-haskell/cabal
parentDrop KDE 4.2.0 (diff)
downloadgentoo-2-8bd33722b2bf9927931744fdb0e09f2e0930895f.tar.gz
gentoo-2-8bd33722b2bf9927931744fdb0e09f2e0930895f.tar.bz2
gentoo-2-8bd33722b2bf9927931744fdb0e09f2e0930895f.zip
Bump dev-haskell/cabal to 1.6.0.2
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/cabal')
-rw-r--r--dev-haskell/cabal/ChangeLog7
-rw-r--r--dev-haskell/cabal/cabal-1.6.0.2.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-haskell/cabal/ChangeLog b/dev-haskell/cabal/ChangeLog
index 2feb52b546ff..5dbba156e07d 100644
--- a/dev-haskell/cabal/ChangeLog
+++ b/dev-haskell/cabal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/cabal
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.45 2009/03/08 19:26:34 kolmodin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/ChangeLog,v 1.46 2009/03/08 19:31:30 kolmodin Exp $
+
+*cabal-1.6.0.2 (08 Mar 2009)
+
+ 08 Mar 2009; Lennart Kolmodin <kolmodin@gentoo.org> +cabal-1.6.0.2.ebuild:
+ Version bump
08 Mar 2009; Lennart Kolmodin <kolmodin@gentoo.org> cabal-1.6.0.1.ebuild:
Add CABAL_CORE_LIB_GHC_PV="6.10.1" to make this a dummy package
diff --git a/dev-haskell/cabal/cabal-1.6.0.2.ebuild b/dev-haskell/cabal/cabal-1.6.0.2.ebuild
new file mode 100644
index 000000000000..b2554d890b42
--- /dev/null
+++ b/dev-haskell/cabal/cabal-1.6.0.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal/cabal-1.6.0.2.ebuild,v 1.1 2009/03/08 19:31:30 kolmodin Exp $
+
+CABAL_FEATURES="bootstrap lib profile"
+inherit haskell-cabal eutils
+
+MY_PN="Cabal"
+MY_P="${MY_PN}-${PV}"
+
+# Resolve cyclic dep between filepath and Cabal by using a private copy of
+# filepath when building Cabal.
+FP_PN=filepath
+FP_PV=1.1.0.1
+FP_P=${FP_PN}-${FP_PV}
+
+
+DESCRIPTION="A framework for packaging Haskell software"
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz
+ http://hackage.haskell.org/packages/archive/${FP_PN}/${FP_PV}/${FP_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+DEPEND=">=dev-lang/ghc-6.4"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ # We're using the private copy of filepath:
+ sed -i -e 's/Build-Depends: filepath >= 1 && < 1.2//' \
+ -e '/Other-Modules:/a \
+ System.FilePath System.FilePath.Posix System.FilePath.Windows' \
+ "${S}/Cabal.cabal"
+ # Note: do not replace spaces with tabs on the line above, it'll break
+ # things. You'll just have to put up with the repoman warning.
+
+ echo " Hs-Source-Dirs: ., ../${FP_P}" >> "${S}/Cabal.cabal"
+}
+
+src_compile() {
+ if ! cabal-is-dummy-lib; then
+ einfo "Bootstrapping Cabal..."
+ $(ghc-getghc) -i -i. -i"${WORKDIR}/${FP_P}" -cpp --make Setup.hs \
+ -o setup || die "compiling Setup.hs failed"
+ cabal-configure
+ cabal-build
+ fi
+}