summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-11-25 06:03:14 +0000
committerMark Wright <gienah@gentoo.org>2012-11-25 06:03:14 +0000
commitc8da8398c79f0dcc0f3d4915ecbc86465e11e623 (patch)
treefdb8d2b3da6516f512f0b0ce45abe4071516e682 /dev-haskell/citeproc-hs
parentAdd hexpat (diff)
downloadgentoo-2-c8da8398c79f0dcc0f3d4915ecbc86465e11e623.tar.gz
gentoo-2-c8da8398c79f0dcc0f3d4915ecbc86465e11e623.tar.bz2
gentoo-2-c8da8398c79f0dcc0f3d4915ecbc86465e11e623.zip
Bump citeproc-hs to 0.3.6
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/citeproc-hs')
-rw-r--r--dev-haskell/citeproc-hs/ChangeLog8
-rw-r--r--dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild39
-rw-r--r--dev-haskell/citeproc-hs/metadata.xml11
3 files changed, 54 insertions, 4 deletions
diff --git a/dev-haskell/citeproc-hs/ChangeLog b/dev-haskell/citeproc-hs/ChangeLog
index 44ac16570554..d03bf00d4389 100644
--- a/dev-haskell/citeproc-hs/ChangeLog
+++ b/dev-haskell/citeproc-hs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/citeproc-hs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/ChangeLog,v 1.3 2012/09/12 15:30:29 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/ChangeLog,v 1.4 2012/11/25 06:03:14 gienah Exp $
+
+*citeproc-hs-0.3.6 (25 Nov 2012)
+
+ 25 Nov 2012; Mark Wright <gienah@gentoo.org> +citeproc-hs-0.3.6.ebuild,
+ metadata.xml:
+ Bump citeproc-hs to 0.3.6
12 Sep 2012; Alexander Vershilov <qnikst@gentoo.org> citeproc-hs-0.3.2.ebuild,
citeproc-hs-0.3.4.ebuild:
diff --git a/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild b/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild
new file mode 100644
index 000000000000..fd2fa40f16a4
--- /dev/null
+++ b/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/citeproc-hs/citeproc-hs-0.3.6.ebuild,v 1.1 2012/11/25 06:03:14 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A Citation Style Language implementation in Haskell"
+HOMEPAGE="http://gorgias.mine.nu/repos/citeproc-hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+bibutils hexpat +network"
+
+RDEPEND="dev-haskell/json:=[generic,profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/pandoc-types-1.8:=[profile?]
+ <dev-haskell/pandoc-types-1.11:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/time:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ !hexpat? ( dev-haskell/xml:=[profile?] )
+ hexpat? ( >=dev-haskell/hexpat-0.20.2:=[profile?] )
+ >=dev-lang/ghc-6.10.4:=
+ bibutils? ( >=dev-haskell/hs-bibutils-0.3:=[profile?] )
+ network? (
+ >=dev-haskell/http-4000.0.9:=[profile?]
+ >=dev-haskell/network-2:=[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/citeproc-hs/metadata.xml b/dev-haskell/citeproc-hs/metadata.xml
index eb4ffec0ccb3..90fd5c0f9dc4 100644
--- a/dev-haskell/citeproc-hs/metadata.xml
+++ b/dev-haskell/citeproc-hs/metadata.xml
@@ -9,10 +9,15 @@
citeproc-hs is a library for rendering
bibliographic reference citations into a variety
of styles using a macro language called Citation
- Style Language (CSL).
+ Style Language (CSL). More details on CSL can be
+ found here:
+ &lt;http://citationstyles.org/&gt;.
+
+ For the API documentation please see &quot;Text.CSL&quot;.
</longdescription>
<use>
- <flag name="bibutils">Use Chris Putnam's <pkg>app-text/bibutils</pkg></flag>
- <flag name="network">Use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs.</flag>
+ <flag name="bibutils">use Chris Putnam's <pkg>app-text/bibutils</pkg></flag>
+ <flag name="network">use <pkg>dev-haskell/network</pkg> and <pkg>dev-haskell/http</pkg> to retrieve CSL file from URIs</flag>
+ <flag name="hexpat">use <pkg>dev-haskell/hexpat</pkg> instead of <pkg>dev-haskell/xml</pkg> for XML parsing</flag>
</use>
</pkgmetadata>