summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 12:38:06 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 12:38:06 +0000
commit6c2a61cc5c916f68e97f662e9783fc063c6e73d8 (patch)
treee2ca136b334ee5e5d9126b965e3c46191fac9df3 /dev-haskell/crypto-pubkey
parentBump crypto-conduit to 0.5.2.2 (diff)
downloadgentoo-2-6c2a61cc5c916f68e97f662e9783fc063c6e73d8.tar.gz
gentoo-2-6c2a61cc5c916f68e97f662e9783fc063c6e73d8.tar.bz2
gentoo-2-6c2a61cc5c916f68e97f662e9783fc063c6e73d8.zip
Bump crypto-pubkey to 0.2.4
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/crypto-pubkey')
-rw-r--r--dev-haskell/crypto-pubkey/ChangeLog9
-rw-r--r--dev-haskell/crypto-pubkey/crypto-pubkey-0.2.4.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-haskell/crypto-pubkey/ChangeLog b/dev-haskell/crypto-pubkey/ChangeLog
index 4f59fa390418..7179bcaa108a 100644
--- a/dev-haskell/crypto-pubkey/ChangeLog
+++ b/dev-haskell/crypto-pubkey/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/crypto-pubkey
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/ChangeLog,v 1.6 2013/12/11 05:53:37 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/ChangeLog,v 1.7 2014/03/09 12:38:06 gienah Exp $
+
+*crypto-pubkey-0.2.4 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +crypto-pubkey-0.2.4.ebuild:
+ Bump crypto-pubkey to 0.2.4
*crypto-pubkey-0.2.3 (11 Dec 2013)
diff --git a/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.4.ebuild b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.4.ebuild
new file mode 100644
index 000000000000..8751baa96b9d
--- /dev/null
+++ b/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/crypto-pubkey/crypto-pubkey-0.2.4.ebuild,v 1.1 2014/03/09 12:38:06 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Public Key cryptography"
+HOMEPAGE="http://github.com/vincenthz/hs-crypto-pubkey"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmark"
+
+RDEPEND="dev-haskell/byteable:=[profile?]
+ >=dev-haskell/crypto-numbers-0.2.2:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4.1:=[profile?] <dev-haskell/crypto-pubkey-types-0.5:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.9.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ >=dev-haskell/quickcheck-2
+ >=dev-haskell/test-framework-0.3.3
+ dev-haskell/test-framework-hunit
+ >=dev-haskell/test-framework-quickcheck2-0.2.9 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag benchmark benchmark)
+}