summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-09-06 18:56:47 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-09-06 18:56:47 +0000
commit7cf8514da2222c80b739295b5492261319a5fb2f (patch)
tree8ff15186b44c4a47b6b14b7c6554408330673a51 /dev-haskell/dav
parentCUPS 2.0 is near, so add live ebuild for the stable branch (diff)
downloadgentoo-2-7cf8514da2222c80b739295b5492261319a5fb2f.tar.gz
gentoo-2-7cf8514da2222c80b739295b5492261319a5fb2f.tar.bz2
gentoo-2-7cf8514da2222c80b739295b5492261319a5fb2f.zip
Version bump.
(Portage version: 2.2.12_p12/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/dav')
-rw-r--r--dev-haskell/dav/ChangeLog7
-rw-r--r--dev-haskell/dav/dav-1.0.1.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-haskell/dav/ChangeLog b/dev-haskell/dav/ChangeLog
index ef590bab6b43..9ec6f716c1cb 100644
--- a/dev-haskell/dav/ChangeLog
+++ b/dev-haskell/dav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/dav
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/ChangeLog,v 1.5 2014/07/25 08:59:30 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/ChangeLog,v 1.6 2014/09/06 18:56:47 slyfox Exp $
+
+*dav-1.0.1 (06 Sep 2014)
+
+ 06 Sep 2014; Sergei Trofimovich <slyfox@gentoo.org> +dav-1.0.1.ebuild:
+ Version bump.
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/dav/dav-1.0.1.ebuild b/dev-haskell/dav/dav-1.0.1.ebuild
new file mode 100644
index 000000000000..04ec4af5a9b4
--- /dev/null
+++ b/dev-haskell/dav/dav-1.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dav/dav-1.0.1.ebuild,v 1.1 2014/09/06 18:56:47 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="DAV"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="RFC 4918 WebDAV support"
+HOMEPAGE="http://floss.scru.org/hDAV"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/case-insensitive-0.4:=[profile?]
+ dev-haskell/data-default:=[profile?]
+ >=dev-haskell/either-4.3:=[profile?]
+ dev-haskell/errors:=[profile?]
+ dev-haskell/exceptions:=[profile?]
+ >=dev-haskell/http-client-0.2:=[profile?]
+ >=dev-haskell/http-client-tls-0.2:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lens-3.0:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?]
+ >=dev-haskell/network-2.3:=[profile?]
+ >=dev-haskell/optparse-applicative-0.5.0:=[profile?]
+ >=dev-haskell/transformers-0.3:=[profile?]
+ dev-haskell/transformers-base:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-haskell/xml-conduit-1.0:=[profile?] <dev-haskell/xml-conduit-1.3:=[profile?]
+ >=dev-haskell/xml-hamlet-0.4:=[profile?] <dev-haskell/xml-hamlet-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+S="${WORKDIR}/${MY_P}"