summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-12 20:31:22 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-12 20:31:22 +0000
commitba587ce31346d7260c98c75735dcaac041d863d3 (patch)
tree55fbcd022ce465ddfd266e7ef236f1cf43374544 /dev-haskell/fingertree
parentrevbump to update engine (diff)
downloadgentoo-2-ba587ce31346d7260c98c75735dcaac041d863d3.tar.gz
gentoo-2-ba587ce31346d7260c98c75735dcaac041d863d3.tar.bz2
gentoo-2-ba587ce31346d7260c98c75735dcaac041d863d3.zip
initial version
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/fingertree')
-rw-r--r--dev-haskell/fingertree/ChangeLog9
-rw-r--r--dev-haskell/fingertree/fingertree-0.1.0.0.ebuild29
-rw-r--r--dev-haskell/fingertree/metadata.xml23
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-haskell/fingertree/ChangeLog b/dev-haskell/fingertree/ChangeLog
new file mode 100644
index 000000000000..153eca192da4
--- /dev/null
+++ b/dev-haskell/fingertree/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/fingertree
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fingertree/ChangeLog,v 1.1 2014/03/12 20:31:22 qnikst Exp $
+
+*fingertree-0.1.0.0 (12 Mar 2014)
+
+ 12 Mar 2014; Alexander Vershilov <qnikst@gentoo.org>
+ +fingertree-0.1.0.0.ebuild, +metadata.xml:
+ initial version
diff --git a/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild b/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild
new file mode 100644
index 000000000000..8e4de7957c74
--- /dev/null
+++ b/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/fingertree/fingertree-0.1.0.0.ebuild,v 1.1 2014/03/12 20:31:22 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generic finger-tree structure, with example instances"
+HOMEPAGE="http://hackage.haskell.org/package/fingertree"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit
+ dev-haskell/test-framework-quickcheck2
+ )"
diff --git a/dev-haskell/fingertree/metadata.xml b/dev-haskell/fingertree/metadata.xml
new file mode 100644
index 000000000000..44b6b5afac6e
--- /dev/null
+++ b/dev-haskell/fingertree/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ A general sequence representation with arbitrary
+ annotations, for use as a base for implementations of
+ various collection types, with examples, as described
+ in section 4 of
+
+ * Ralf Hinze and Ross Paterson,
+ \&quot;Finger trees: a simple general-purpose data structure\&quot;,
+ /Journal of Functional Programming/ 16:2 (2006) pp 197-217.
+ &lt;http://www.soi.city.ac.uk/~ross/papers/FingerTree.html&gt;
+
+ For a tuned sequence type, see @Data.Sequence@ in the
+ @containers@ package, which is a specialization of
+ this structure.
+ </longdescription>
+</pkgmetadata>