summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:45:33 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 00:45:33 +0000
commit4b99915cf7f39c9a01f328ecea4ce39e5dc9947f (patch)
tree9eb634d19a2f4b0f417dea72d4dc109ff3a12363 /dev-haskell/haddock/haddock-0.8.ebuild
parentDoes not work with gtksourceview 2.x. Fixes bug #201210. (diff)
downloadgentoo-2-4b99915cf7f39c9a01f328ecea4ce39e5dc9947f.tar.gz
gentoo-2-4b99915cf7f39c9a01f328ecea4ce39e5dc9947f.tar.bz2
gentoo-2-4b99915cf7f39c9a01f328ecea4ce39e5dc9947f.zip
Remove unnecessary blocker. Fix shell quoting.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell/haddock/haddock-0.8.ebuild')
-rw-r--r--dev-haskell/haddock/haddock-0.8.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-haskell/haddock/haddock-0.8.ebuild b/dev-haskell/haddock/haddock-0.8.ebuild
index 995ac2a7b88e..05d4a36777d9 100644
--- a/dev-haskell/haddock/haddock-0.8.ebuild
+++ b/dev-haskell/haddock/haddock-0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-0.8.ebuild,v 1.10 2007/10/31 12:57:11 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-0.8.ebuild,v 1.11 2007/12/13 00:45:33 dcoutts Exp $
CABAL_FEATURES="bin"
inherit haskell-cabal eutils versionator
@@ -29,9 +29,9 @@ S="${WORKDIR}/${MY_PF}"
src_compile () {
cabal_src_compile
if use doc; then
- cd ${S}/doc
+ cd "${S}/doc"
autoconf
- ./configure --prefix=${D}/usr/ \
+ ./configure --prefix="${D}/usr/" \
|| die 'error configuring documentation.'
make html || die 'error building documentation.'
fi
@@ -40,7 +40,7 @@ src_compile () {
src_install () {
cabal_src_install
if use doc; then
- dohtml -r ${S}/doc/haddock/*
+ dohtml -r "${S}/doc/haddock/"*
fi
- dodoc CHANGES LICENSE README
+ dodoc CHANGES README
}