summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2004-10-21 15:15:43 +0000
committerAndres Loeh <kosmikus@gentoo.org>2004-10-21 15:15:43 +0000
commit65cb7149530002958d1407483530ec4ede290491 (patch)
tree122b7627a326d5c570b017a283211ea4c2de1fb7 /dev-haskell/happy
parentinstall build_icon.sh #68399 by chico76 (Manifest recommit) (diff)
downloadgentoo-2-65cb7149530002958d1407483530ec4ede290491.tar.gz
gentoo-2-65cb7149530002958d1407483530ec4ede290491.tar.bz2
gentoo-2-65cb7149530002958d1407483530ec4ede290491.zip
patched for gcc-3.4
Diffstat (limited to 'dev-haskell/happy')
-rw-r--r--dev-haskell/happy/ChangeLog7
-rw-r--r--dev-haskell/happy/files/digest-happy-1.131
-rw-r--r--dev-haskell/happy/files/happy-1.13-pragma.patch.bz2bin498 -> 0 bytes
-rw-r--r--dev-haskell/happy/files/happy-1.14-gcc3.4.patch49
-rw-r--r--dev-haskell/happy/happy-1.13.ebuild31
-rw-r--r--dev-haskell/happy/happy-1.14.ebuild18
6 files changed, 64 insertions, 42 deletions
diff --git a/dev-haskell/happy/ChangeLog b/dev-haskell/happy/ChangeLog
index 7c715d3d8d11..747a7fb005cc 100644
--- a/dev-haskell/happy/ChangeLog
+++ b/dev-haskell/happy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/happy
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.4 2004/06/24 22:15:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/ChangeLog,v 1.5 2004/10/21 15:15:43 kosmikus Exp $
+
+ 21 Oct 2004; Andres Loeh <kosmikus@gentoo.org> happy-1.13.ebuild,
+ happy-1.14.ebuild, files/happy-1.13-pragma.patch.bz2,
+ files/happy-1.14-gcc3.4.patch:
+ Patched for gcc-3.4.
*happy-1.14 (14 Apr 2004)
diff --git a/dev-haskell/happy/files/digest-happy-1.13 b/dev-haskell/happy/files/digest-happy-1.13
deleted file mode 100644
index 60877aeeae3a..000000000000
--- a/dev-haskell/happy/files/digest-happy-1.13
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d17619ae6e2caf883651d88be38dfd8a happy-1.13-src.tar.gz 329764
diff --git a/dev-haskell/happy/files/happy-1.13-pragma.patch.bz2 b/dev-haskell/happy/files/happy-1.13-pragma.patch.bz2
deleted file mode 100644
index bdf01f960e43..000000000000
--- a/dev-haskell/happy/files/happy-1.13-pragma.patch.bz2
+++ /dev/null
Binary files differ
diff --git a/dev-haskell/happy/files/happy-1.14-gcc3.4.patch b/dev-haskell/happy/files/happy-1.14-gcc3.4.patch
new file mode 100644
index 000000000000..0dd915cb77f3
--- /dev/null
+++ b/dev-haskell/happy/files/happy-1.14-gcc3.4.patch
@@ -0,0 +1,49 @@
+diff -Naur happy-1.14.orig/happy/src/Main.lhs happy-1.14/happy/src/Main.lhs
+--- happy-1.14.orig/happy/src/Main.lhs 2004-10-21 17:03:27.923088968 +0200
++++ happy-1.14/happy/src/Main.lhs 2004-10-21 17:03:55.192943320 +0200
+@@ -417,20 +417,11 @@
+
+ CPP is turned on for -fglasogw-exts, so we can use conditional compilation:
+
+-> import_glaexts = "#if __GLASGOW_HASKELL__ >= 503\n\
+-> \import GHC.Exts\n\
+-> \#else\n\
+-> \import GlaExts\n\
+-> \#endif\n"
+-
+-> import_debug = "#if __GLASGOW_HASKELL__ >= 503\n\
+-> \import System.IO\n\
+-> \import System.IO.Unsafe\n\
+-> \import Debug.Trace\n\
+-> \#else\n\
+-> \import IO\n\
+-> \import IOExts\n\
+-> \#endif\n"
++> import_glaexts =
++> "#if __GLASGOW_HASKELL__ >= 503\nimport GHC.Exts\n#else\nimport GlaExts\n#endif\n"
++
++> import_debug =
++> "#if __GLASGOW_HASKELL__ >= 503\nimport System.IO\nimport System.IO.Unsafe\nimport Debug.Trace\n#else\nimport IO\nimport IOExts\n#endif\n"
+
+ ------------------------------------------------------------------------------
+ Extract various command-line options.
+@@ -468,8 +459,8 @@
+ > = if OptUseCoercions `elem` cli
+ > then if OptGhcTarget `elem` cli
+ > then return True
+-> else dieHappy "-c/--coerce may only be used \
+-> \in conjunction with -g/--ghc\n"
++> else dieHappy
++> "-c/--coerce may only be used in conjunction with -g/--ghc\n"
+ > else return False
+
+ > getGhc cli = return (OptGhcTarget `elem` cli)
+diff -Naur happy-1.14.orig/happy/src/Version.hs happy-1.14/happy/src/Version.hs
+--- happy-1.14.orig/happy/src/Version.hs 2004-10-21 17:03:27.929088056 +0200
++++ happy-1.14/happy/src/Version.hs 2004-10-21 17:03:44.131624896 +0200
+@@ -1,4 +1,3 @@
+ module Version (version) where
+
+-version = tail "\
+- \ HAPPY_VERSION"
++version = "1.14"
diff --git a/dev-haskell/happy/happy-1.13.ebuild b/dev-haskell/happy/happy-1.13.ebuild
deleted file mode 100644
index cfc1e01eb5b5..000000000000
--- a/dev-haskell/happy/happy-1.13.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.13.ebuild,v 1.4 2004/06/24 22:15:05 agriffis Exp $
-
-DESCRIPTION="A yacc-like parser generator for Haskell"
-HOMEPAGE="http://haskell.org/happy/"
-SRC_URI="http://haskell.cs.yale.edu/happy/dist/1.13/happy-1.13-src.tar.gz"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86"
-IUSE=""
-
-DEPEND="virtual/ghc"
-RDEPEND=""
-
-src_unpack() {
- unpack ${A}
- bzcat ${FILESDIR}/happy-1.13-pragma.patch.bz2 | patch -p0
-}
-
-src_compile() {
- econf || die
-
- # "emake" does not work reliably. Probably due to the classic
- # dependency problem in make with parallel builds.
- make || die
-}
-
-src_install() {
- einstall || die
-}
diff --git a/dev-haskell/happy/happy-1.14.ebuild b/dev-haskell/happy/happy-1.14.ebuild
index c66f48124507..6001bd760647 100644
--- a/dev-haskell/happy/happy-1.14.ebuild
+++ b/dev-haskell/happy/happy-1.14.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.14.ebuild,v 1.3 2004/06/24 22:15:05 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/happy/happy-1.14.ebuild,v 1.4 2004/10/21 15:15:43 kosmikus Exp $
DESCRIPTION="A yacc-like parser generator for Haskell"
HOMEPAGE="http://haskell.org/happy/"
SRC_URI="http://haskell.cs.yale.edu/happy/dist/${PV}/${P}-src.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="virtual/ghc"
RDEPEND=""
+inherit base eutils
+
src_unpack() {
- unpack ${A}
+ base_src_unpack
+ epatch "${FILESDIR}/${P}-gcc3.4.patch"
}
src_compile() {
- econf || die
-
- # "emake" does not work reliably. Probably due to the classic
- # dependency problem in make with parallel builds.
- make || die
+ econf || die "configure failed"
+ emake -j1 || die "make failed"
}
src_install() {
- einstall || die
+ einstall || die "installation failed"
}