summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-12-24 15:35:57 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-12-24 15:35:57 +0000
commit62661705f17133e14ae5e43c813744b199c62351 (patch)
tree019a5827296b93084f3e5b213015a81f438c4d7c /dev-haskell/hdbc-postgresql
parentVersion bump. (diff)
downloadgentoo-2-62661705f17133e14ae5e43c813744b199c62351.tar.gz
gentoo-2-62661705f17133e14ae5e43c813744b199c62351.tar.bz2
gentoo-2-62661705f17133e14ae5e43c813744b199c62351.zip
Fix against ghc-7.6.
(Portage version: 2.2.0_alpha149_p1/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/hdbc-postgresql')
-rw-r--r--dev-haskell/hdbc-postgresql/ChangeLog7
-rw-r--r--dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch53
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild61
-rw-r--r--dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild6
4 files changed, 63 insertions, 64 deletions
diff --git a/dev-haskell/hdbc-postgresql/ChangeLog b/dev-haskell/hdbc-postgresql/ChangeLog
index 0d9be085736d..39df7ef7600a 100644
--- a/dev-haskell/hdbc-postgresql/ChangeLog
+++ b/dev-haskell/hdbc-postgresql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc-postgresql
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.20 2012/12/07 10:35:21 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/ChangeLog,v 1.21 2012/12/24 15:35:57 slyfox Exp $
+
+ 24 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org>
+ +files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch, -hdbc-postgresql-2.2.3.3.ebuild,
+ hdbc-postgresql-2.3.2.1.ebuild:
+ Fix against ghc-7.6.
07 Dec 2012; Sergei Trofimovich <slyfox@gentoo.org>
hdbc-postgresql-2.2.3.3.ebuild:
diff --git a/dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch b/dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch
new file mode 100644
index 000000000000..2f81f35c1410
--- /dev/null
+++ b/dev-haskell/hdbc-postgresql/files/HDBC-postgresql-2.3.2.1-ghc-7.6.patch
@@ -0,0 +1,53 @@
+--- HDBC-postgresql-2.3.2.1-orig/testsrc/TestSbasics.hs 2012-03-04 04:08:01.000000000 +1100
++++ HDBC-postgresql-2.3.2.1/testsrc/TestSbasics.hs 2012-10-13 11:08:27.482597846 +1100
+@@ -1,10 +1,14 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module TestSbasics(tests) where
+ import Test.HUnit
+ import Data.List
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -142,7 +146,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do sExecuteMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ sExecute qrysth []
+ sFetchAllRows qrysth >>= (assertEqual "rollback" [[Just "0"]])
+
+--- HDBC-postgresql-2.3.2.1-orig/testsrc/Testbasics.hs 2012-03-04 04:08:01.000000000 +1100
++++ HDBC-postgresql-2.3.2.1/testsrc/Testbasics.hs 2012-10-13 11:07:43.622396904 +1100
+@@ -1,9 +1,13 @@
++{-# LANGUAGE CPP, ScopedTypeVariables #-}
+ module Testbasics(tests) where
+ import Test.HUnit
+ import Database.HDBC
+ import TestUtils
+ import System.IO
+-import Control.Exception hiding (catch)
++#if !MIN_VERSION_base(4,6,0)
++import Prelude hiding (catch)
++#endif
++import Control.Exception
+
+ openClosedb = sqlTestCase $
+ do dbh <- connectDB
+@@ -140,7 +144,7 @@
+ -- Let's try a rollback.
+ catch (withTransaction dbh (\_ -> do executeMany sth rows
+ fail "Foo"))
+- (\_ -> return ())
++ (\(_::IOException) -> return ())
+ execute qrysth []
+ fetchAllRows qrysth >>= (assertEqual "rollback" [[SqlString "0"]])
+
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild
deleted file mode 100644
index b029aad3f4f5..000000000000
--- a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.2.3.3.ebuild,v 1.3 2012/12/07 10:35:21 slyfox Exp $
-
-# ebuild generated by hackport 0.2.12
-
-EAPI="2"
-
-CABAL_FEATURES="bin lib profile haddock hscolour"
-inherit haskell-cabal
-
-MY_PN="HDBC-postgresql"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="PostgreSQL driver for HDBC"
-HOMEPAGE="http://software.complete.org/hdbc-postgresql"
-SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="test" # requires configured postgresql
-
-hdbc_PV=$(get_version_component_range 1-2)
-
-RDEPEND=">=dev-lang/ghc-6.8.2
- =dev-haskell/hdbc-${hdbc_PV}*
- dev-haskell/mtl
- dev-haskell/parsec
- dev-haskell/utf8-string
- >=dev-db/postgresql-base-8"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-1.8
- test? ( dev-haskell/convertible
- dev-haskell/hunit
- dev-haskell/quickcheck
- dev-haskell/testpack
- )
- "
-
-S="${WORKDIR}/${MY_P}"
-
-src_configure() {
- cabal_src_configure $(cabal_flag test buildtests)
-}
-
-src_test() {
- # default tests
- haskell-cabal_src_test || die "cabal test failed"
-
- # built custom tests
- "${S}/dist/build/runtests/runtests" || die "unit tests failed"
-}
-
-src_install() {
- cabal_src_install
-
- # if tests were enabled, make sure the unit test driver is deleted
- rm -f "${ED}/usr/bin/runtests"
-}
diff --git a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
index 829c29f13834..3a8310b3c388 100644
--- a/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
+++ b/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild,v 1.4 2012/12/06 22:54:58 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc-postgresql/hdbc-postgresql-2.3.2.1.ebuild,v 1.5 2012/12/24 15:35:57 slyfox Exp $
EAPI=4
# ebuild generated by hackport 0.2.18.9999
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
-inherit haskell-cabal versionator
+inherit base haskell-cabal versionator
MY_PN="HDBC-postgresql"
MY_P="${MY_PN}-${PV}"
@@ -43,6 +43,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/${MY_P}"
+PATCHES=("${FILESDIR}/${MY_PN}-2.3.2.1-ghc-7.6.patch")
+
src_configure() {
cabal_src_configure $(cabal_flag test buildtests)
}