summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2015-04-03 23:52:02 +0000
committerMark Wright <gienah@gentoo.org>2015-04-03 23:52:02 +0000
commit8bc304dd9b52c0aa2b3af0847a029af60b8a7f21 (patch)
treef2603599020cb64bdd461f4403f232abff2bef1e /dev-haskell/hdbc
parentApply patch by Sergei Trofimovich to port testpack-2.1.3.0 to quickcheck-2.8 (diff)
downloadgentoo-2-8bc304dd9b52c0aa2b3af0847a029af60b8a7f21.tar.gz
gentoo-2-8bc304dd9b52c0aa2b3af0847a029af60b8a7f21.tar.bz2
gentoo-2-8bc304dd9b52c0aa2b3af0847a029af60b8a7f21.zip
Bump hdbc to 2.4.0.1
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/hdbc')
-rw-r--r--dev-haskell/hdbc/ChangeLog9
-rw-r--r--dev-haskell/hdbc/hdbc-2.4.0.1.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/dev-haskell/hdbc/ChangeLog b/dev-haskell/hdbc/ChangeLog
index 88d154571d39..e50af7a59562 100644
--- a/dev-haskell/hdbc/ChangeLog
+++ b/dev-haskell/hdbc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hdbc
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/ChangeLog,v 1.19 2014/07/25 08:58:35 slyfox Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/ChangeLog,v 1.20 2015/04/03 23:52:02 gienah Exp $
+
+*hdbc-2.4.0.1 (03 Apr 2015)
+
+ 03 Apr 2015; Mark Wright <gienah@gentoo.org> +hdbc-2.4.0.1.ebuild:
+ Bump hdbc to 2.4.0.1
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild b/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild
new file mode 100644
index 000000000000..26e903067f3f
--- /dev/null
+++ b/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdbc/hdbc-2.4.0.1.ebuild,v 1.1 2015/04/03 23:52:02 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+#hackport: flags: buildtests:test
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="HDBC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Haskell Database Connectivity"
+HOMEPAGE="https://github.com/hdbc/hdbc"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="test" # Tests do not compile with time 1.5
+
+RDEPEND=">=dev-haskell/convertible-1.1.0.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/text:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hunit:=[profile?]
+ >=dev-haskell/quickcheck-2.0:2=[profile?]
+ >=dev-haskell/testpack-2.0:=[profile?] )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag test buildtests)
+}
+
+src_test() {
+ # default tests
+ haskell-cabal_src_test || die "cabal test failed"
+
+ # built custom tests
+ "${S}/dist/build/runtests/runtests" || die "unit tests failed"
+}
+
+src_install() {
+ cabal_src_install
+
+ # if tests were enabled, make sure the unit test driver is deleted
+ rm -f "${ED}/usr/bin/runtests"
+}