summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-01-21 10:34:58 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-01-21 10:34:58 +0000
commit72e5d5433abcc6c2ba26f1a1af58f62f95d9bb5d (patch)
tree4bb3ea78f0554d082446cb2beb7c35934e0ff186 /dev-haskell/hmake
parentVersion bumped. (Manifest recommit) (diff)
downloadgentoo-2-72e5d5433abcc6c2ba26f1a1af58f62f95d9bb5d.tar.gz
gentoo-2-72e5d5433abcc6c2ba26f1a1af58f62f95d9bb5d.tar.bz2
gentoo-2-72e5d5433abcc6c2ba26f1a1af58f62f95d9bb5d.zip
Fixed bug #71713. Removed optional nhc98 dependency because nhc98 is currently masked.
Diffstat (limited to 'dev-haskell/hmake')
-rw-r--r--dev-haskell/hmake/ChangeLog7
-rw-r--r--dev-haskell/hmake/files/digest-hmake-3.071
-rw-r--r--dev-haskell/hmake/hmake-3.07.ebuild45
-rw-r--r--dev-haskell/hmake/hmake-3.08.ebuild40
4 files changed, 21 insertions, 72 deletions
diff --git a/dev-haskell/hmake/ChangeLog b/dev-haskell/hmake/ChangeLog
index 38aa21c2205f..db2e26fa338e 100644
--- a/dev-haskell/hmake/ChangeLog
+++ b/dev-haskell/hmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hmake
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.10 2005/01/01 18:05:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.11 2005/01/21 10:34:58 kosmikus Exp $
+
+ 21 Jan 2005; Andres Loeh <kosmikus@gentoo.org> -hmake-3.07.ebuild,
+ hmake-3.08.ebuild:
+ Restored gcc compatibility (bug #71713). Removed optional nhc98 dependency
+ for now.
01 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org> hmake-3.08.ebuild:
virtual/glibc -> virtual/libc
diff --git a/dev-haskell/hmake/files/digest-hmake-3.07 b/dev-haskell/hmake/files/digest-hmake-3.07
deleted file mode 100644
index 82ef897eed46..000000000000
--- a/dev-haskell/hmake/files/digest-hmake-3.07
+++ /dev/null
@@ -1 +0,0 @@
-MD5 db1f290731c075628f60a59667c97434 hmake-3.07.tar.gz 72561
diff --git a/dev-haskell/hmake/hmake-3.07.ebuild b/dev-haskell/hmake/hmake-3.07.ebuild
deleted file mode 100644
index 90e569985096..000000000000
--- a/dev-haskell/hmake/hmake-3.07.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.07.ebuild,v 1.6 2005/01/01 18:05:07 eradicator Exp $
-
-DESCRIPTION="a make tool for Haskell programs"
-HOMEPAGE="http://www.haskell.org/hmake/"
-SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
-
-LICENSE="nhc98"
-KEYWORDS="~x86"
-SLOT="0"
-IUSE="nhc98"
-
-# hmake can be build with either ghc or nhc98; we prefer ghc
-# unless a use flag tells us otherwise
-DEPEND="nhc98? ( dev-lang/nhc98 )
- !nhc98? ( virtual/ghc )"
-
-src_compile() {
- if use nhc98; then
- buildwith="--buildwith=nhc98"
- # Makefile is erroneous; we need to fix it
- pushd hmake-3.07
- mv Makefile Makefile.orig
- sed -e "s/^TARGETS.*=/TARGETS = hmake-nhc hi-nhc/" \
- Makefile.orig > Makefile
- popd
- else
- buildwith="--buildwith=ghc"
- fi
- # package uses non-standard configure, therefore econf does
- # not work ...
- ./configure \
- --prefix=/usr \
- --mandir=/usr/share/man/man1 \
- ${buildwith} || die "./configure failed"
-
- # emake tested; does not work
- make || die "make failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die
- dohtml docs/hmake/*
-}
diff --git a/dev-haskell/hmake/hmake-3.08.ebuild b/dev-haskell/hmake/hmake-3.08.ebuild
index 135932f26a20..8c4a32322f38 100644
--- a/dev-haskell/hmake/hmake-3.08.ebuild
+++ b/dev-haskell/hmake/hmake-3.08.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.08.ebuild,v 1.11 2005/01/01 18:05:07 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.08.ebuild,v 1.12 2005/01/21 10:34:58 kosmikus Exp $
inherit base fixheadtails
@@ -11,17 +11,13 @@ SRC_URI="http://www.cs.york.ac.uk/ftpdir/pub/haskell/hmake/${P}.tar.gz"
LICENSE="nhc98"
KEYWORDS="~x86"
SLOT="0"
-IUSE="nhc98 readline"
+IUSE=""
-# hmake can be build with either ghc or nhc98; we prefer ghc
-# unless a use flag tells us otherwise
-DEPEND="nhc98? ( dev-lang/nhc98 )
- !nhc98? ( virtual/ghc )
- readline? ( sys-libs/readline )"
-RDEPEND="readline? ( sys-libs/readline )
+DEPEND="virtual/ghc
+ sys-libs/readline"
+RDEPEND="sys-libs/readline
virtual/libc
- !nhc98? ( dev-libs/gmp
- sys-libs/readline )"
+ dev-libs/gmp"
# if using readline, hmake depends also on ncurses; but
# readline already has this dependency
@@ -30,16 +26,17 @@ src_compile() {
local buildwith
local arch
- if use nhc98; then
- buildwith="--buildwith=nhc98"
- else
- buildwith="--buildwith=ghc"
- fi
+ buildwith="--buildwith=ghc"
# fix all head/tail declarations
- cd ${S}
+ sed -i 's/tail -1/tail -n 1/' src/hmake/MkConfig.hs
+ # the line above prevents current fixheadtails.eclass from doing nonsense;
+ # double space before -n is significant
ht_fix_all
+ # fix string gaps
+ sed -i -e 's/\\ $/" ++/' -e 's/^\\/ "/' src/interpreter/HInteractive.hs
+
# package uses non-standard configure, therefore econf does
# not work ...
./configure \
@@ -47,18 +44,11 @@ src_compile() {
--mandir=/usr/share/man/man1 \
${buildwith} || die "./configure failed"
- if ! use readline; then
- arch="`script/harch`"
- # manually override readline configuration
- einfo "Disabling readline ..."
- echo "READLINE=\"\"" >> lib/${arch}/config
- fi
-
# emake tested; does not work
- make || die "make failed"
+ emake -j1 || die "make failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR=${D} install || die "make install failed"
dohtml docs/hmake/*
}