summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-28 02:45:40 +0000
committerMark Wright <gienah@gentoo.org>2013-09-28 02:45:40 +0000
commit691fa492dd535f682d398c8c677b796ccd885cfb (patch)
tree4d8526b24cd49378422854aabc99c3e586c5c628 /dev-haskell/missingh
parentInitial import. (diff)
downloadgentoo-2-691fa492dd535f682d398c8c677b796ccd885cfb.tar.gz
gentoo-2-691fa492dd535f682d398c8c677b796ccd885cfb.tar.bz2
gentoo-2-691fa492dd535f682d398c8c677b796ccd885cfb.zip
Bump missingh to 1.2.0.2, patched for ghc 6.12, ghc 7.7.20130927 development snapshot, and hopefully ghc 7.8.1 when it is released
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/missingh')
-rw-r--r--dev-haskell/missingh/ChangeLog9
-rw-r--r--dev-haskell/missingh/files/missingh-1.2.0.2-ghc-7.7.patch47
-rw-r--r--dev-haskell/missingh/missingh-1.2.0.2.ebuild52
3 files changed, 107 insertions, 1 deletions
diff --git a/dev-haskell/missingh/ChangeLog b/dev-haskell/missingh/ChangeLog
index a97c9b518d7e..008f70f2f603 100644
--- a/dev-haskell/missingh/ChangeLog
+++ b/dev-haskell/missingh/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/missingh
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/missingh/ChangeLog,v 1.28 2013/07/27 21:16:54 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/missingh/ChangeLog,v 1.29 2013/09/28 02:45:40 gienah Exp $
+
+*missingh-1.2.0.2 (28 Sep 2013)
+
+ 28 Sep 2013; Mark Wright <gienah@gentoo.org>
+ +files/missingh-1.2.0.2-ghc-7.7.patch, +missingh-1.2.0.2.ebuild:
+ Bump missingh to 1.2.0.2, patched for ghc 6.12, ghc 7.7.20130927 development
+ snapshot, and hopefully ghc 7.8.1 when it is released
27 Jul 2013; Sergei Trofimovich <slyfox@gentoo.org> missingh-1.2.0.0.ebuild:
Allow dev-haskell/quickcheck:2 in tests as well.
diff --git a/dev-haskell/missingh/files/missingh-1.2.0.2-ghc-7.7.patch b/dev-haskell/missingh/files/missingh-1.2.0.2-ghc-7.7.patch
new file mode 100644
index 000000000000..0b249462fa51
--- /dev/null
+++ b/dev-haskell/missingh/files/missingh-1.2.0.2-ghc-7.7.patch
@@ -0,0 +1,47 @@
+--- MissingH-1.2.0.2-orig/src/System/Cmd/Utils.hs 2013-08-22 00:35:27.000000000 +1000
++++ MissingH-1.2.0.2/src/System/Cmd/Utils.hs 2013-09-28 01:17:29.697333968 +1000
+@@ -325,7 +325,11 @@
+ Just (Exited (ExitSuccess)) -> return ()
+ Just (Exited (ExitFailure fc)) ->
+ cmdfailed funcname fp args fc
++#if (__GLASGOW_HASKELL__ >= 707)
++ Just (Terminated sig _) ->
++#else
+ Just (Terminated sig) ->
++#endif
+ warnfail fp args $ "Terminated by signal " ++ show sig
+ Just (Stopped sig) ->
+ warnfail fp args $ "Stopped by signal " ++ show sig
+@@ -351,7 +355,11 @@
+ case ec of
+ Exited ExitSuccess -> return ()
+ Exited (ExitFailure fc) -> cmdfailed "safeSystem" command args fc
++#if (__GLASGOW_HASKELL__ >= 707)
++ Terminated s _ -> cmdsignalled "safeSystem" command args s
++#else
+ Terminated s -> cmdsignalled "safeSystem" command args s
++#endif
+ Stopped s -> cmdsignalled "safeSystem" command args s
+ #endif
+
+--- MissingH-1.2.0.2-orig/testsrc/Eithertest.hs 2013-08-22 00:35:27.000000000 +1000
++++ MissingH-1.2.0.2/testsrc/Eithertest.hs 2013-09-28 01:19:32.177332800 +1000
+@@ -6,6 +6,7 @@
+ For license and copyright information, see the file LICENSE
+
+ -}
++{-# LANGUAGE CPP #-}
+
+ module Eithertest(tests) where
+ import Test.HUnit
+@@ -13,8 +14,10 @@
+ import Test.HUnit.Tools
+ import Control.Exception
+
++#if (__GLASGOW_HASKELL__ < 707)
+ instance Eq ErrorCall where
+ (ErrorCall x) == (ErrorCall y) = x == y
++#endif
+
+ test_maybeToEither =
+ let f msg inp exp = TestLabel msg $ TestCase $ assertEqual "" exp inp in
diff --git a/dev-haskell/missingh/missingh-1.2.0.2.ebuild b/dev-haskell/missingh/missingh-1.2.0.2.ebuild
new file mode 100644
index 000000000000..1b8e4256e7c3
--- /dev/null
+++ b/dev-haskell/missingh/missingh-1.2.0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/missingh/missingh-1.2.0.2.ebuild,v 1.1 2013/09/28 02:45:39 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit base haskell-cabal
+
+MY_PN="MissingH"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Large utility library"
+HOMEPAGE="http://software.complete.org/missingh"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux"
+IUSE=""
+
+RDEPEND="dev-haskell/hslogger:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-lang/ghc-6.12.1:=
+"
+DEPEND="${RDEPEND}
+ virtual/libiconv
+ >=dev-haskell/cabal-1.8.0.2
+ test? ( dev-haskell/quickcheck
+ dev-haskell/testpack )
+"
+
+# libiconv is needed for the trick below to make it compile with ghc-6.12
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=("${FILESDIR}/${PN}-1.2.0.2-ghc-7.7.patch")
+
+src_prepare() {
+ base_src_prepare
+ # (non-ASCII non-UTF-8 source breaks hscolour)
+ cd src/System/Time
+ mv ParseDate.hs ParseDate.hs.ISO-8859-1
+ iconv -f ISO-8859-1 -t UTF-8 -c ParseDate.hs.ISO-8859-1 > ParseDate.hs || die "unable to recode ParseDate.hs to UTF-8"
+}