summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 06:11:44 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 06:11:44 +0000
commitac9508e46d21b1f1533f31b05dde911638381932 (patch)
treeb4d92627bf4495e5b19559c1b6897bd5e3f00fcc /dev-haskell/snap-core
parentVersion bump. (diff)
downloadgentoo-2-ac9508e46d21b1f1533f31b05dde911638381932.tar.gz
gentoo-2-ac9508e46d21b1f1533f31b05dde911638381932.tar.bz2
gentoo-2-ac9508e46d21b1f1533f31b05dde911638381932.zip
Loosen text dependency in snap-core-0.9.6.3-r1
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/snap-core')
-rw-r--r--dev-haskell/snap-core/ChangeLog7
-rw-r--r--dev-haskell/snap-core/snap-core-0.9.6.3-r1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/dev-haskell/snap-core/ChangeLog b/dev-haskell/snap-core/ChangeLog
index 079517d670a9..8b325fccc50f 100644
--- a/dev-haskell/snap-core/ChangeLog
+++ b/dev-haskell/snap-core/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/snap-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/ChangeLog,v 1.3 2014/07/25 08:58:38 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/ChangeLog,v 1.4 2014/12/14 06:11:44 gienah Exp $
+
+*snap-core-0.9.6.3-r1 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +snap-core-0.9.6.3-r1.ebuild:
+ Loosen text dependency in snap-core-0.9.6.3-r1
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> metadata.xml:
Drop redundant '<maintainer>' field, leave only '<herd>'.
diff --git a/dev-haskell/snap-core/snap-core-0.9.6.3-r1.ebuild b/dev-haskell/snap-core/snap-core-0.9.6.3-r1.ebuild
new file mode 100644
index 000000000000..8f1d2c291b16
--- /dev/null
+++ b/dev-haskell/snap-core/snap-core-0.9.6.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/snap-core/snap-core-0.9.6.3-r1.ebuild,v 1.1 2014/12/14 06:11:44 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Snap: A Haskell Web Framework (core interfaces and types)"
+HOMEPAGE="http://snapframework.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug portable"
+
+RDEPEND=">=dev-haskell/attoparsec-0.10:=[profile?] <dev-haskell/attoparsec-0.13:=[profile?]
+ >=dev-haskell/attoparsec-enumerator-0.3:=[profile?] <dev-haskell/attoparsec-enumerator-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-enumerator-0.2:=[profile?] <dev-haskell/blaze-builder-enumerator-0.3:=[profile?]
+ >=dev-haskell/case-insensitive-0.3:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
+ >=dev-haskell/enumerator-0.4.15:=[profile?] <dev-haskell/enumerator-0.5:=[profile?]
+ >=dev-haskell/hunit-1.2:=[profile?] <dev-haskell/hunit-2:=[profile?]
+ >=dev-haskell/monadcatchio-transformers-0.2.1:=[profile?] <dev-haskell/monadcatchio-transformers-0.4:=[profile?]
+ >=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-2:=[profile?]
+ >=dev-haskell/regex-posix-0.95:=[profile?] <dev-haskell/regex-posix-1:=[profile?]
+ >=dev-haskell/text-0.11:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?] <dev-haskell/unix-compat-0.5:=[profile?]
+ >=dev-haskell/unordered-containers-0.1.4.3:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
+ >=dev-haskell/vector-0.6:=[profile?] <dev-haskell/vector-0.11:=[profile?]
+ >=dev-haskell/zlib-enum-0.2.1:=[profile?] <dev-haskell/zlib-enum-0.3:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ || ( ( >=dev-haskell/hashable-1.1:=[profile?] <dev-haskell/hashable-1.2:=[profile?] )
+ ( >=dev-haskell/hashable-1.2.1:=[profile?] <dev-haskell/hashable-1.3:=[profile?] ) )
+ !portable? ( >=dev-haskell/bytestring-mmap-0.2.2:=[profile?] <dev-haskell/bytestring-mmap-0.3:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+"
+
+src_prepare() {
+ cabal_chdeps \
+ 'text >= 0.11 && < 1.2' 'text >= 0.11'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag debug debug) \
+ $(cabal_flag portable portable)
+}