summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-12 20:55:33 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-12 20:55:33 +0000
commit488aed13b9f37cd6387fd10b2cf761319f1eab06 (patch)
treeaed02beeca8980c2d1e93e91e9d5a786855af255 /dev-haskell/tasty
parentVersion bump, readline is needed when client is built (#504038 by Richard Li)... (diff)
downloadgentoo-2-488aed13b9f37cd6387fd10b2cf761319f1eab06.tar.gz
gentoo-2-488aed13b9f37cd6387fd10b2cf761319f1eab06.tar.bz2
gentoo-2-488aed13b9f37cd6387fd10b2cf761319f1eab06.zip
new versions
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/tasty')
-rw-r--r--dev-haskell/tasty/ChangeLog11
-rw-r--r--dev-haskell/tasty/tasty-0.7.ebuild38
-rw-r--r--dev-haskell/tasty/tasty-0.8.ebuild38
3 files changed, 85 insertions, 2 deletions
diff --git a/dev-haskell/tasty/ChangeLog b/dev-haskell/tasty/ChangeLog
index db451a14e051..50d9dbe606f2 100644
--- a/dev-haskell/tasty/ChangeLog
+++ b/dev-haskell/tasty/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-haskell/tasty
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/ChangeLog,v 1.4 2013/12/11 13:52:52 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/ChangeLog,v 1.5 2014/03/12 20:55:33 qnikst Exp $
+
+*tasty-0.8 (12 Mar 2014)
+*tasty-0.7 (12 Mar 2014)
+
+ 12 Mar 2014; Alexander Vershilov <qnikst@gentoo.org> +tasty-0.7.ebuild,
+ +tasty-0.8.ebuild:
+ new versions
*tasty-0.5.2 (11 Dec 2013)
diff --git a/dev-haskell/tasty/tasty-0.7.ebuild b/dev-haskell/tasty/tasty-0.7.ebuild
new file mode 100644
index 000000000000..bf1c894d59ee
--- /dev/null
+++ b/dev-haskell/tasty/tasty-0.7.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/tasty-0.7.ebuild,v 1.1 2014/03/12 20:55:33 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="http://hackage.haskell.org/package/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+colors"
+
+RDEPEND=">=dev-haskell/deepseq-1.3:=[profile?]
+ >=dev-haskell/either-4.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ >=dev-haskell/regex-tdfa-1.1.8:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ colors? ( >=dev-haskell/ansi-terminal-0.6.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag colors colors)
+}
diff --git a/dev-haskell/tasty/tasty-0.8.ebuild b/dev-haskell/tasty/tasty-0.8.ebuild
new file mode 100644
index 000000000000..131a5aff885c
--- /dev/null
+++ b/dev-haskell/tasty/tasty-0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tasty/tasty-0.8.ebuild,v 1.1 2014/03/12 20:55:33 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Modern and extensible testing framework"
+HOMEPAGE="http://documentup.com/feuerbach/tasty"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+colors"
+
+RDEPEND=">=dev-haskell/async-2.0:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/optparse-applicative-0.6:=[profile?]
+ >=dev-haskell/regex-tdfa-1.2:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?]
+ >=dev-haskell/tagged-0.5:=[profile?]
+ >=dev-haskell/unbounded-delays-0.1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+ colors? ( >=dev-haskell/ansi-terminal-0.6.1:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag colors colors)
+}