summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-03-09 13:12:38 +0000
committerMark Wright <gienah@gentoo.org>2014-03-09 13:12:38 +0000
commitdfcd331d8cd41406cc7b54ce7011dcc769edf2da (patch)
tree0fe2d909f93228d9a9fe86441949a1976fe3b284 /dev-haskell/warp-tls
parentBump warp to 2.1.0 (diff)
downloadgentoo-2-dfcd331d8cd41406cc7b54ce7011dcc769edf2da.tar.gz
gentoo-2-dfcd331d8cd41406cc7b54ce7011dcc769edf2da.tar.bz2
gentoo-2-dfcd331d8cd41406cc7b54ce7011dcc769edf2da.zip
Bump warp-tls to 2.0.3.1
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/warp-tls')
-rw-r--r--dev-haskell/warp-tls/ChangeLog9
-rw-r--r--dev-haskell/warp-tls/warp-tls-2.0.3.1.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-haskell/warp-tls/ChangeLog b/dev-haskell/warp-tls/ChangeLog
index 6dde43e97357..6f0c02be2aee 100644
--- a/dev-haskell/warp-tls/ChangeLog
+++ b/dev-haskell/warp-tls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/warp-tls
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp-tls/ChangeLog,v 1.1 2013/12/11 06:52:05 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp-tls/ChangeLog,v 1.2 2014/03/09 13:12:38 gienah Exp $
+
+*warp-tls-2.0.3.1 (09 Mar 2014)
+
+ 09 Mar 2014; Mark Wright <gienah@gentoo.org> +warp-tls-2.0.3.1.ebuild:
+ Bump warp-tls to 2.0.3.1
*warp-tls-2.0.0 (11 Dec 2013)
diff --git a/dev-haskell/warp-tls/warp-tls-2.0.3.1.ebuild b/dev-haskell/warp-tls/warp-tls-2.0.3.1.ebuild
new file mode 100644
index 000000000000..4cc3a8f276e8
--- /dev/null
+++ b/dev-haskell/warp-tls/warp-tls-2.0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp-tls/warp-tls-2.0.3.1.ebuild,v 1.1 2014/03/09 13:12:38 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+#hackport: flags: +tls_1_1_3
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="HTTP over SSL/TLS support for Warp via the TLS package"
+HOMEPAGE="http://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/conduit-0.5:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/cprng-aes-0.5.0:=[profile?]
+ >=dev-haskell/data-default-class-0.0.1:=[profile?]
+ >=dev-haskell/network-2.2.1:=[profile?]
+ >=dev-haskell/network-conduit-0.6:=[profile?] <dev-haskell/network-conduit-1.1:=[profile?]
+ >=dev-haskell/tls-1.2.1:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ >=dev-haskell/wai-2.0:=[profile?] <dev-haskell/wai-2.2:=[profile?]
+ >=dev-haskell/warp-2.0.2:=[profile?] <dev-haskell/warp-2.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6.0.3
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=tls_1_1_3
+}