summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-01-01 08:15:43 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-01-01 08:15:43 +0000
commita5ef2749dcf5c0c5c72cb03bca9033dc06163168 (patch)
treefdec44643bc951f74cff979e5ca5f06c7695d1d9 /dev-haskell/x11
parentupdate to eapi5 and distutils-r1 (diff)
downloadgentoo-2-a5ef2749dcf5c0c5c72cb03bca9033dc06163168.tar.gz
gentoo-2-a5ef2749dcf5c0c5c72cb03bca9033dc06163168.tar.bz2
gentoo-2-a5ef2749dcf5c0c5c72cb03bca9033dc06163168.zip
dev-haskell/x11 version bump
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-haskell/x11')
-rw-r--r--dev-haskell/x11/ChangeLog9
-rw-r--r--dev-haskell/x11/x11-1.6.0.2.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-haskell/x11/ChangeLog b/dev-haskell/x11/ChangeLog
index d1c70a00cefe..56011280801d 100644
--- a/dev-haskell/x11/ChangeLog
+++ b/dev-haskell/x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/x11
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.27 2012/12/16 18:51:52 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.28 2013/01/01 08:15:43 qnikst Exp $
+
+*x11-1.6.0.2 (01 Jan 2013)
+
+ 01 Jan 2013; <qnikst@gentoo.org> +x11-1.6.0.2.ebuild:
+ dev-haskell/x11 version bump
16 Dec 2012; Agostino Sarubbo <ago@gentoo.org> x11-1.5.0.1.ebuild:
Stable for x86, wrt bug #447462
diff --git a/dev-haskell/x11/x11-1.6.0.2.ebuild b/dev-haskell/x11/x11-1.6.0.2.ebuild
new file mode 100644
index 000000000000..ef3f7ce70d52
--- /dev/null
+++ b/dev-haskell/x11/x11-1.6.0.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.6.0.2.ebuild,v 1.1 2013/01/01 08:15:43 qnikst Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="https://github.com/haskell-pkg-janitors/X11"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~ppc64 ~ppc-macos ~x86-linux"
+IUSE="xinerama"
+
+RDEPEND="dev-haskell/syb[profile?]
+ >=dev-lang/ghc-6.8.2
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure --configure-option=$(use_with xinerama)
+}