summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDuncan Coutts <dcoutts@gentoo.org>2007-12-13 05:50:33 +0000
committerDuncan Coutts <dcoutts@gentoo.org>2007-12-13 05:50:33 +0000
commit89fec33049eb2c7f13ce8a954008804d3348607a (patch)
treee54af12a7f2a2d0118fa1b8f9c01e09f4592fd93 /dev-haskell/xhtml
parentUpdates for upward compatability with cabal-1.2 and ghc-6.8 (diff)
downloadgentoo-2-89fec33049eb2c7f13ce8a954008804d3348607a.tar.gz
gentoo-2-89fec33049eb2c7f13ce8a954008804d3348607a.tar.bz2
gentoo-2-89fec33049eb2c7f13ce8a954008804d3348607a.zip
Updates for upward compatability with cabal-1.2 and ghc-6.8
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell/xhtml')
-rw-r--r--dev-haskell/xhtml/ChangeLog6
-rw-r--r--dev-haskell/xhtml/xhtml-2006.9.13.ebuild7
-rw-r--r--dev-haskell/xhtml/xhtml-3000.0.2.ebuild5
3 files changed, 13 insertions, 5 deletions
diff --git a/dev-haskell/xhtml/ChangeLog b/dev-haskell/xhtml/ChangeLog
index 9519c6843ff3..619ba3243175 100644
--- a/dev-haskell/xhtml/ChangeLog
+++ b/dev-haskell/xhtml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/xhtml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/ChangeLog,v 1.9 2007/12/12 13:17:42 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/ChangeLog,v 1.10 2007/12/13 05:50:33 dcoutts Exp $
+
+ 13 Dec 2007; Duncan Coutts <dcoutts@gentoo.org> xhtml-2006.9.13.ebuild,
+ xhtml-3000.0.2.ebuild:
+ Updates for upward compatability with cabal-1.2 and ghc-6.8
12 Dec 2007; Ferris McCormick <fmccor@gentoo.org> xhtml-3000.0.2.ebuild:
Sparc stable --- part of Bug #201984.
diff --git a/dev-haskell/xhtml/xhtml-2006.9.13.ebuild b/dev-haskell/xhtml/xhtml-2006.9.13.ebuild
index 7f622e648967..3c3ff59a85df 100644
--- a/dev-haskell/xhtml/xhtml-2006.9.13.ebuild
+++ b/dev-haskell/xhtml/xhtml-2006.9.13.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/xhtml-2006.9.13.ebuild,v 1.4 2007/07/08 15:50:26 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/xhtml-2006.9.13.ebuild,v 1.5 2007/12/13 05:50:33 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -19,3 +19,8 @@ IUSE=""
DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
+
+src_unpack() {
+ unpack "${A}"
+ cabal-mksetup
+}
diff --git a/dev-haskell/xhtml/xhtml-3000.0.2.ebuild b/dev-haskell/xhtml/xhtml-3000.0.2.ebuild
index 6d71bc7702c5..148d17f12b01 100644
--- a/dev-haskell/xhtml/xhtml-3000.0.2.ebuild
+++ b/dev-haskell/xhtml/xhtml-3000.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/xhtml-3000.0.2.ebuild,v 1.5 2007/12/12 13:17:42 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/xhtml/xhtml-3000.0.2.ebuild,v 1.6 2007/12/13 05:50:33 dcoutts Exp $
CABAL_FEATURES="lib profile haddock"
inherit haskell-cabal
@@ -20,8 +20,7 @@ DEPEND=">=dev-lang/ghc-6.6"
S="${WORKDIR}/ghc-${GHC_PV}/libraries/${PN}"
-# Sadly Setup.hs in the ghc-6.6.1 extralibs was not tested with Cabal-1.1.6.x
src_unpack() {
unpack "${A}"
- sed -i -e "/type Hook/ s/UserHooks/Maybe UserHooks/" "${S}/Setup.hs"
+ cabal-mksetup
}