summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2003-04-22 08:26:25 +0000
committerAndres Loeh <kosmikus@gentoo.org>2003-04-22 08:26:25 +0000
commit6f4598346c559b324b1293a3ab35c66e2aa577a3 (patch)
tree7bd76db08d9292c01088ce99c606651c92f2d831 /dev-haskell
parentadded dev-haskell category and nhc98 USE flag for Haskell-related ebuilds (diff)
downloadgentoo-2-6f4598346c559b324b1293a3ab35c66e2aa577a3.tar.gz
gentoo-2-6f4598346c559b324b1293a3ab35c66e2aa577a3.tar.bz2
gentoo-2-6f4598346c559b324b1293a3ab35c66e2aa577a3.zip
added hdoc ebuild
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/hdoc/ChangeLog11
-rw-r--r--dev-haskell/hdoc/files/digest-hdoc-0.8.21
-rw-r--r--dev-haskell/hdoc/hdoc-0.8.2.ebuild39
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/hdoc/ChangeLog b/dev-haskell/hdoc/ChangeLog
new file mode 100644
index 000000000000..acffc7835dd9
--- /dev/null
+++ b/dev-haskell/hdoc/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-haskell/hdoc
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdoc/ChangeLog,v 1.1 2003/04/22 08:26:25 kosmikus Exp $
+
+*hdoc-0.8.2 (22 Apr 2003)
+
+ 22 Apr 2003; Andres Loeh <kosmikus@gentoo.org> all :
+
+ Initial import. Thanks to Thomas L. Bevan <tom@regex.com.au> for submitting an
+ ebuild (#3970). hdoc is a tool to generate documentation automatically from
+ Haskell source files, much like javadoc.
diff --git a/dev-haskell/hdoc/files/digest-hdoc-0.8.2 b/dev-haskell/hdoc/files/digest-hdoc-0.8.2
new file mode 100644
index 000000000000..cddf1119fae8
--- /dev/null
+++ b/dev-haskell/hdoc/files/digest-hdoc-0.8.2
@@ -0,0 +1 @@
+MD5 3e71a2f29c3ebea04888071cbf8c7edf hdoc-0.8.2.tar.gz 215643
diff --git a/dev-haskell/hdoc/hdoc-0.8.2.ebuild b/dev-haskell/hdoc/hdoc-0.8.2.ebuild
new file mode 100644
index 000000000000..02d80abca947
--- /dev/null
+++ b/dev-haskell/hdoc/hdoc-0.8.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hdoc/hdoc-0.8.2.ebuild,v 1.1 2003/04/22 08:26:25 kosmikus Exp $
+
+DESCRIPTION="A documentation generator for Haskell"
+
+HOMEPAGE="http://www.fmi.uni-passau.de/~groessli/hdoc/"
+
+LICENSE="GPL-2"
+
+IUSE="nhc98"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND="!nhc98? ( virtual/ghc )
+ nhc98? ( dev-lang/nhc98
+ dev-haskell/hmake )"
+RDEPEND="virtual/glibc"
+
+SRC_URI="http://www.fmi.uni-passau.de/~groessli/hdoc/${P}.tar.gz"
+
+src_compile() {
+ if [ "`use nhc98`" ] ; then
+ buildwith="--with-compiler=nhc98"
+ # I don't see why nhc98 complains in the presence of this
+ # file, but I am certain that it does no harm to remove it ...
+ rm hsparser/HsParser.ly
+ else
+ buildwith="--with-compiler=ghc"
+ fi
+ econf ${buildwith} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ # DESTDIR does not work, but only bindir is used ...
+ make bindir=${D}/usr/bin install || die
+ dodoc docs/hdoc.pdf
+}