summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 06:49:21 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 06:49:21 +0000
commit95e479021a8d54ae47eeb48c01346385d067f2de (patch)
treedf2bbe76a2f24427165b7c59fa0ad90c896d96a7 /dev-haskell
parentBump pandoc-citeproc to 0.2 (diff)
downloadgentoo-2-95e479021a8d54ae47eeb48c01346385d067f2de.tar.gz
gentoo-2-95e479021a8d54ae47eeb48c01346385d067f2de.tar.bz2
gentoo-2-95e479021a8d54ae47eeb48c01346385d067f2de.zip
Bump wai-app-static to 2.0.0.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/wai-app-static/ChangeLog7
-rw-r--r--dev-haskell/wai-app-static/wai-app-static-2.0.0.1.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/dev-haskell/wai-app-static/ChangeLog b/dev-haskell/wai-app-static/ChangeLog
index ba1810ea10a6..680a8e6e2337 100644
--- a/dev-haskell/wai-app-static/ChangeLog
+++ b/dev-haskell/wai-app-static/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/wai-app-static
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-app-static/ChangeLog,v 1.2 2013/09/13 06:41:09 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-app-static/ChangeLog,v 1.3 2013/12/11 06:49:21 gienah Exp $
+
+*wai-app-static-2.0.0.1 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +wai-app-static-2.0.0.1.ebuild:
+ Bump wai-app-static to 2.0.0.1
*wai-app-static-1.3.2.1 (13 Sep 2013)
diff --git a/dev-haskell/wai-app-static/wai-app-static-2.0.0.1.ebuild b/dev-haskell/wai-app-static/wai-app-static-2.0.0.1.ebuild
new file mode 100644
index 000000000000..1011963fdd5a
--- /dev/null
+++ b/dev-haskell/wai-app-static/wai-app-static-2.0.0.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wai-app-static/wai-app-static-2.0.0.1.ebuild,v 1.1 2013/12/11 06:49:21 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="WAI application for static serving"
+HOMEPAGE="http://www.yesodweb.com/book/web-application-interface"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="print"
+
+RDEPEND=">=dev-haskell/base64-bytestring-0.1:=[profile?]
+ >=dev-haskell/blaze-builder-0.2.1.4:=[profile?]
+ >=dev-haskell/blaze-html-0.5:=[profile?]
+ >=dev-haskell/blaze-markup-0.5.1:=[profile?]
+ >=dev-haskell/cereal-0.3.5:=[profile?]
+ >=dev-haskell/crypto-api-0.12.2:=[profile?]
+ >=dev-haskell/crypto-conduit-0.4:=[profile?]
+ >=dev-haskell/cryptohash-cryptoapi-0.1.0:=[profile?]
+ >=dev-haskell/file-embed-0.0.3.1:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/mime-types-0.1:=[profile?] <dev-haskell/mime-types-0.2:=[profile?]
+ >=dev-haskell/system-fileio-0.3:=[profile?]
+ >=dev-haskell/system-filepath-0.4:=[profile?]
+ >=dev-haskell/text-0.7:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ >=dev-haskell/unordered-containers-0.2:=[profile?]
+ >=dev-haskell/wai-2.0:=[profile?] <dev-haskell/wai-2.1:=[profile?]
+ >=dev-haskell/zlib-0.5:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/network
+ dev-haskell/wai-test )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag print print)
+}