summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:31:41 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:31:41 +0000
commit99f5b49035e59668140122eebc408648e519119d (patch)
tree20fd753490c9187eed98d8e726808cc0b86180d2 /dev-haskell
parentadd live ebuild (diff)
downloadgentoo-2-99f5b49035e59668140122eebc408648e519119d.tar.gz
gentoo-2-99f5b49035e59668140122eebc408648e519119d.tar.bz2
gentoo-2-99f5b49035e59668140122eebc408648e519119d.zip
dev-haskell/pwstore-fast: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/pwstore-fast/ChangeLog9
-rw-r--r--dev-haskell/pwstore-fast/metadata.xml18
-rw-r--r--dev-haskell/pwstore-fast/pwstore-fast-2.3.ebuild26
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-haskell/pwstore-fast/ChangeLog b/dev-haskell/pwstore-fast/ChangeLog
new file mode 100644
index 000000000000..3d1a185e127f
--- /dev/null
+++ b/dev-haskell/pwstore-fast/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/pwstore-fast
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pwstore-fast/ChangeLog,v 1.1 2013/08/26 12:31:41 qnikst Exp $
+
+*pwstore-fast-2.3 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +pwstore-fast-2.3.ebuild:
+ dev-haskell/pwstore-fast: initial layout
diff --git a/dev-haskell/pwstore-fast/metadata.xml b/dev-haskell/pwstore-fast/metadata.xml
new file mode 100644
index 000000000000..10aff569f8b7
--- /dev/null
+++ b/dev-haskell/pwstore-fast/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ To store passwords securely, they should be salted,
+ then hashed with a slow hash function. This library
+ uses PBKDF1-SHA256, and handles all the details.
+ It uses the cryptohash package for speed; if you need
+ a pure Haskell library, pwstore-purehaskell has the
+ exact same API, but uses only pure Haskell. It is
+ about 25 times slower than this package, but still
+ quite usable.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/pwstore-fast/pwstore-fast-2.3.ebuild b/dev-haskell/pwstore-fast/pwstore-fast-2.3.ebuild
new file mode 100644
index 000000000000..49505b6ab3f0
--- /dev/null
+++ b/dev-haskell/pwstore-fast/pwstore-fast-2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/pwstore-fast/pwstore-fast-2.3.ebuild,v 1.1 2013/08/26 12:31:41 qnikst Exp $
+
+EAPI=4
+
+# ebuild generated by hackport 0.2.18.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Secure password storage."
+HOMEPAGE="https://github.com/PeterScott/pwstore"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/base64-bytestring-0.1[profile?]
+ >=dev-haskell/cryptohash-0.6[profile?]
+ >=dev-haskell/random-1[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"