summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-05-29 08:21:16 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-05-29 08:21:16 +0000
commitaebe773cd2095d6cc0153b39953498f8fa241388 (patch)
tree9cb752659ebfe47b9875c1aa79c0928e0ae2d7aa /dev-haskell
parentapp-office/scribus: Backport upstream fix for deprecated dev-python/imaging u... (diff)
downloadgentoo-2-aebe773cd2095d6cc0153b39953498f8fa241388.tar.gz
gentoo-2-aebe773cd2095d6cc0153b39953498f8fa241388.tar.bz2
gentoo-2-aebe773cd2095d6cc0153b39953498f8fa241388.zip
fix haddock-2.13.2 build in absence of alex and happy (due #471384)
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/haddock/ChangeLog8
-rw-r--r--dev-haskell/haddock/haddock-2.13.2-r1.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-haskell/haddock/ChangeLog b/dev-haskell/haddock/ChangeLog
index 9f9ce6b99f1e..f5212f9067a5 100644
--- a/dev-haskell/haddock/ChangeLog
+++ b/dev-haskell/haddock/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/haddock
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.107 2013/05/26 04:07:08 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/ChangeLog,v 1.108 2013/05/29 08:21:16 qnikst Exp $
+
+*haddock-2.13.2-r1 (29 May 2013)
+
+ 29 May 2013; Alexander Vershilov <qnikst@gentoo.org>
+ +haddock-2.13.2-r1.ebuild:
+ fix haddock-2.13.2 build in absence of alex and happy (due #471384)
*haddock-2.13.2 (26 May 2013)
diff --git a/dev-haskell/haddock/haddock-2.13.2-r1.ebuild b/dev-haskell/haddock/haddock-2.13.2-r1.ebuild
new file mode 100644
index 000000000000..580d17f4d527
--- /dev/null
+++ b/dev-haskell/haddock/haddock-2.13.2-r1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/haddock/haddock-2.13.2-r1.ebuild,v 1.1 2013/05/29 08:21:16 qnikst Exp $
+
+EAPI=5
+
+CABAL_FEATURES="bin lib profile haddock hscolour nocabaldep"
+inherit eutils haskell-cabal pax-utils
+
+DESCRIPTION="A documentation-generation tool for Haskell libraries"
+HOMEPAGE="http://www.haskell.org/haddock/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz
+ http://dev.gentoo.org/~qnikst/patches/dev-haskell-${PN}/${P}-pregenerated-files.patch
+ "
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+# ia64 lost as we don't have ghc-7 there yet
+# ppc64 needs to be rekeyworded due to xhtml not being keyworded
+# x86-fbsd is lost due xhtml
+KEYWORDS="~amd64 -ia64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/ghc-paths:=[profile?]
+ =dev-haskell/xhtml-3000.2*:=[profile?]
+ >=dev-lang/ghc-7.6.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.14"
+
+RESTRICT="test" # avoid depends on QC
+
+CABAL_EXTRA_BUILD_FLAGS="--ghc-options=-rtsopts"
+
+src_prepare() {
+ # we would like to avoid happy and alex depends
+ epatch "${DISTDIR}"/${P}-pregenerated-files.patch
+ epatch "${FILESDIR}"/${PN}-2.13.1-drop-tools.patch
+ # Fix: Ticket #213 Haddock fails when advanced typesystem features are used
+ # epatch "${FILESDIR}"/${PN}-2.13.1-renameType.patch
+ if use doc && [ ! -e "${S}/html" ]; then
+ ln -s "${S}/resources/html" "${S}/html" || die "Could not create symbolic link ${S}/html"
+ fi
+}
+
+src_configure() {
+ # create a fake haddock executable. it'll set the right version to cabal
+ # configure, but will eventually get overwritten in src_compile by
+ # the real executable.
+ local exe="${S}/dist/build/haddock/haddock"
+ mkdir -p $(dirname "${exe}")
+ echo -e "#!/bin/sh\necho Haddock version ${PV}" > "${exe}"
+ chmod +x "${exe}"
+
+ # we use 'nocabaldep' to use ghc's bundled Cabal
+ # as external one is likely to break our haddock
+ # (known to work on 1.16.0 and breaks on 1.16.0.1!)
+ haskell-cabal_src_configure \
+ --with-haddock="${exe}" \
+ --constraint="Cabal == $(cabal-version)"
+}
+
+src_compile() {
+ # when building the (recursive..) haddock docs, change the datadir to the
+ # current directory, as we're using haddock inplace even if it's built to be
+ # installed into the system first.
+ haddock_datadir="${S}" haskell-cabal_src_compile
+}
+
+src_install() {
+ cabal_src_install
+ # haddock uses GHC-api to process TH source.
+ # TH requires GHCi which needs mmap('rwx') (bug #299709)
+ pax-mark -m "${D}/usr/bin/${PN}"
+}