summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-05-09 11:45:47 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-05-09 11:45:47 +0000
commit40b0b62739105bc57d7d1a51e5d50554c6c05680 (patch)
tree34d83b16c82d4530d90808f436cd147f264288a4 /dev-java/antlr
parentUnmasking dev-java/antlr[java] as per bug #412223, acked by sera. (diff)
downloadgentoo-2-40b0b62739105bc57d7d1a51e5d50554c6c05680.tar.gz
gentoo-2-40b0b62739105bc57d7d1a51e5d50554c6c05680.tar.bz2
gentoo-2-40b0b62739105bc57d7d1a51e5d50554c6c05680.zip
Do not use /usr/bin/tlib or /usr/bin/lib until bug #469150 is resolved, /usr/bin/ar is used instead. This is a temporary fix for bug #468540. Upgraded to EAPI 5, distutils-r1 and indirect python-single-r1.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/antlr')
-rw-r--r--dev-java/antlr/ChangeLog9
-rw-r--r--dev-java/antlr/antlr-2.7.7-r1.ebuild38
-rw-r--r--dev-java/antlr/antlr-2.7.7-r2.ebuild39
-rw-r--r--dev-java/antlr/antlr-2.7.7-r3.ebuild38
-rw-r--r--dev-java/antlr/antlr-2.7.7-r4.ebuild38
-rw-r--r--dev-java/antlr/antlr-2.7.7-r5.ebuild38
-rw-r--r--dev-java/antlr/antlr-2.7.7.ebuild38
7 files changed, 129 insertions, 109 deletions
diff --git a/dev-java/antlr/ChangeLog b/dev-java/antlr/ChangeLog
index 0d0022d78606..c995affa6bdf 100644
--- a/dev-java/antlr/ChangeLog
+++ b/dev-java/antlr/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/antlr
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.95 2013/02/05 06:56:19 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/ChangeLog,v 1.96 2013/05/09 11:45:47 tomwij Exp $
+
+ 09 May 2013; Tom Wijsman <TomWij@gentoo.org> antlr-2.7.7-r1.ebuild,
+ antlr-2.7.7-r2.ebuild, antlr-2.7.7-r3.ebuild, antlr-2.7.7-r4.ebuild,
+ antlr-2.7.7-r5.ebuild, antlr-2.7.7.ebuild:
+ Do not use /usr/bin/tlib or /usr/bin/lib until bug #469150 is resolved,
+ /usr/bin/ar is used instead. This is a temporary fix for bug #468540. Upgraded
+ to EAPI 5, distutils-r1 and indirect python-single-r1.
05 Feb 2013; Rick Farina <zerochaos@gentoo.org> antlr-3.1.3-r2.ebuild:
adding ~arm
diff --git a/dev-java/antlr/antlr-2.7.7-r1.ebuild b/dev-java/antlr/antlr-2.7.7-r1.ebuild
index 271d765e554a..a1039e6e6951 100644
--- a/dev-java/antlr/antlr-2.7.7-r1.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r1.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r1.ebuild,v 1.3 2013/02/05 06:54:43 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r1.ebuild,v 1.4 2013/05/09 11:45:47 tomwij Exp $
-EAPI="3"
-PYTHON_DEPEND="python? 2"
+EAPI="5"
-inherit base java-pkg-2 mono distutils multilib
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+DISTUTILS_OPTIONAL="y"
+DISTUTILS_SINGLE_IMPL="y"
+DISTUTILS_IN_SOURCE_BUILD="y"
+
+inherit base java-pkg-2 mono autotools distutils-r1 multilib
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -17,7 +22,8 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE="doc debug examples mono +cxx +java python script source"
# TODO do we actually need jdk at runtime?
-RDEPEND=">=virtual/jdk-1.3
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -28,14 +34,17 @@ PATCHES=( "${FILESDIR}/2.7.7-gcc-4.3.patch" "${FILESDIR}/2.7.7-gcc-4.4.patch" "$
pkg_setup() {
java-pkg-2_pkg_setup
- if use python; then
- python_set_active_version 2
- python_pkg_setup
+ if use python ; then
+ python-single-r1_pkg_setup
fi
}
src_prepare() {
base_src_prepare
+
+ # See bug #468540, this can be removed once bug #469150 is fixed.
+ sed -i 's/tlib lib ar/ar/' configure.in || die
+ eautoreconf
}
src_configure() {
@@ -96,8 +105,9 @@ src_install() {
fi
if use python ; then
- cd "${S}"/lib/python
- distutils_src_install
+ pushd "${S}"/lib/python > /dev/null
+ distutils-r1_python_install
+ popd > /dev/null
fi
if use examples ; then
@@ -114,11 +124,3 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/dev-java/antlr/antlr-2.7.7-r2.ebuild b/dev-java/antlr/antlr-2.7.7-r2.ebuild
index a61b51612b50..eebb53a435a0 100644
--- a/dev-java/antlr/antlr-2.7.7-r2.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r2.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r2.ebuild,v 1.6 2013/02/05 06:54:43 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r2.ebuild,v 1.7 2013/05/09 11:45:47 tomwij Exp $
-EAPI="3"
-PYTHON_DEPEND="python? 2"
+EAPI="5"
-inherit base java-pkg-2 mono distutils multilib toolchain-funcs versionator
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+DISTUTILS_OPTIONAL="y"
+DISTUTILS_SINGLE_IMPL="y"
+DISTUTILS_IN_SOURCE_BUILD="y"
+
+inherit base java-pkg-2 mono autotools distutils-r1 multilib toolchain-funcs versionator
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -17,7 +22,8 @@ KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
IUSE="doc debug examples mono +cxx +java python script source static-libs"
# TODO do we actually need jdk at runtime?
-RDEPEND=">=virtual/jdk-1.3
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -37,17 +43,21 @@ make_shared_lib() {
pkg_setup() {
java-pkg-2_pkg_setup
- if use python; then
- python_set_active_version 2
- python_pkg_setup
+ if use python ; then
+ python-single-r1_pkg_setup
fi
}
src_prepare() {
base_src_prepare
+
sed -i \
-e 's/install:.*this-install/install:/' \
lib/cpp/src/Makefile.in || die
+
+ # See bug #468540, this can be removed once bug #469150 is fixed.
+ sed -i 's/tlib lib ar/ar/' configure.in || die
+ eautoreconf
}
src_configure() {
@@ -119,8 +129,9 @@ src_install() {
fi
if use python ; then
- cd "${S}"/lib/python
- distutils_src_install
+ pushd "${S}"/lib/python > /dev/null
+ distutils-r1_python_install
+ popd > /dev/null
fi
if use examples ; then
@@ -137,11 +148,3 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/dev-java/antlr/antlr-2.7.7-r3.ebuild b/dev-java/antlr/antlr-2.7.7-r3.ebuild
index 7e283f66b7a9..b5c63fa4f8e3 100644
--- a/dev-java/antlr/antlr-2.7.7-r3.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r3.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r3.ebuild,v 1.3 2013/02/05 06:54:43 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r3.ebuild,v 1.4 2013/05/09 11:45:47 tomwij Exp $
-EAPI="3"
-PYTHON_DEPEND="python? 2"
+EAPI="5"
-inherit base java-pkg-2 mono distutils multilib toolchain-funcs versionator
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+DISTUTILS_OPTIONAL="y"
+DISTUTILS_SINGLE_IMPL="y"
+DISTUTILS_IN_SOURCE_BUILD="y"
+
+inherit base java-pkg-2 mono autotools distutils-r1 multilib toolchain-funcs versionator
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -17,7 +22,8 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-
IUSE="doc debug examples mono +cxx +java python script source static-libs"
# TODO do we actually need jdk at runtime?
-RDEPEND=">=virtual/jdk-1.3
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -52,9 +58,8 @@ make_shared_lib_macho() {
pkg_setup() {
java-pkg-2_pkg_setup
- if use python; then
- python_set_active_version 2
- python_pkg_setup
+ if use python ; then
+ python-single-r1_pkg_setup
fi
}
@@ -63,6 +68,10 @@ src_prepare() {
sed -i \
-e 's/install:.*this-install/install:/' \
lib/cpp/src/Makefile.in || die
+
+ # See bug #468540, this can be removed once bug #469150 is fixed.
+ sed -i 's/tlib lib ar/ar/' configure.in || die
+ eautoreconf
}
src_configure() {
@@ -135,8 +144,9 @@ src_install() {
fi
if use python ; then
- cd "${S}"/lib/python
- distutils_src_install
+ pushd "${S}"/lib/python > /dev/null
+ distutils-r1_python_install
+ popd > /dev/null
fi
if use examples ; then
@@ -153,11 +163,3 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/dev-java/antlr/antlr-2.7.7-r4.ebuild b/dev-java/antlr/antlr-2.7.7-r4.ebuild
index 81329fd9785e..d560faf6ff10 100644
--- a/dev-java/antlr/antlr-2.7.7-r4.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r4.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r4.ebuild,v 1.2 2013/02/05 06:54:43 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r4.ebuild,v 1.3 2013/05/09 11:45:47 tomwij Exp $
-EAPI="3"
-PYTHON_DEPEND="python? 2"
+EAPI="5"
-inherit base java-pkg-2 mono distutils multilib toolchain-funcs versionator
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+DISTUTILS_OPTIONAL="y"
+DISTUTILS_SINGLE_IMPL="y"
+DISTUTILS_IN_SOURCE_BUILD="y"
+
+inherit base java-pkg-2 mono autotools distutils-r1 multilib toolchain-funcs versionator
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -17,7 +22,8 @@ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-
IUSE="doc debug examples mono +cxx +java python script source static-libs"
# TODO do we actually need jdk at runtime?
-RDEPEND=">=virtual/jdk-1.3
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -52,9 +58,8 @@ make_shared_lib_macho() {
pkg_setup() {
java-pkg-2_pkg_setup
- if use python; then
- python_set_active_version 2
- python_pkg_setup
+ if use python ; then
+ python-single-r1_pkg_setup
fi
}
@@ -67,6 +72,10 @@ src_prepare() {
if ! use static-libs ; then
epatch "${FILESDIR}/${PV}-static-libs-fix.patch"
fi
+
+ # See bug #468540, this can be removed once bug #469150 is fixed.
+ sed -i 's/tlib lib ar/ar/' configure.in || die
+ eautoreconf
}
src_configure() {
@@ -139,8 +148,9 @@ src_install() {
fi
if use python ; then
- cd "${S}"/lib/python
- distutils_src_install
+ pushd "${S}"/lib/python > /dev/null
+ distutils-r1_python_install
+ popd > /dev/null
fi
if use examples ; then
@@ -157,11 +167,3 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/dev-java/antlr/antlr-2.7.7-r5.ebuild b/dev-java/antlr/antlr-2.7.7-r5.ebuild
index 23ee62b9ec47..7628e6d2b7f4 100644
--- a/dev-java/antlr/antlr-2.7.7-r5.ebuild
+++ b/dev-java/antlr/antlr-2.7.7-r5.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r5.ebuild,v 1.4 2013/02/05 06:54:43 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7-r5.ebuild,v 1.5 2013/05/09 11:45:47 tomwij Exp $
-EAPI=4
-PYTHON_DEPEND="python? 2"
+EAPI="5"
-inherit base java-pkg-2 mono distutils multilib toolchain-funcs versionator
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+DISTUTILS_OPTIONAL="y"
+DISTUTILS_SINGLE_IMPL="y"
+DISTUTILS_IN_SOURCE_BUILD="y"
+
+inherit base java-pkg-2 mono autotools distutils-r1 multilib toolchain-funcs versionator
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -17,7 +22,8 @@ KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd
IUSE="doc debug examples mono +cxx +java python script source static-libs"
# TODO do we actually need jdk at runtime?
-RDEPEND=">=virtual/jdk-1.3
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -52,19 +58,23 @@ make_shared_lib_macho() {
pkg_setup() {
java-pkg-2_pkg_setup
- if use python; then
- python_set_active_version 2
- python_pkg_setup
+ if use python ; then
+ python-single-r1_pkg_setup
fi
}
src_prepare() {
base_src_prepare
+
sed -i \
-e 's/install:.*this-install/install:/' \
lib/cpp/src/Makefile.in || die
use static-libs || epatch "${FILESDIR}/${PV}-static-libs-fix.patch"
+
+ # See bug #468540, this can be removed once bug #469150 is fixed.
+ sed -i 's/tlib lib ar/ar/' configure.in || die
+ eautoreconf
}
src_configure() {
@@ -137,8 +147,8 @@ src_install() {
fi
if use python ; then
- pushd lib/python > /dev/null
- distutils_src_install
+ pushd "${S}"/lib/python > /dev/null
+ distutils-r1_python_install
popd > /dev/null
fi
@@ -153,11 +163,3 @@ src_install() {
dodoc README.txt
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}
diff --git a/dev-java/antlr/antlr-2.7.7.ebuild b/dev-java/antlr/antlr-2.7.7.ebuild
index 5d90edcd68d0..13dd5fd2dd7b 100644
--- a/dev-java/antlr/antlr-2.7.7.ebuild
+++ b/dev-java/antlr/antlr-2.7.7.ebuild
@@ -1,11 +1,16 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.18 2013/02/05 06:54:43 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/antlr/antlr-2.7.7.ebuild,v 1.19 2013/05/09 11:45:47 tomwij Exp $
-EAPI="3"
-PYTHON_DEPEND="python? 2"
+EAPI="5"
-inherit base java-pkg-2 mono distutils multilib
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+DISTUTILS_OPTIONAL="y"
+DISTUTILS_SINGLE_IMPL="y"
+DISTUTILS_IN_SOURCE_BUILD="y"
+
+inherit base java-pkg-2 mono autotools distutils-r1 multilib
DESCRIPTION="A parser generator for C++, C#, Java, and Python"
HOMEPAGE="http://www.antlr2.org/"
@@ -17,7 +22,8 @@ KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
IUSE="doc debug examples mono +cxx +java python script source"
# TODO do we actually need jdk at runtime?
-RDEPEND=">=virtual/jdk-1.3
+RDEPEND="python? ( ${PYTHON_DEPS} )
+ >=virtual/jdk-1.3
mono? ( dev-lang/mono )"
DEPEND="${RDEPEND}
script? ( !dev-util/pccts )
@@ -28,14 +34,17 @@ PATCHES=( "${FILESDIR}/2.7.7-gcc-4.3.patch" "${FILESDIR}/2.7.7-gcc-4.4.patch" "$
pkg_setup() {
java-pkg-2_pkg_setup
- if use python; then
- python_set_active_version 2
- python_pkg_setup
+ if use python ; then
+ python-single-r1_pkg_setup
fi
}
src_prepare() {
base_src_prepare
+
+ # See bug #468540, this can be removed once bug #469150 is fixed.
+ sed -i 's/tlib lib ar/ar/' configure.in || die
+ eautoreconf
}
src_configure() {
@@ -96,8 +105,9 @@ src_install() {
fi
if use python ; then
- cd "${S}"/lib/python
- distutils_src_install
+ pushd "${S}"/lib/python > /dev/null
+ distutils-r1_python_install
+ popd > /dev/null
fi
if use examples ; then
@@ -114,11 +124,3 @@ src_install() {
newdoc "${S}"/README.txt README || die
}
-
-pkg_postinst() {
- use python && distutils_pkg_postinst
-}
-
-pkg_postrm() {
- use python && distutils_pkg_postrm
-}