summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-06-23 09:04:31 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-06-23 09:04:31 +0000
commit72f47cdc69ffeb046420163ebefa1542755d8dfc (patch)
treee4606a1ebba1092f2cc9a3c6a7805819a9a5cc56 /dev-java/bsh/bsh-2.0_beta4.ebuild
parentFix typos. (diff)
downloadgentoo-2-72f47cdc69ffeb046420163ebefa1542755d8dfc.tar.gz
gentoo-2-72f47cdc69ffeb046420163ebefa1542755d8dfc.tar.bz2
gentoo-2-72f47cdc69ffeb046420163ebefa1542755d8dfc.zip
fix 96799, sorry commited wrong ebuild
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-java/bsh/bsh-2.0_beta4.ebuild')
-rw-r--r--dev-java/bsh/bsh-2.0_beta4.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/dev-java/bsh/bsh-2.0_beta4.ebuild b/dev-java/bsh/bsh-2.0_beta4.ebuild
index 873a0904d0dc..16ba10175611 100644
--- a/dev-java/bsh/bsh-2.0_beta4.ebuild
+++ b/dev-java/bsh/bsh-2.0_beta4.ebuild
@@ -1,10 +1,11 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bsh/bsh-2.0_beta4.ebuild,v 1.1 2005/06/22 17:22:37 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bsh/bsh-2.0_beta4.ebuild,v 1.2 2005/06/23 09:04:31 axxo Exp $
inherit java-pkg eutils
-MY_DIST=${P/_beta/b}-src.jar
+MY_PV=${PV/_beta/b}
+MY_DIST=${PN}-${MY_PV}-src.jar
DESCRIPTION="BeanShell: A small embeddable Java source interpreter"
HOMEPAGE="http://www.beanshell.org"
@@ -14,7 +15,7 @@ SRC_URI="http://www.beanshell.org/${MY_DIST}
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="doc gnome jikes junit kde readline"
+IUSE="doc jikes junit readline"
DEPEND="${RDEPEND}
>=dev-java/ant-core-1.5.4"
@@ -23,7 +24,7 @@ RDEPEND=">=virtual/jdk-1.4
=dev-java/servletapi-2.4*
readline? ( dev-java/libreadline-java )"
-S=${WORKDIR}/BeanShell
+S=${WORKDIR}/BeanShell-${MY_PV}
src_unpack() {
# Extract the sources
@@ -32,7 +33,7 @@ src_unpack() {
# Apply the build patch
cd ${S}
- epatch ${FILESDIR}/bsh2-build.patch
+ epatch ${FILESDIR}/bsh${MY_PV}-build.patch
# Copy the needed files
cp ${FILESDIR}/bsh.Console ${FILESDIR}/bsh.Interpreter ${S}