summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-16 17:28:02 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-16 17:28:02 +0000
commitee3a3719a9057c06f404256e0b44fbe9cc9765d6 (patch)
tree27df38d5e3efed6a88ca752bdaa26cb829775733 /dev-java/burlap
parentShortened DESCRIPTION and removed unused revisions. (diff)
downloadgentoo-2-ee3a3719a9057c06f404256e0b44fbe9cc9765d6.tar.gz
gentoo-2-ee3a3719a9057c06f404256e0b44fbe9cc9765d6.tar.bz2
gentoo-2-ee3a3719a9057c06f404256e0b44fbe9cc9765d6.zip
Added patch to compile with jdks from 1.4 to 1.6. Thanks to Martin Jansa <Martin.Jansa@mk.cvut.cz>. Fixes bug #137968.
(Portage version: 2.1.2)
Diffstat (limited to 'dev-java/burlap')
-rw-r--r--dev-java/burlap/ChangeLog11
-rw-r--r--dev-java/burlap/burlap-3.0.8-r2.ebuild41
-rw-r--r--dev-java/burlap/files/3.0.8-java5.patch28
-rw-r--r--dev-java/burlap/files/digest-burlap-3.0.8-r23
4 files changed, 81 insertions, 2 deletions
diff --git a/dev-java/burlap/ChangeLog b/dev-java/burlap/ChangeLog
index b60ae7d8e294..51f5c295556a 100644
--- a/dev-java/burlap/ChangeLog
+++ b/dev-java/burlap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/burlap
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/burlap/ChangeLog,v 1.10 2006/12/05 01:51:51 caster Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/burlap/ChangeLog,v 1.11 2007/01/16 17:28:02 betelgeuse Exp $
+
+*burlap-3.0.8-r2 (16 Jan 2007)
+
+ 16 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+ +files/3.0.8-java5.patch, +burlap-3.0.8-r2.ebuild:
+ Added patch to compile with jdks from 1.4 to 1.6. Thanks to Martin Jansa
+ <Martin.Jansa@mk.cvut.cz>. Fixes bug #137968.
05 Dec 2006; Vlastimil Babka <caster@gentoo.org> burlap-3.0.8-r1.ebuild:
Fix building due to stray space.
diff --git a/dev-java/burlap/burlap-3.0.8-r2.ebuild b/dev-java/burlap/burlap-3.0.8-r2.ebuild
new file mode 100644
index 000000000000..2782dccf71b6
--- /dev/null
+++ b/dev-java/burlap/burlap-3.0.8-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/burlap/burlap-3.0.8-r2.ebuild,v 1.1 2007/01/16 17:28:02 betelgeuse Exp $
+
+inherit base java-pkg-2 java-ant-2
+
+DESCRIPTION="The Burlap web service protocol makes web services usable without requiring a large framework, and without learning yet another alphabet soup of protocols."
+HOMEPAGE="http://www.caucho.com/burlap/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="Apache-1.1"
+SLOT="3.0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="doc source"
+
+COMMON_DEP="
+ =dev-java/servletapi-2.3*
+ =dev-java/hessian-3*
+ ~dev-java/caucho-services-${PV}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ dev-java/ant-core
+ source? ( app-arch/zip )
+ ${COMMON_DEP}"
+
+PATCHES="${FILESDIR}/3.0.8-java5.patch"
+
+src_compile() {
+ eant jar $(use_doc) -Dclasspath=$(java-pkg_getjars servletapi-2.3,hessian-3.0.8,caucho-services-3.0)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/doc/api
+ use source && java-pkg_dosrc src/*
+}
diff --git a/dev-java/burlap/files/3.0.8-java5.patch b/dev-java/burlap/files/3.0.8-java5.patch
new file mode 100644
index 000000000000..02fe38f096b8
--- /dev/null
+++ b/dev-java/burlap/files/3.0.8-java5.patch
@@ -0,0 +1,28 @@
+diff -uNr burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxyFactory.java burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxyFactory.java
+--- burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxyFactory.java 2006-08-15 10:47:30.000000000 +0200
++++ burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxyFactory.java 2006-08-15 10:48:19.000000000 +0200
+@@ -202,7 +202,7 @@
+ {
+ BurlapProxy handler = new BurlapProxy(this, new URL(url));
+
+- return Proxy.newProxyInstance(api.getClassLoader(),
++ return java.lang.reflect.Proxy.newProxyInstance(api.getClassLoader(),
+ new Class[] { api,
+ BurlapRemoteObject.class },
+ handler);
+diff -uNr burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxy.java burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxy.java
+--- burlap-3.0.8.orig/src/com/caucho/burlap/client/BurlapProxy.java 2006-08-15 10:47:30.000000000 +0200
++++ burlap-3.0.8/src/com/caucho/burlap/client/BurlapProxy.java 2006-08-15 10:48:08.000000000 +0200
+@@ -94,10 +94,10 @@
+ if (methodName.equals("equals") &&
+ params.length == 1 && params[0].equals(Object.class)) {
+ Object value = args[0];
+- if (value == null || ! Proxy.isProxyClass(value.getClass()))
++ if (value == null || ! java.lang.reflect.Proxy.isProxyClass(value.getClass()))
+ return new Boolean(false);
+
+- BurlapProxy handler = (BurlapProxy) Proxy.getInvocationHandler(value);
++ BurlapProxy handler = (BurlapProxy) java.lang.reflect.Proxy.getInvocationHandler(value);
+
+ return new Boolean(_url.equals(handler.getURL()));
+ }
diff --git a/dev-java/burlap/files/digest-burlap-3.0.8-r2 b/dev-java/burlap/files/digest-burlap-3.0.8-r2
new file mode 100644
index 000000000000..836a14e6e1d4
--- /dev/null
+++ b/dev-java/burlap/files/digest-burlap-3.0.8-r2
@@ -0,0 +1,3 @@
+MD5 14004ea790142d7ea07c8bf07973cca5 burlap-3.0.8.tar.bz2 19835
+RMD160 5b1120aacd8cc5bc3a335d71bafcb34c003d5003 burlap-3.0.8.tar.bz2 19835
+SHA256 4cdb276c9c2a33379a7cd3dfe41abde503b6745bdd47e4d08c91b2ae382ebca1 burlap-3.0.8.tar.bz2 19835