summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-10 19:12:07 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-10 19:12:07 +0000
commit42bbe3990a153e11c027a0de9a6ff02b011db97e (patch)
tree09967019ac5201a496d6c880369d5cc8a632a08d /dev-java/commons-lang
parentAdd murm use flag to 9999, thanks to 0xd34df00d (diff)
downloadgentoo-2-42bbe3990a153e11c027a0de9a6ff02b011db97e.tar.gz
gentoo-2-42bbe3990a153e11c027a0de9a6ff02b011db97e.tar.bz2
gentoo-2-42bbe3990a153e11c027a0de9a6ff02b011db97e.zip
Version bump to 3.1, new slot because of API incompatibility with previous versions.
(Portage version: 2.1.13.7/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/commons-lang')
-rw-r--r--dev-java/commons-lang/ChangeLog10
-rw-r--r--dev-java/commons-lang/commons-lang-3.1.ebuild36
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-java/commons-lang/ChangeLog b/dev-java/commons-lang/ChangeLog
index 912e8a9d284c..e104f5728049 100644
--- a/dev-java/commons-lang/ChangeLog
+++ b/dev-java/commons-lang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-lang
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.66 2011/12/19 12:18:25 sera Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/ChangeLog,v 1.67 2013/08/10 19:12:07 tomwij Exp $
+
+*commons-lang-3.1 (10 Aug 2013)
+
+ 10 Aug 2013; Tom Wijsman <TomWij@gentoo.org> +commons-lang-3.1.ebuild:
+ Version bump to 3.1, new slot because of API incompatibility with previous
+ versions.
19 Dec 2011; Ralph Sennhauser <sera@gentoo.org> commons-lang-2.0-r2.ebuild:
Fix homepage wrt #202445.
diff --git a/dev-java/commons-lang/commons-lang-3.1.ebuild b/dev-java/commons-lang/commons-lang-3.1.ebuild
new file mode 100644
index 000000000000..2c3f6b3e2bdf
--- /dev/null
+++ b/dev-java/commons-lang/commons-lang-3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-3.1.ebuild,v 1.1 2013/08/10 19:12:07 tomwij Exp $
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source test"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${PN}3-${PV}"
+
+DESCRIPTION="Commons components to manipulate core java classes"
+HOMEPAGE="http://commons.apache.org/lang/"
+SRC_URI="mirror://apache/commons/lang/source/${MY_P}-src.tar.gz"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit:0 )"
+
+RDEPEND=">=virtual/jre-1.5"
+
+LICENSE="Apache-2.0"
+SLOT="3.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris"
+
+S="${WORKDIR}/${MY_P}-src"
+
+JAVA_ANT_ENCODING="ISO-8859-1"
+
+src_install() {
+ java-pkg_newjar target/${MY_P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt
+
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}