summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-10 13:25:36 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-10 13:25:36 +0000
commit54ff546dc064e26ba0c5aa4e56967c19b98982aa (patch)
tree906fb0a14247275c62db73fdc73024e439206ef9 /dev-java/commons-validator
parentStable macos. (Manifest recommit) (diff)
downloadgentoo-2-54ff546dc064e26ba0c5aa4e56967c19b98982aa.tar.gz
gentoo-2-54ff546dc064e26ba0c5aa4e56967c19b98982aa.tar.bz2
gentoo-2-54ff546dc064e26ba0c5aa4e56967c19b98982aa.zip
version bump
Diffstat (limited to 'dev-java/commons-validator')
-rw-r--r--dev-java/commons-validator/ChangeLog8
-rw-r--r--dev-java/commons-validator/Manifest14
-rw-r--r--dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild4
-rw-r--r--dev-java/commons-validator/commons-validator-1.1.3.ebuild58
-rw-r--r--dev-java/commons-validator/files/digest-commons-validator-1.1.32
5 files changed, 72 insertions, 14 deletions
diff --git a/dev-java/commons-validator/ChangeLog b/dev-java/commons-validator/ChangeLog
index d615a1cc6d6d..e0fe299d02a0 100644
--- a/dev-java/commons-validator/ChangeLog
+++ b/dev-java/commons-validator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-validator
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.13 2004/09/08 13:06:59 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/ChangeLog,v 1.14 2004/09/10 13:25:36 axxo Exp $
+
+*commons-validator-1.1.3 (10 Sep 2004)
+
+ 10 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
+ commons-validator-1.0.2-r3.ebuild, +commons-validator-1.1.3.ebuild:
+ version bump
08 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
commons-validator-1.0.2-r3.ebuild:
diff --git a/dev-java/commons-validator/Manifest b/dev-java/commons-validator/Manifest
index 6175a21c1d40..fb28bc70491a 100644
--- a/dev-java/commons-validator/Manifest
+++ b/dev-java/commons-validator/Manifest
@@ -1,14 +1,6 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 685cb4b3d97334c7dfd880a05bd76016 commons-validator-1.0.2-r3.ebuild 1964
+MD5 0030060794718daae1c97cb61f5b8801 commons-validator-1.0.2-r3.ebuild 1986
+MD5 ad2209431cbf6cde2cf06e42480101b3 commons-validator-1.1.3.ebuild 2190
MD5 1812d41970a2d43eb039dbe33b0a674f ChangeLog 2290
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 b4056d324a1cc96ca13a9f0c3e7c68fc files/digest-commons-validator-1.1.3 173
MD5 3b4d11c72fe5990ec6689406240d3ef6 files/digest-commons-validator-1.0.2-r3 78
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBPwRD/rLF9B432nYRAhPQAJ90OLwIf37GTpin05Us7j5iELingACgxBAl
-G2wrxMRwW7tYx3mZl62YSzc=
-=w+cS
------END PGP SIGNATURE-----
diff --git a/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild b/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild
index 3cf300898620..a3cdcf220e66 100644
--- a/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild
+++ b/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild,v 1.4 2004/09/08 13:06:59 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.0.2-r3.ebuild,v 1.5 2004/09/10 13:25:36 axxo Exp $
inherit java-pkg
@@ -43,7 +43,7 @@ src_compile() {
use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
use doc && antflags="${antflags} javadoc"
use junit && antflags="${antflags} test"
- ant ${antflags}
+ ant ${antflags} || die "build failed"
}
src_install() {
diff --git a/dev-java/commons-validator/commons-validator-1.1.3.ebuild b/dev-java/commons-validator/commons-validator-1.1.3.ebuild
new file mode 100644
index 000000000000..95a09a77761b
--- /dev/null
+++ b/dev-java/commons-validator/commons-validator-1.1.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-validator/commons-validator-1.1.3.ebuild,v 1.1 2004/09/10 13:25:36 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Jakarta component to validate user input, or data input"
+HOMEPAGE="http://jakarta.apache.org/commons/validator/"
+SRC_URI="mirror://apache/jakarta/commons/validator/source/${PN}-${PV}-src.tar.gz mirror://gentoo/commons-validator-1.1.3-gentoo-missingfiles.tar.bz2"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/ant-1.4
+ app-arch/zip
+ jikes? ( dev-java/jikes )
+ junit? ( >=junit-3.8.1 )"
+RDEPEND=">=virtual/jre-1.3
+ >=dev-java/oro-2.0.8
+ >=dev-java/commons-digester-1.5
+ >=dev-java/commons-collections-2.1
+ >=dev-java/commons-logging-1.0.3
+ >=dev-java/commons-beanutils-1.6
+ >=dev-java/xerces-2.6.2-r1"
+LICENSE="Apache-1.1"
+SLOT="0"
+RESTRICT="nomirror"
+KEYWORDS="~x86 ~ppc ~sparc"
+IUSE="doc jikes junit"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ #dirty hack
+ sed -e 's:target name="compile" depends="static":target name="compile" depends="prepare":' -i build.xml
+
+ echo "oro.jar=`java-config --classpath=oro`" >> build.properties
+ echo "commons-digester.jar=`java-config --classpath=commons-digester`" >> build.properties
+ echo "commons-collections.jar=`java-config --classpath=commons-collections`" >> build.properties
+ echo "commons-logging.jar=`java-config --classpath=commons-logging | sed s/.*://`" >> build.properties
+ echo "commons-beanutils.jar=`java-config --classpath=commons-beanutils | sed s/.*://`" >> build.properties
+ echo "xerces.jar=`java-config --classpath=xerces-2`" >> build.properties
+ use junit && echo "junit.jar=`java-config --classpath=junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ ant ${antflags} || die "build failed"
+ jar -cvf ${PN}.jar -C target/classes/ . || die "could not create jar"
+}
+
+src_install() {
+ cd ${S}
+ java-pkg_dojar ${PN}.jar
+ use doc && dohtml -r dist/docs/
+ dohtml PROPOSAL.html STATUS.html
+ dodoc LICENSE.txt
+}
diff --git a/dev-java/commons-validator/files/digest-commons-validator-1.1.3 b/dev-java/commons-validator/files/digest-commons-validator-1.1.3
new file mode 100644
index 000000000000..14da3e258aa4
--- /dev/null
+++ b/dev-java/commons-validator/files/digest-commons-validator-1.1.3
@@ -0,0 +1,2 @@
+MD5 a24f8612138427019269af37148b590d commons-validator-1.1.3-src.tar.gz 180203
+MD5 9c19c398966e4aac3783deb06cba41d6 commons-validator-1.1.3-gentoo-missingfiles.tar.bz2 4161