summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-02-15 01:30:29 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-02-15 01:30:29 +0000
commitc9f546bf2a2b2aa25d7569d5936ae1a7e6edbd9e (patch)
treefc860d0001f962d3e05277bd1fa76a2b008bb674 /dev-java/gjdoc
parentMake rewriter3 respect JAVA_ANT_CLASSPATH_TAGS (diff)
downloadgentoo-2-c9f546bf2a2b2aa25d7569d5936ae1a7e6edbd9e.tar.gz
gentoo-2-c9f546bf2a2b2aa25d7569d5936ae1a7e6edbd9e.tar.bz2
gentoo-2-c9f546bf2a2b2aa25d7569d5936ae1a7e6edbd9e.zip
Add patch for a method in Main.java that is needed by testng.
(Portage version: 2.2_rc20/cvs/Linux 2.6.28-gentoo-r1 i686)
Diffstat (limited to 'dev-java/gjdoc')
-rw-r--r--dev-java/gjdoc/ChangeLog8
-rw-r--r--dev-java/gjdoc/files/0.7.9-main-execute.patch17
-rw-r--r--dev-java/gjdoc/gjdoc-0.7.9-r1.ebuild72
3 files changed, 96 insertions, 1 deletions
diff --git a/dev-java/gjdoc/ChangeLog b/dev-java/gjdoc/ChangeLog
index 0dee1b27bf09..aab4a0b08c5d 100644
--- a/dev-java/gjdoc/ChangeLog
+++ b/dev-java/gjdoc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/gjdoc
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gjdoc/ChangeLog,v 1.35 2009/01/04 17:38:40 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gjdoc/ChangeLog,v 1.36 2009/02/15 01:30:29 betelgeuse Exp $
+
+*gjdoc-0.7.9-r1 (15 Feb 2009)
+
+ 15 Feb 2009; Petteri Räty <betelgeuse@gentoo.org>
+ +files/0.7.9-main-execute.patch, +gjdoc-0.7.9-r1.ebuild:
+ Add patch for a method in Main.java that is needed by testng.
04 Jan 2009; Raúl Porcel <armin76@gentoo.org> gjdoc-0.7.8.ebuild,
gjdoc-0.7.9.ebuild:
diff --git a/dev-java/gjdoc/files/0.7.9-main-execute.patch b/dev-java/gjdoc/files/0.7.9-main-execute.patch
new file mode 100644
index 000000000000..79a8e5f34730
--- /dev/null
+++ b/dev-java/gjdoc/files/0.7.9-main-execute.patch
@@ -0,0 +1,17 @@
+Index: src/com/sun/tools/javadoc/Main.java
+===================================================================
+RCS file: /sources/classpath/gjdoc/src/com/sun/tools/javadoc/Main.java,v
+retrieving revision 1.3
+diff -u -r1.3 Main.java
+--- src/com/sun/tools/javadoc/Main.java 12 May 2007 10:40:10 -0000 1.3
++++ src/com/sun/tools/javadoc/Main.java 15 Feb 2009 00:32:57 -0000
+@@ -6,4 +6,9 @@
+ {
+ gnu.classpath.tools.gjdoc.Main.main(args);
+ }
++
++ public static int execute(String[] args)
++ {
++ return gnu.classpath.tools.gjdoc.Main.execute(args);
++ }
+ }
diff --git a/dev-java/gjdoc/gjdoc-0.7.9-r1.ebuild b/dev-java/gjdoc/gjdoc-0.7.9-r1.ebuild
new file mode 100644
index 000000000000..a67d6bc2e0c1
--- /dev/null
+++ b/dev-java/gjdoc/gjdoc-0.7.9-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gjdoc/gjdoc-0.7.9-r1.ebuild,v 1.1 2009/02/15 01:30:29 betelgeuse Exp $
+
+EAPI=2
+JAVA_PKG_IUSE="source"
+
+inherit eutils autotools java-pkg-2
+
+DESCRIPTION="A javadoc compatible Java source documentation generator."
+HOMEPAGE="http://www.gnu.org/software/cp-tools/"
+SRC_URI="mirror://gnu/classpath/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+# Possible USE flags.
+#
+# native: to --enable-native
+# doc: to generate javadoc
+# debug: There is a debug doclet installed by default but maybe could
+# have a wrapper that uses it.
+#
+IUSE="xmldoclet"
+
+RDEPEND=">=virtual/jre-1.4
+ >=dev-java/antlr-2.7.1[java]"
+
+# Refused to emerge with sun-jdk-1.3* complaining about wanting a bigger stack size
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.4"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-0.7.7-gcp.patch"
+ epatch "${FILESDIR}/0.7.9-main-execute.patch"
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # I think that configure will do --enable-native if it finds gcj
+ # so we'll disable it explicitly
+ local myc="--with-antlr-jar=$(java-pkg_getjar antlr antlr.jar) --disable-native"
+ myc="${myc} --disable-dependency-tracking"
+
+ # Does not work with gcc 3.* and without these it tries to use gij
+ # see bug #116804 for details
+
+ # TODO ideally, would respect JAVACFLAGS
+ JAVA="java" JAVAC="javac $(java-pkg_javac-args)" \
+ econf ${myc} \
+ $(use_enable xmldoclet) || die "econf failed"
+}
+
+src_compile() {
+ default # Don't use from java-pkg-2
+}
+
+src_install() {
+ local jars="com-sun-tools-doclets-Taglet gnu-classpath-tools-gjdoc com-sun-javadoc"
+ for jar in ${jars}; do
+ java-pkg_newjar ${jar}-${PV}.jar ${jar}.jar
+ done
+
+ dobin "${FILESDIR}"/gjdoc
+ dodoc AUTHORS ChangeLog NEWS README || die
+
+ cd "${S}"/docs
+ emake DESTDIR="${D}" install || die "Failed to install documentation"
+
+ use source && java-pkg_dosrc "${S}/src"/{com,gnu}
+}