summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-16 17:13:38 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-16 17:13:38 +0000
commit0ea9d281e680cd73904f3a70e8efe8834650baa3 (patch)
tree063211d1d7c963ea7a13d8eb2cded300e75911e0 /dev-java/hessian
parentStable on amd64. Remove obsolete versions. (diff)
downloadgentoo-2-0ea9d281e680cd73904f3a70e8efe8834650baa3.tar.gz
gentoo-2-0ea9d281e680cd73904f3a70e8efe8834650baa3.tar.bz2
gentoo-2-0ea9d281e680cd73904f3a70e8efe8834650baa3.zip
Separated caucho-services from 3.0.8 to dev-java/caucho-services.
(Portage version: 2.1.2)
Diffstat (limited to 'dev-java/hessian')
-rw-r--r--dev-java/hessian/files/3.0.8-java5.patch28
-rw-r--r--dev-java/hessian/files/digest-hessian-3.0.8-r43
-rw-r--r--dev-java/hessian/hessian-3.0.8-r4.ebuild55
-rw-r--r--dev-java/hessian/metadata.xml6
4 files changed, 89 insertions, 3 deletions
diff --git a/dev-java/hessian/files/3.0.8-java5.patch b/dev-java/hessian/files/3.0.8-java5.patch
new file mode 100644
index 000000000000..906eb7efca18
--- /dev/null
+++ b/dev-java/hessian/files/3.0.8-java5.patch
@@ -0,0 +1,28 @@
+diff -uNr hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxyFactory.java hessian-3.0.8/src/com/caucho/hessian/client/HessianProxyFactory.java
+--- hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxyFactory.java 2006-08-15 10:38:05.000000000 +0200
++++ hessian-3.0.8/src/com/caucho/hessian/client/HessianProxyFactory.java 2006-08-15 10:40:24.000000000 +0200
+@@ -230,7 +230,7 @@
+ {
+ HessianProxy handler = new HessianProxy(this, new URL(url));
+
+- return Proxy.newProxyInstance(api.getClassLoader(),
++ return java.lang.reflect.Proxy.newProxyInstance(api.getClassLoader(),
+ new Class[] { api,
+ HessianRemoteObject.class },
+ handler);
+diff -uNr hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxy.java hessian-3.0.8/src/com/caucho/hessian/client/HessianProxy.java
+--- hessian-3.0.8.orig/src/com/caucho/hessian/client/HessianProxy.java 2006-08-15 10:38:05.000000000 +0200
++++ hessian-3.0.8/src/com/caucho/hessian/client/HessianProxy.java 2006-08-15 10:40:06.000000000 +0200
+@@ -94,10 +94,10 @@
+ if (methodName.equals("equals") &&
+ params.length == 1 && params[0].equals(Object.class)) {
+ Object value = args[0];
+- if (value == null || ! Proxy.isProxyClass(value.getClass()))
++ if (value == null || ! java.lang.reflect.Proxy.isProxyClass(value.getClass()))
+ return new Boolean(false);
+
+- HessianProxy handler = (HessianProxy) Proxy.getInvocationHandler(value);
++ HessianProxy handler = (HessianProxy) java.lang.reflect.Proxy.getInvocationHandler(value);
+
+ return new Boolean(_url.equals(handler.getURL()));
+ }
diff --git a/dev-java/hessian/files/digest-hessian-3.0.8-r4 b/dev-java/hessian/files/digest-hessian-3.0.8-r4
new file mode 100644
index 000000000000..bbef2bfc8555
--- /dev/null
+++ b/dev-java/hessian/files/digest-hessian-3.0.8-r4
@@ -0,0 +1,3 @@
+MD5 de8cb0063ef400a2f0f98a42f3714e5a hessian-3.0.8-src.jar 184076
+RMD160 58fabf4adaf5fc508293c55a4451ab2dde48265a hessian-3.0.8-src.jar 184076
+SHA256 467163cb89ca6f40d8fd8ccafd1ca9c8e3a4d670529acbc53c0e0efe29c2cb1b hessian-3.0.8-src.jar 184076
diff --git a/dev-java/hessian/hessian-3.0.8-r4.ebuild b/dev-java/hessian/hessian-3.0.8-r4.ebuild
new file mode 100644
index 000000000000..dd78bc2aefe6
--- /dev/null
+++ b/dev-java/hessian/hessian-3.0.8-r4.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/hessian/hessian-3.0.8-r4.ebuild,v 1.1 2007/01/16 17:13:38 betelgeuse Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="The Hessian binary web service protocol makes web services usable without requiring a large framework, and without learning yet another alphabet soup of protocols."
+HOMEPAGE="http://www.caucho.com/hessian/"
+SRC_URI="http://www.caucho.com/hessian/download/${P}-src.jar"
+
+LICENSE="Apache-1.1"
+SLOT="3.0.8"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc source"
+
+COMMON_DEP="=dev-java/servletapi-2.3*
+ ~dev-java/caucho-services-${PV}"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ source? ( app-arch/zip )
+ dev-java/ant-core
+ ${COMMON_DEP}"
+
+src_unpack() {
+ mkdir -p ${P}/src
+ cd ${P}/src
+ unpack ${A}
+
+ # They package stuff from burlap in here
+ # Burlap is a separate protocol
+ rm -fr "${S}/src/com/caucho/burlap"
+ rm -fr "${S}/src/com/caucho/services"
+
+ cd "${S}"
+ epatch "${FILESDIR}/3.0.8-java5.patch"
+
+ # No included ant script! Bad Java developer, bad!
+ cp ${FILESDIR}/build-${PV}.xml build.xml
+
+ # Populate classpath
+ echo "classpath=$(java-pkg_getjars servletapi-2.3):$(java-pkg_getjars caucho-services-3.0)" >> build.properties
+}
+
+src_compile() {
+ eant -Dproject.name=${PN} jar $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dojavadoc dist/doc/api
+ use source && java-pkg_dosrc src/com
+}
diff --git a/dev-java/hessian/metadata.xml b/dev-java/hessian/metadata.xml
index dd8d2a5c5026..656536970396 100644
--- a/dev-java/hessian/metadata.xml
+++ b/dev-java/hessian/metadata.xml
@@ -3,9 +3,9 @@
<pkgmetadata>
<herd>java</herd>
<longdescription>
-The Hessian binary web service protocol makes web services usable without
-requiring a large framework, and without learning yet another alphabet soup
-of protocols. Because it is a binary protocol, it is well-suited to sending
+The Hessian binary web service protocol makes web services usable without
+requiring a large framework, and without learning yet another alphabet soup
+of protocols. Because it is a binary protocol, it is well-suited to sending
binary data without any need to extend the protocol with attachments.
</longdescription>
</pkgmetadata>