summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-29 21:01:53 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-29 21:01:53 +0000
commitb348ede4735eb41feb695a3998d5633a772bcef2 (patch)
tree4f3ae85f1bce9f0276925e4aa3c5b4fe4cf3d1f1 /dev-java/ibm-jdk-bin
parentThe directory needs to exist for older clients to prune the directory. (diff)
downloadgentoo-2-b348ede4735eb41feb695a3998d5633a772bcef2.tar.gz
gentoo-2-b348ede4735eb41feb695a3998d5633a772bcef2.tar.bz2
gentoo-2-b348ede4735eb41feb695a3998d5633a772bcef2.zip
Cleaned up plugin instalation, Moved some messages to the eclass, see #22395 for more information
Diffstat (limited to 'dev-java/ibm-jdk-bin')
-rw-r--r--dev-java/ibm-jdk-bin/ChangeLog7
-rw-r--r--dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild48
-rw-r--r--dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild48
3 files changed, 47 insertions, 56 deletions
diff --git a/dev-java/ibm-jdk-bin/ChangeLog b/dev-java/ibm-jdk-bin/ChangeLog
index bd605cad337c..60900289a8ba 100644
--- a/dev-java/ibm-jdk-bin/ChangeLog
+++ b/dev-java/ibm-jdk-bin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ibm-jdk-bin
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ChangeLog,v 1.15 2004/09/23 15:40:24 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ChangeLog,v 1.16 2004/09/29 20:59:27 axxo Exp $
+
+ 29 Sep 2004; Thomas Matthijs <axxo@gentoo.org>
+ ibm-jdk-bin-1.4.1-r2.ebuild, ibm-jdk-bin-1.4.2.ebuild:
+ Cleaned up plugin instalation, Moved some messages to the eclass, see #22395
+ for more information
23 Sep 2004; Thomas Matthijs <axxo@gentoo.org> -ibm-jdk-bin-1.4.1-r1.ebuild,
-ibm-jdk-bin-1.4.1.ebuild:
diff --git a/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild b/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild
index a523cfd31ba9..d751a3b3aad4 100644
--- a/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild
+++ b/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild
@@ -1,18 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild,v 1.8 2004/09/06 18:12:45 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.1-r2.ebuild,v 1.9 2004/09/29 20:59:27 axxo Exp $
-IUSE="X doc javacomm"
-
-inherit java nsplugins eutils
-
-if use ppc; then
- S="${WORKDIR}/IBMJava2-ppc-141"
-elif use ppc64; then
- S="${WORKDIR}/IBMJava2-ppc64-141"
-else
- S="${WORKDIR}/IBMJava2-141"
-fi
+inherit java eutils
DESCRIPTION="IBM Java Development Kit ${PV}"
SRC_URI="ppc? ( mirror://gentoo/IBMJava2-SDK-141.ppc.tgz )
@@ -34,8 +24,16 @@ DEPEND="virtual/libc
doc? ( =dev-java/java-sdk-docs-1.4.1* )
X? ( virtual/x11 )"
RDEPEND=" !ppc64? sys-libs/lib-compat"
+IUSE="X doc javacomm mozilla"
+
+if use ppc; then
+ S="${WORKDIR}/IBMJava2-ppc-141"
+elif use ppc64; then
+ S="${WORKDIR}/IBMJava2-ppc64-141"
+else
+ S="${WORKDIR}/IBMJava2-141"
+fi
-# No compilation needed!
src_compile() { :; }
src_install() {
@@ -50,11 +48,15 @@ src_install() {
if use ppc; then
dosed s:/proc/cpuinfo:/etc//cpuinfo:g /opt/${P}/jre/bin/libjitc.so
dosed s:/proc/cpuinfo:/etc//cpuinfo:g /opt/${P}/jre/bin/libjitc_g.so
- insinto ${D}/etc
+ insinto /etc
doins ${FILESDIR}/cpuinfo
- else
- # No java-plugin on ppc
- inst_plugin /opt/${P}/jre/bin/libjavaplugin_oji.so
+ fi
+ if use mozilla && ! use ppc; then
+ local plugin="libjavaplugin_oji.so"
+ if has_version '>=gcc-3*' ; then
+ plugin="libjavaplugin_ojigcc3.so"
+ fi
+ install_mozilla_plugin /opt/${P}/jre/bin/${plugin}
fi
dohtml -a html,htm,HTML -r docs
@@ -67,23 +69,13 @@ src_install() {
pkg_postinst() {
java_pkg_postinst
if ! use X; then
- einfo "********************************************************"
+ echo
eerror "You're not using X so its possible that you dont have"
eerror "a X server installed, please read the following warning: "
eerror "Some parts of IBM JDK require XFree86 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- einfo "********************************************************"
- echo
fi
- einfo " After installing ${P} this"
- einfo " was set as the default JVM to run."
- einfo " When finished please run the following so your"
- einfo " enviroment gets updated."
- eerror " /usr/sbin/env-update && source /etc/profile"
- einfo " Or use java-config program to set your preferred VM"
- einfo "******************************************************"
-
ebeep 5
epause 8
}
diff --git a/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild b/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild
index 8671044c1080..8c655d5a5b96 100644
--- a/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild
+++ b/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild
@@ -1,18 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild,v 1.10 2004/09/06 18:12:45 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ibm-jdk-bin/ibm-jdk-bin-1.4.2.ebuild,v 1.11 2004/09/29 20:59:27 axxo Exp $
-IUSE="X doc javacomm"
-
-inherit java nsplugins eutils
-
-if use ppc; then
- S="${WORKDIR}/IBMJava2-ppc-142"
-elif use ppc64; then
- S="${WORKDIR}/IBMJava2-ppc64-142"
-else
- S="${WORKDIR}/IBMJava2-142"
-fi
+inherit java eutils
DESCRIPTION="IBM Java Development Kit ${PV}"
SRC_URI="ppc? ( mirror://gentoo/IBMJava2-SDK-142.ppc.tgz )
@@ -35,7 +25,16 @@ DEPEND="virtual/libc
X? ( virtual/x11 )"
RDEPEND=" !ppc64? sys-libs/lib-compat"
-# No compilation needed!
+IUSE="X doc javacomm mozilla"
+
+if use ppc; then
+ S="${WORKDIR}/IBMJava2-ppc-142"
+elif use ppc64; then
+ S="${WORKDIR}/IBMJava2-ppc64-142"
+else
+ S="${WORKDIR}/IBMJava2-142"
+fi
+
src_compile() { :; }
src_install() {
@@ -52,9 +51,14 @@ src_install() {
dosed s:/proc/cpuinfo:/etc//cpuinfo:g /opt/${P}/jre/bin/libjitc_g.so
insinto /etc
doins ${FILESDIR}/cpuinfo
- else
- # No java-plugin on ppc
- inst_plugin /opt/${P}/jre/bin/libjavaplugin_oji.so
+ fi
+
+ if use mozilla && ! use ppc; then
+ local plugin="libjavaplugin_oji.so"
+ if has_version '>=gcc-3*' ; then
+ plugin="libjavaplugin_ojigcc3.so"
+ fi
+ install_mozilla_plugin /opt/${P}/jre/bin/${plugin}
fi
dohtml -a html,htm,HTML -r docs
@@ -67,23 +71,13 @@ src_install() {
pkg_postinst() {
java_pkg_postinst
if ! use X; then
- einfo "********************************************************"
+ echo
eerror "You're not using X so its possible that you dont have"
eerror "a X server installed, please read the following warning: "
eerror "Some parts of IBM JDK require XFree86 to be installed."
eerror "Be careful which Java libraries you attempt to use."
- einfo "********************************************************"
- echo
fi
- einfo " After installing ${P} this"
- einfo " was set as the default JVM to run."
- einfo " When finished please run the following so your"
- einfo " enviroment gets updated."
- eerror " /usr/sbin/env-update && source /etc/profile"
- einfo " Or use java-config program to set your preferred VM"
- einfo "******************************************************"
-
ebeep 5
epause 8
}