summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Sennhauser <sera@gentoo.org>2011-11-18 21:32:23 +0000
committerRalph Sennhauser <sera@gentoo.org>2011-11-18 21:32:23 +0000
commit93703cf6b0b91d6acfb6485d3d0650ec79be040d (patch)
tree37d0835eca2104587065aa8df09578b792c28d53 /dev-java/icedtea-bin
parentUpstream patch to support LT_PREREQ and LT_INIT libtool syntax. (diff)
downloadgentoo-2-93703cf6b0b91d6acfb6485d3d0650ec79be040d.tar.gz
gentoo-2-93703cf6b0b91d6acfb6485d3d0650ec79be040d.tar.bz2
gentoo-2-93703cf6b0b91d6acfb6485d3d0650ec79be040d.zip
Temporarely add PaX markings for x86
(Portage version: 2.1.10.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icedtea-bin')
-rw-r--r--dev-java/icedtea-bin/ChangeLog6
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild11
-rw-r--r--dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild11
3 files changed, 23 insertions, 5 deletions
diff --git a/dev-java/icedtea-bin/ChangeLog b/dev-java/icedtea-bin/ChangeLog
index c634f279a58e..f3d55162957d 100644
--- a/dev-java/icedtea-bin/ChangeLog
+++ b/dev-java/icedtea-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/icedtea-bin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.6 2011/11/18 20:27:58 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/ChangeLog,v 1.7 2011/11/18 21:32:23 sera Exp $
+
+ 18 Nov 2011; Ralph Sennhauser <sera@gentoo.org> icedtea-bin-6.1.10.4.ebuild,
+ icedtea-bin-7.2.0-r1.ebuild:
+ Temporarely add PaX markings for x86
18 Nov 2011; Vlastimil Babka <caster@gentoo.org> icedtea-bin-7.2.0-r1.ebuild:
Update deps to match scanelf results more closely, fix #390945.
diff --git a/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild b/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild
index 29265e78b56d..aa8f86dcecc0 100644
--- a/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild
+++ b/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild,v 1.2 2011/11/08 23:47:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-6.1.10.4.ebuild,v 1.3 2011/11/18 21:32:23 sera Exp $
EAPI="4"
-inherit java-vm-2
+inherit java-vm-2 pax-utils
dist="http://dev.gentoo.org/~caster/distfiles/"
DESCRIPTION="A Gentoo-made binary build of the Icedtea6 JDK"
@@ -68,6 +68,13 @@ src_install() {
# doins can't handle symlinks.
cp -pRP bin include jre lib man "${ddest}" || die "failed to copy"
+ # Remove on next bump as the needed marks are already set by icedtea ebuild.
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ local marks="m"
+ use x86 && marks="msp"
+ pax-mark ${marks} $(list-paxables "${ddest}"{,/jre}/bin/*)
+
dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README}
if use doc ; then
dohtml -r ../doc/html/*
diff --git a/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild b/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild
index 51d549b8057c..7b0cd900ea77 100644
--- a/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild
+++ b/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild,v 1.2 2011/11/18 20:27:58 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icedtea-bin/icedtea-bin-7.2.0-r1.ebuild,v 1.3 2011/11/18 21:32:23 sera Exp $
EAPI="4"
-inherit java-vm-2
+inherit java-vm-2 pax-utils
dist="http://dev.gentoo.org/~caster/distfiles/"
DESCRIPTION="A Gentoo-made binary build of the Icedtea6 JDK"
@@ -68,6 +68,13 @@ src_install() {
# doins can't handle symlinks.
cp -pRP bin include jre lib man "${ddest}" || die "failed to copy"
+ # Remove on next bump as the needed marks are already set by icedtea ebuild.
+ # Set PaX markings on all JDK/JRE executables to allow code-generation on
+ # the heap by the JIT compiler.
+ local marks="m"
+ use x86 && marks="msp"
+ pax-mark ${marks} $(list-paxables "${ddest}"{,/jre}/bin/*)
+
dodoc ../doc/{ASSEMBLY_EXCEPTION,THIRD_PARTY_README}
if use doc ; then
dohtml -r ../doc/html/*