summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-05-16 22:21:03 +0000
committerVlastimil Babka <caster@gentoo.org>2009-05-16 22:21:03 +0000
commit89ea6d10610ba2e4c061d0296294d75c311229ea (patch)
tree7ebad8ec7caf2bfe28ff50cfaba7c6985a881b08 /dev-java/icu4j
parentVersion bump. (diff)
downloadgentoo-2-89ea6d10610ba2e4c061d0296294d75c311229ea.tar.gz
gentoo-2-89ea6d10610ba2e4c061d0296294d75c311229ea.tar.bz2
gentoo-2-89ea6d10610ba2e4c061d0296294d75c311229ea.zip
Version bump, bug #256242, new slot. Drop osgi for now, until it's needed. Restrict tests.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/icu4j')
-rw-r--r--dev-java/icu4j/ChangeLog8
-rw-r--r--dev-java/icu4j/icu4j-4.2.ebuild74
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index 9480ea9ecca7..66acb2f28bfc 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icu4j
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.30 2009/05/16 19:11:20 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.31 2009/05/16 22:21:03 caster Exp $
+
+*icu4j-4.2 (16 May 2009)
+
+ 16 May 2009; Vlastimil Babka <caster@gentoo.org> +icu4j-4.2.ebuild:
+ Version bump, bug #256242, new slot. Drop osgi for now, until it's needed.
+ Restrict tests.
*icu4j-4.0.1 (16 May 2009)
diff --git a/dev-java/icu4j/icu4j-4.2.ebuild b/dev-java/icu4j/icu4j-4.2.ebuild
new file mode 100644
index 000000000000..83f9f5ae2777
--- /dev/null
+++ b/dev-java/icu4j/icu4j-4.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-4.2.ebuild,v 1.1 2009/05/16 22:21:03 caster Exp $
+
+EAPI=2
+
+# We currently download the Javadoc documentation.
+# It could optionally be built using the Ant build file.
+# testdata.jar and icudata.jar do not contain *.class files but *.res files
+# These *.res data files are needed to built the final jar
+# They do not need to be installed however as they will already be present in icu4j.jar
+
+JAVA_PKG_IUSE="doc test source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support."
+MY_PV=${PV//./_}
+
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-src.jar
+ doc? ( http://download.icu-project.org/files/${PN}/${PV}/${PN}-${MY_PV}-docs.jar )"
+
+HOMEPAGE="http://www.icu-project.org/"
+LICENSE="icu"
+SLOT="4.2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+
+# there's some test that limit its run to 10s and fails
+RESTRICT="test"
+
+# Tests only work with JDK-1.6, severe out of memory problems appear with 1.5
+DEPEND="test? ( =virtual/jdk-1.6* )
+ !test? ( >=virtual/jdk-1.4 )
+ app-arch/unzip"
+
+RESTRICT="ia64? ( test )
+ x86-fbsd? ( test )"
+JAVA_PKG_WANT_SOURCE="1.4"
+JAVA_PKG_WANT_TARGET="1.4"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-src.jar" || die "Failed to unpack"
+
+ if use doc; then
+ mkdir docs; cd docs
+ jar -xf "${DISTDIR}/${PN}-${MY_PV}-docs.jar" || die "Failed to unpack docs"
+ fi
+}
+
+src_compile() {
+ # Classes extending CharsetICU not implementing Comparable
+ # Breaks with ecj on jdk 1.5+, javac doesn't mind - Sun's hack?
+ # Restricting to javac (didn't even care to try jikes) is better
+ # than forcing 1.4
+ java-pkg_force-compiler javac
+ eant jar || die "Compile failed"
+}
+
+src_install() {
+ java-pkg_dojar "${PN}.jar"
+ java-pkg_dojar "${PN}-charsets.jar"
+
+ use doc && dohtml -r readme.html docs/*
+ use source && java-pkg_dosrc src/*
+}
+
+src_test() {
+ eant check
+}