summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-09 15:25:48 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-09 15:25:48 +0000
commit8e71cd1371696f7c78d345278fcb686705a212e2 (patch)
treeb1b7a61a95140780583a261392baf67acfd90aaf /dev-java/iso-relax/iso-relax-20050331-r1.ebuild
parentfix 139708 (diff)
downloadgentoo-2-8e71cd1371696f7c78d345278fcb686705a212e2.tar.gz
gentoo-2-8e71cd1371696f7c78d345278fcb686705a212e2.tar.bz2
gentoo-2-8e71cd1371696f7c78d345278fcb686705a212e2.zip
Migrated to generation 2.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'dev-java/iso-relax/iso-relax-20050331-r1.ebuild')
-rw-r--r--dev-java/iso-relax/iso-relax-20050331-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-java/iso-relax/iso-relax-20050331-r1.ebuild b/dev-java/iso-relax/iso-relax-20050331-r1.ebuild
new file mode 100644
index 000000000000..79baaf6c82fb
--- /dev/null
+++ b/dev-java/iso-relax/iso-relax-20050331-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/iso-relax/iso-relax-20050331-r1.ebuild,v 1.1 2006/07/09 15:25:48 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Interfaces useful for applications which support RELAX Core"
+HOMEPAGE="http://iso-relax.sourceforge.net"
+SRC_URI="mirror://gentoo/${P}-gentoo.tar.bz2"
+
+# To get the build system:
+# cvs -d:pserver:anonymous@iso-relax.cvs.sourceforge.net:/cvsroot/iso-relax login
+# mkdir iso-relax-20050331
+# cd iso-relax-20050331
+# cvs -d:pserver:anonymous@iso-relax.cvs.sourceforge.net:/cvsroot/iso-relax -frelease-20050331 co build.xml lib
+# rm -r $(find -name CVS)
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="source"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+PATCHES="${FILESDIR}/${P}-build.patch"
+
+src_compile() {
+ eant release || die "ant failed"
+}
+
+src_install() {
+ java-pkg_dojar isorelax.jar
+ use source && java-pkg_dosrc src
+}