summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2010-02-23 23:01:11 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2010-02-23 23:01:11 +0000
commitd29ea9ab4a2be590b77014d2720b7917f3162450 (patch)
treed72a0f7531ec4dc50b752c099c92ed65c8a1afef /dev-java/jdbc-postgresql
parentVersion bump, security bug #306583. (diff)
downloadgentoo-2-d29ea9ab4a2be590b77014d2720b7917f3162450.tar.gz
gentoo-2-d29ea9ab4a2be590b77014d2720b7917f3162450.tar.bz2
gentoo-2-d29ea9ab4a2be590b77014d2720b7917f3162450.zip
Version bump.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jdbc-postgresql')
-rw-r--r--dev-java/jdbc-postgresql/ChangeLog8
-rw-r--r--dev-java/jdbc-postgresql/jdbc-postgresql-8.4_p701.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-java/jdbc-postgresql/ChangeLog b/dev-java/jdbc-postgresql/ChangeLog
index f09bde37543b..66f08cb793dc 100644
--- a/dev-java/jdbc-postgresql/ChangeLog
+++ b/dev-java/jdbc-postgresql/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jdbc-postgresql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.33 2010/02/12 08:50:46 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/ChangeLog,v 1.34 2010/02/23 23:01:11 nelchael Exp $
+
+*jdbc-postgresql-8.4_p701 (23 Feb 2010)
+
+ 23 Feb 2010; Krzysiek Pawlik <nelchael@gentoo.org>
+ +jdbc-postgresql-8.4_p701.ebuild:
+ Version bump.
12 Feb 2010; Vlastimil Babka <caster@gentoo.org>
jdbc-postgresql-8.3_p603.ebuild:
diff --git a/dev-java/jdbc-postgresql/jdbc-postgresql-8.4_p701.ebuild b/dev-java/jdbc-postgresql/jdbc-postgresql-8.4_p701.ebuild
new file mode 100644
index 000000000000..ef224262d225
--- /dev/null
+++ b/dev-java/jdbc-postgresql/jdbc-postgresql-8.4_p701.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdbc-postgresql/jdbc-postgresql-8.4_p701.ebuild,v 1.1 2010/02/23 23:01:11 nelchael Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_PN="postgresql-jdbc"
+MY_PV="${PV/_p/-}"
+MY_P="${MY_PN}-${MY_PV}.src"
+
+DESCRIPTION="JDBC Driver for PostgreSQL"
+SRC_URI="http://jdbc.postgresql.org/download/${MY_P}.tar.gz"
+HOMEPAGE="http://jdbc.postgresql.org/"
+
+LICENSE="POSTGRESQL"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="java6 test"
+
+DEPEND=">=dev-java/java-config-2.0.31
+ java6? ( =virtual/jdk-1.6* )
+ !java6? ( =virtual/jdk-1.5* )
+ doc? (
+ dev-libs/libxslt
+ app-text/docbook-xsl-stylesheets
+ )
+ test? (
+ dev-java/ant-junit
+ virtual/postgresql-server
+ )"
+RDEPEND="java6? ( >=virtual/jre-1.6 )
+ !java6? ( >=virtual/jre-1.5 )"
+
+S="${WORKDIR}/${MY_P}"
+
+EANT_DOC_TARGET="publicapi"
+
+java_prepare() {
+ # needed for src_test
+ java-ant_rewrite-classpath
+}
+
+src_compile() {
+ java-pkg-2_src_compile
+
+ # There is a task that creates this doc but I didn't find a way how to use system catalog
+ # to lookup the stylesheet so the 'doc' target is rewritten here to use system call instead.
+ if use doc; then
+ mkdir -p "${S}/build/doc"
+ xsltproc -o "${S}/build/doc/pgjdbc.html" http://docbook.sourceforge.net/release/xsl/current/xhtml/docbook.xsl \
+ "${S}/doc/pgjdbc.xml"
+ fi
+}
+
+src_test() {
+ einfo "In order to run the tests successfully, you have to have:"
+ einfo "1) PostgreSQL server running"
+ einfo "2) database 'test' defined with user 'test' with password 'password'"
+ einfo " as owner of the database"
+ einfo "3) plpgsql support in the 'test' database"
+ einfo
+ einfo "You can find a general info on how to perform these steps at"
+ einfo "http://gentoo-wiki.com/HOWTO_Configure_Postgresql"
+
+ ANT_TASKS="ant-junit" eant test -Dgentoo.classpath=$(java-pkg_getjars --build-only junit)
+}
+
+src_install() {
+ java-pkg_newjar jars/postgresql.jar jdbc-postgresql.jar
+
+ if use doc ; then
+ java-pkg_dojavadoc build/publicapi
+ dohtml build/doc/pgjdbc.html || die
+ fi
+
+ use source && java-pkg_dosrc org
+}