summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2007-03-16 20:47:35 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2007-03-16 20:47:35 +0000
commit1444f41e20b6c72651668e297186c1a9918f6d8a (patch)
tree3aef7bc4ab44da631de765836802c52678ba0821 /dev-java/jexcelapi
parentadd 'CVS' ebuild (diff)
downloadgentoo-2-1444f41e20b6c72651668e297186c1a9918f6d8a.tar.gz
gentoo-2-1444f41e20b6c72651668e297186c1a9918f6d8a.tar.bz2
gentoo-2-1444f41e20b6c72651668e297186c1a9918f6d8a.zip
Version bump.
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-java/jexcelapi')
-rw-r--r--dev-java/jexcelapi/ChangeLog7
-rw-r--r--dev-java/jexcelapi/files/digest-jexcelapi-2.6.33
-rw-r--r--dev-java/jexcelapi/jexcelapi-2.6.3.ebuild47
3 files changed, 56 insertions, 1 deletions
diff --git a/dev-java/jexcelapi/ChangeLog b/dev-java/jexcelapi/ChangeLog
index 5df0efb8bea5..545e116bb881 100644
--- a/dev-java/jexcelapi/ChangeLog
+++ b/dev-java/jexcelapi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jexcelapi
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.6 2007/02/10 00:18:45 fordfrog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/ChangeLog,v 1.7 2007/03/16 20:47:35 fordfrog Exp $
+
+*jexcelapi-2.6.3 (16 Mar 2007)
+
+ 16 Mar 2007; Miroslav Šulc <fordfrog@gentoo.org> +jexcelapi-2.6.3.ebuild:
+ Version bump.
*jexcelapi-2.6.2 (10 Feb 2007)
diff --git a/dev-java/jexcelapi/files/digest-jexcelapi-2.6.3 b/dev-java/jexcelapi/files/digest-jexcelapi-2.6.3
new file mode 100644
index 000000000000..76e206a38a23
--- /dev/null
+++ b/dev-java/jexcelapi/files/digest-jexcelapi-2.6.3
@@ -0,0 +1,3 @@
+MD5 6774ef87a3cdc38f8c3bb11579142ad6 jexcelapi_2_6_3.tar.gz 1672432
+RMD160 9a3fd399faf05e7b01c1960dc308a9cacc337bc1 jexcelapi_2_6_3.tar.gz 1672432
+SHA256 6738eb86078336566cb41222fc09a6e7a2e0e8166ab9cc3ed8842aaf157c84a6 jexcelapi_2_6_3.tar.gz 1672432
diff --git a/dev-java/jexcelapi/jexcelapi-2.6.3.ebuild b/dev-java/jexcelapi/jexcelapi-2.6.3.ebuild
new file mode 100644
index 000000000000..67bf70717f0d
--- /dev/null
+++ b/dev-java/jexcelapi/jexcelapi-2.6.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jexcelapi/jexcelapi-2.6.3.ebuild,v 1.1 2007/03/16 20:47:35 fordfrog Exp $
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+MY_P="${P//-/_}"
+MY_P="${MY_P//./_}"
+
+DESCRIPTION="A Java API to read, write, and modify Excel spreadsheets"
+HOMEPAGE="http://jexcelapi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/jexcelapi/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2.5"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ rm -rf jxl.jar docs
+
+ # sun-jdk-1.5/jikes fails
+ java-pkg_filter-compiler jikes
+}
+
+src_compile() {
+ eant -f build/build.xml jxl $(use_doc docs)
+}
+
+src_install() {
+ java-pkg_newjar jxl.jar ${PN}.jar
+
+ java-pkg_dohtml index.html tutorial.html
+ use doc && java-pkg_dojavadoc docs
+ use source && java-pkg_dosrc ${S}/src/*
+}