summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-12-25 21:15:11 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-12-25 21:15:11 +0000
commit4b865713bdd6f42b851a2bb0cd17e2ac0509dca1 (patch)
tree0dbcb83b86cf869375c81abd80ff1affa6f59616 /dev-java/jgrapht
parentdev-java/proguard: version bump (diff)
downloadgentoo-2-4b865713bdd6f42b851a2bb0cd17e2ac0509dca1.tar.gz
gentoo-2-4b865713bdd6f42b851a2bb0cd17e2ac0509dca1.tar.bz2
gentoo-2-4b865713bdd6f42b851a2bb0cd17e2ac0509dca1.zip
dev-java/jgrapht: version bump
(Portage version: 2.1.10.43/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jgrapht')
-rw-r--r--dev-java/jgrapht/ChangeLog8
-rw-r--r--dev-java/jgrapht/files/DOTExporter-nullpointer.patch36
-rw-r--r--dev-java/jgrapht/jgrapht-0.8.2.ebuild49
3 files changed, 92 insertions, 1 deletions
diff --git a/dev-java/jgrapht/ChangeLog b/dev-java/jgrapht/ChangeLog
index ce4ab9c46a3b..44f8f48b66bc 100644
--- a/dev-java/jgrapht/ChangeLog
+++ b/dev-java/jgrapht/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/jgrapht
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgrapht/ChangeLog,v 1.6 2011/01/23 17:03:27 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgrapht/ChangeLog,v 1.7 2011/12/25 21:15:11 fordfrog Exp $
+
+*jgrapht-0.8.2 (25 Dec 2011)
+
+ 25 Dec 2011; Miroslav Šulc <fordfrog@gentoo.org> +jgrapht-0.8.2.ebuild,
+ +files/DOTExporter-nullpointer.patch:
+ Version bump (thanks to Elliott Rezny <erezny@gmail.com> for the ebuild)
23 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org> jgrapht-0.7.3.ebuild:
Mark ~ppc wrt #301239
diff --git a/dev-java/jgrapht/files/DOTExporter-nullpointer.patch b/dev-java/jgrapht/files/DOTExporter-nullpointer.patch
new file mode 100644
index 000000000000..5c7b0ee2250a
--- /dev/null
+++ b/dev-java/jgrapht/files/DOTExporter-nullpointer.patch
@@ -0,0 +1,36 @@
+--- src/org/jgrapht/ext/DOTExporter.java 2010-11-27 23:36:27.000000000 -0600
++++ DOTExporter.java 2011-12-07 21:06:03.041369519 -0600
+@@ -152,7 +152,7 @@
+ if (vertexLabelProvider != null) {
+ labelName = vertexLabelProvider.getVertexName(v);
+ }
+- Map<String, String> attributes = null;
++ Map<String, String> attributes = new HashMap<String, String>();;
+ if (vertexAttributeProvider != null) {
+ attributes = vertexAttributeProvider.getComponentAttributes(v);
+ }
+@@ -200,14 +200,16 @@
+ if (labelName != null) {
+ out.print("label=\"" + labelName + "\" ");
+ }
+- for (Map.Entry<String, String> entry : attributes.entrySet()) {
+- String name = entry.getKey();
+- if (name.equals("label")) {
+- // already handled by special case above
+- continue;
+- }
+- out.print(name + "=\"" + entry.getValue() + "\" ");
+- }
++ if (attributes != null) {
++ for (Map.Entry<String, String> entry : attributes.entrySet()) {
++ String name = entry.getKey();
++ if (name.equals("label")) {
++ // already handled by special case above
++ continue;
++ }
++ out.print(name + "=\"" + entry.getValue() + "\" ");
++ }
++ }
+ out.print("]");
+ }
+
diff --git a/dev-java/jgrapht/jgrapht-0.8.2.ebuild b/dev-java/jgrapht/jgrapht-0.8.2.ebuild
new file mode 100644
index 000000000000..fabac9640cbf
--- /dev/null
+++ b/dev-java/jgrapht/jgrapht-0.8.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgrapht/jgrapht-0.8.2.ebuild,v 1.1 2011/12/25 21:15:11 fordfrog Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Graph library that is a simpler and faster alternative to JGraph"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://jgrapht.sourceforge.net"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+IUSE="test"
+
+CDEPEND="dev-java/touchgraph-graphlayout:0
+ dev-java/jgraph:0"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6
+ test? ( dev-java/ant-junit
+ dev-java/xmlunit:1 )"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="touchgraph-graphlayout jgraph"
+EANT_DOC_TARGET="javadoc"
+
+java_prepare() {
+ rm -rf "${S}/lib" || die
+ rm -v "${S}"/*.jar || die
+ epatch "${FILESDIR}"/DOTExporter-nullpointer.patch
+}
+
+src_install() {
+ java-pkg_newjar ${PN}*.jar || die
+
+ dohtml README.html || die
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/org
+}
+
+src_test() {
+ EANT_GENTOO_CLASSPATH="${EANT_GENTOO_CLASSPATH} xmlunit:1" ANT_TASKS="ant-junit" eant test
+}