summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-08-05 17:04:05 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-08-05 17:04:05 +0000
commitf2c3217d4d30973555b2331afa8d81a8d4c863f3 (patch)
tree4706be3cf96e064109ee4b6001aa452c3c2aba09 /dev-java/jrexx/jrexx-1.1.1-r1.ebuild
parentRevision bump to support new Java system. (diff)
downloadgentoo-2-f2c3217d4d30973555b2331afa8d81a8d4c863f3.tar.gz
gentoo-2-f2c3217d4d30973555b2331afa8d81a8d4c863f3.tar.bz2
gentoo-2-f2c3217d4d30973555b2331afa8d81a8d4c863f3.zip
Revision bump to support new Java system
(Portage version: 2.1.1_pre4-r2)
Diffstat (limited to 'dev-java/jrexx/jrexx-1.1.1-r1.ebuild')
-rw-r--r--dev-java/jrexx/jrexx-1.1.1-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-java/jrexx/jrexx-1.1.1-r1.ebuild b/dev-java/jrexx/jrexx-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..fd431b9dd7b4
--- /dev/null
+++ b/dev-java/jrexx/jrexx-1.1.1-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jrexx/jrexx-1.1.1-r1.ebuild,v 1.1 2006/08/05 17:04:05 nichoj Exp $
+
+inherit java-pkg-2
+
+DESCRIPTION="Regular expression API for textual pattern matching based on the finite state automaton theory."
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+HOMEPAGE="http://www.karneim.com/jrexx/"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ source? ( app-arch/zip )"
+IUSE="doc source"
+S=${WORKDIR}
+
+src_compile() {
+ mkdir build
+
+ cd src
+ javac $(java-pkg_javac-args) -nowarn -d ${S}/build $(find -name "*.java") \
+ || die "Failed to compile ${i}"
+
+ if use doc ; then
+ mkdir ${S}/javadoc
+ javadoc -d ${S}/javadoc $(find * -type d | tr '/' '.') \
+ || die "failed to build javadocs"
+ fi
+
+ cd ..
+ jar cf ${PN}.jar -C build com || die "failed to create jar"
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ use doc && java-pkg_dohtml -r javadoc
+ use source && java-pkg_dosrc src/*
+}