summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2004-12-03 21:31:32 +0000
committerDon Seiler <rizzo@gentoo.org>2004-12-03 21:31:32 +0000
commit989ddf5a62ecee6edda2bbd27673c3b5f81b78d8 (patch)
tree640c267ec5712f775fe2db09a0236e19b7193b0e /dev-java/spin/spin-1.3.1.ebuild
parentInherit kde-functions and fix #73252. (Manifest recommit) (diff)
downloadgentoo-2-989ddf5a62ecee6edda2bbd27673c3b5f81b78d8.tar.gz
gentoo-2-989ddf5a62ecee6edda2bbd27673c3b5f81b78d8.tar.bz2
gentoo-2-989ddf5a62ecee6edda2bbd27673c3b5f81b78d8.zip
Initial add
Diffstat (limited to 'dev-java/spin/spin-1.3.1.ebuild')
-rw-r--r--dev-java/spin/spin-1.3.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/spin/spin-1.3.1.ebuild b/dev-java/spin/spin-1.3.1.ebuild
new file mode 100644
index 000000000000..38768e0afc19
--- /dev/null
+++ b/dev-java/spin/spin-1.3.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/spin/spin-1.3.1.ebuild,v 1.1 2004/12/03 21:31:32 rizzo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Spin is a transparent threading solution for non-freezing Swing applications."
+HOMEPAGE="http://spin.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="dev-java/ant"
+#RDEPEND=""
+S=${WORKDIR}
+
+IUSE="doc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i 's:${java.home}/src::' -i build.xml
+}
+
+src_compile() {
+ ant || die "failed to build"
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use doc && java-pkg_dohtml -r ${S}/docs/api/*
+}
+